Error Code 0F00:1332 - General Hardware - Laptop - Dell Community

Error Code 0F00:1332


Laptop computer Forums (Audio, General Hardware, Video)

Error Code 0F00:1332

This question has been answered by SpeedStep


I've recently had a problem with my laptop which is a Dell Inspiron 1545. I'm running windows 7 and it's about 1.5 years old.

When i try to boot the machine it goes to the 'Windows Error Recovery' Screen with the option of 'Load windows normally' or 'Launch Startup Repair (Recommended)'. When i choose launch startup repair it says 'Startup Repair cannot repair this computer automatically'. However if i choose 'start windows normally' it goes to the windows startup screen with the light which form the 'windows flag' then flashes a blue screen with white writing (it flashes too fast to be able to read the writing) and then goes back the the dell startup screen which comes up when you initially start the machine, and back onto the screen with the options of starting windows normally or launch startup repeair. The cycle continues.

I've tried running in safe mode but as its 'Loading Windows Files' it stops at 'CLASSPNP.SYS' then the blue screen flashes again into the boot cycle!

I've also run the diagnostic software and came across 'Error Code: 0F00:1332, Msg Disk - Block 99840578: Interrupt Request(IRQ) did not set in time.


I'm not so worried about losing the data on my computer as ive been able to use an 'UBUNTU' boot cd to transfer the important files to an external harddrive. What would be the best option to go about fixing this?


Any help would be hugely appreciated ^_^

Cheers, Chris

Verified Answer
All Replies
  • Replace the faulty hard drive with a new one -- then reload WIndows.

  • ok, so there is no chance of using the faulty hardrive? I was planning on buying a new laptop at the end of the year so i'd rather not spend the money on getting a new one if its will only be for 5 months. Would reinstalling windows on the faulty harddrive do anything?

    Thanks for the quick reply!


    The drive is bad and will only get worse.

    Momentus 250GB 5,400 RPM SATA 3.0Gb/s 2.5" Internal Hard Drive ST90250N1A1AS-RK  $50

    Manufacturer Warranty
    Parts 5 years
    Labor 5 years

    Micro Center - Seagate Momentus 250GB 5400 RPM SATA 3.0Gb/s 2.5 ...

    Report Unresolved Customer Service Issues here
    I do not work for Dell. I too am a user.
    The forum is primarily user to user, with Dell employees moderating
    Contact USA Technical Support

    Get Support on Twitter @DellCaresPro

  • Thanks for that. That's pretty affordable and will make a good replacement until i get a new one.

  • Hello,

    I too had the same problem, but along with it my laptop wont start for a week and then again it comes to normal function mode.  i did format it and have hardly any new things installed.  I really wonder whether there is a problem with the hard disk or the motherboard.

  • I'm working on a Vostro 220s with the same error. Dell sent me a new WD hard drive and I'm still getting the same diagnostic errors with the new drive. I also can't get through the restore CD windows setup. It fails with a blue screen.  There's something wrong with the motherboard. Linux live cds sometimes take an extra long time to initialize hardware on this machine. When they do boot, it takes an extra long time to show folder contents and move files around.

  • I have the same message in a Dell Inspiron Net book that was purchased 1.5 years ago directly from Sprint. Do you have any idea what Hard Drive is in my machine and is it possible to change the hard drive in this machine?

  • Which model netbook?  

  • Likewise, I have a Vostro 1520 w/ same codes.  However, I pulled the WD drive out and connected to my other desktop and ran ChkDsk and Defrag utilities on it with no issue.  This leads me to believe I likely have other issues (motherboard?) in the Vostro laptop.  Thoughts?

  • I have an Inspiron 570 desktop machine and I'm getting the same error when I run Dell Diagnostics.  However ChkDsk doesn't show any errors. I don't think that it would, because it checks the surface of the disk Indexes, Tables, Files.  The problem is with the IRQ not setting in time which may be related to mechanical functions of the disk (random read/write etc) which ChkDsk and Defrag do not test.


    Likewise, I have a Vostro 1520 w/ same codes.  However, I pulled the WD drive out and connected to my other desktop and ran ChkDsk and Defrag utilities on it with no issue.  This leads me to believe I likely have other issues (motherboard?) in the Vostro laptop.  Thoughts?

  • This post was quite a while ago, but a question anyway.  I'm getting the Error Code 1332 and am concerned about losing pics/files.  What is 'UBUNTU' boot cd and where do i get one?  Do you think it will help me save my files as well?

  • Speedstep,

    I have an Dell Inspiron N5010 stuck in a boot loop with the Dell logo.  I F12 into Diagnostics, went through the Memory and Extended hardware diagnostic test.  Came up with several Error Code: 1332.  I thought i surfed over one of your posts saying there was a i mistaken?  Also, my wife and i have tons of pics, files on the laptop.  Are they not recoverable?  

    Another dell user with similar Error Code problem used an 'UBUNTU' boot cd to recover files.  What is that? Will that work?

  • Ubuntu is a distribution of Linux. As Linux goes, it is one of the easier to use versions. You can get a "LiveCD" of ubuntu from Despite the name, you can install it either to a CD, DVD, or even a USB stick. You may have to go into your system BIOS (F2 on most dells) and change the boot order (put the device on top of the list) in order to get it to run.

    It should automount your harddrive and whatever other media (e.g. usb stick) you're using to back it up and allow you to copy the files over to later put on a new computer.

    There are other CD/USB boot stick options available. I like YUMI as you can have a stick with multiple options on it. Anything that allows you to see your files and copy to a new drive will work, but it will take a little "boning up" to use them properly.