Hey everyone,

 

So about a month ago, my Dell Latitude D630 started flashing me a message in the bottom right hand corner of my screen.  It said something like "Your battery is able to charge normally, but is reaching the end of its usable life."  So I figured, ok time to replace it in a little while.  Long story short, I go on vacation this week, and I shut my computer down before I leave.  I have shut my laptop down/hibernated/standby'ed it many times previously in the last few months with no such problem. 

The laptop was off for about 4 days, and when I came home Saturday and tried to turn it on I got very little response.  My 4 light panel by my bottom right of the screen (From left to right; Power, usage, charge, wireless) displays the following sequence.  When I push the power button, the power light turns on, but no noise is made in the computer, nor is there any reaction on screen and whatnot.  After about 3 seconds the power icon deilluminates and my wireless light flashes and then deilluminates, followed finally by my ac/charging light.  Then the computer goes back to doing nothing.  I have tried powering it on with no ac adaptor attached, without the battery in (just plugged in), and a few other equally unsuccessful methods. 

So finally, after the backstory here is my question.  Is anyone able to tell me if this is just my battery?  I'm not sure why it would be if my computer is still unable to power on without it in place, but I'm just hoping for some direction.  The message I was getting for the last month or two regarding my batteries demise gives me hope that it is the problem, but I'm not sure.  If I can explain anything better to help someone give me direction please let me know.  Appreciate everyone's time on this matter.  I am running Windows Vista.