Dell XPS 15 (L502X) Webcam Won't Work!

Laptop

Laptop
Laptop computer Hardware and Software discussion

Dell XPS 15 (L502X) Webcam Won't Work!

This question has suggested answer(s)

     Received my Dell XPS 15 (L502X) back in mid-March, everything was working great (even the webcam).  Re-installed Dell Win 7 Pro 64-bit to remove bloatware and upon installing all drivers, the Device Manager shows a USB-connection error conflict.  All drivers, Windows updates and programs installed successfully except for the webcam.  Installed Dell WEBCAM Central software and it's saying "no webcam detected" and it's asking me to plug in a webcam. Also, I followed the correct sequence to installing all driver categories as per Dell's instructions below:

http://support.dell.com/support/topics/global.aspx/support/kcs/document?c=us&docid=268873&l=en&s=gen

 

     The only issue I can conclude is that the incompatibility is due to the BIOS update I installed (revision A04) upon receiving the notebook.  Checking the version of the Quanta  H264 Webcam Driver, it currently shows 1.0.1404.1005, A00.  I didn't opt for the fancy-pants designer LCD so I don't think it's a physical connection issue. (could be wrong though)

 

    I tried "scanning for hardware changes" and "auto-installing best available software" from Device Manager but still no dice. 

Help!

All Replies
  • accordboy23,

     

    Try...

     

    start, control panel, programs and features, Dell webcam Central, uninstall.

     

    Restart your computer.

     

    Download Dell Webcam Central v2.00.39 and follow the instructions located at Installing Dell Webcam Central

     

     

    Rick

    #DellRockStar

    What is a Dell Service Tag and how do I locate it? 

     

     

    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

  • Rick,

       Yep, I uninstalled the v 1.3 Dell Webcam Central software, rebooted and installed v. 2.00.39 flavor. (Installed in C:\Program Files, not Program Files\(x86)) Still has the same problem.  I even updated the BIOS to the most recent release (A05).  I also tried uninstalling the USB 3.0 host controller (Renesas) and re-installed the Quanta H264 webcam driver (and then re-installed the USB 3.0 host controller driver after) to see if it was the priority of the USB driver installation that mattered.  Could it be a setting in the BIOS or something?

  •  accordboy23,

     

    Did you recently install the operating system?

     

     

    Rick

    #DellRockStar

    What is a Dell Service Tag and how do I locate it? 

     

     

    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

  • Here is what I have done since receiving the XPS 15 (L502X)

    1.) Received it - Tested & confirmed computer works (even tested the webcam successfully)

    2.) Re-installed Win 7 64-bit via my OEM Dell Win 7 64-bit disc to wipe out bloatware

    3.) Downloaded new BIOS (revision A04 at the time) and successfully installed

    4.) Downloaded & installed necessary drivers and Windows Updates - All successfully installed except webcam (USB Controllers - Unknown Device)

    5.) Downloaded & successfully installed newer revision A05 BIOS

    6.) Un-installed Dell Webcam Central software (1.3), rebooted and installed v2.00.39 (installed under Program Files, not Program  Files (x86))

    7.) Un-installed USB 3 Host Controller (Renesas) & re-installed Quanta H264 Webcam Driver, then re-installed USB 3 Host Controller driver

    8.) Issue still persists.....

  •  accordboy23,

     

    Sorry for the delay, work.

    accordboy23

    2.) Re-installed Win 7 64-bit via my OEM Dell Win 7 64-bit disc to wipe out bloatware

     

    When you installed Windows 7 (32-bit or 64-bit) did you install the desktop/notebook utility and the chipset drivers first? If not the rest of the drivers will fail to install. How to Download and Install Drivers in the Correct Order If you cannot find Windows 7 drivers, then try using the Vista (or XP) 32-bit drivers, for Windows 7 32-bit of the Vista (or XP) 64-bit drivers for Windows 7 64-bit and install the drivers in the Compatibility mode

     

     

    Rick

    #DellRockStar

    What is a Dell Service Tag and how do I locate it? 

     

     

    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

  •    If you completely read my very first post, it specifically says I installed the drivers in the correct order as per the Dell link you posted. (which I also posted the same link) Also, as I said in earlier posts, I did find ALL Win 7 64-bit drivers and they all successfully installed; the webcam is the only device that is not being recognized by Dell Webcam Central and is showing as an UNKNOWN DEVICE conflict in the Device Manager.

  •  accordboy23,

     

    Go to device manager and uninstall the unknown device, then restart your computer. The new hardware wizard will locate the device and if the drivers are there, will install it.

    Similar to this image.

     

     

    Rick

    #DellRockStar

    What is a Dell Service Tag and how do I locate it? 

     

     

    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

  • Hi Rick,

    For me that Image drivers option only not getting visible.. actualy previously everything working fine.. I dont know what happend suddenly my web cam is not functioning

    Could you please let me know the actual problem if possible

    Thanks in advance.

  • I have the same problem, i was in the middle of a conversation in skype and the camera died.... ive tried to unnistallit, let it install by windows and nothing, it installs the webcam but when i try it in skype i get the circling animation and no image... the dell webcam central 2.00.44 does nothing wither... help??

    Thanks in advance.

    Alejo.

  • Alejo.,

     

    Try reading...

     

    Using and Troubleshooting the Dell Webcam and Dell Webcam Central Software

     

    If the webcam does not show up in the device manager, under imaging devices, then contact Dell Tech Support.

     

     

    Rick

    #DellRockStar

    What is a Dell Service Tag and how do I locate it? 

     

     

    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

  • Thanks for the quick answer Rick, but the webcam is shown at the device manager and there sais its working correctly, at the webcam central i get no error message but a back screen and nothnig else....

  • AlejoRoncarolo,

     

    Do you have Fast Access Facial Recognition software installed?

     

     

    Rick

    #DellRockStar

    What is a Dell Service Tag and how do I locate it? 

     

     

    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

  • Nope, in may when i received the notebook i formated it and resintall from scratch, everything was working fine till today.... when videoconferencing in skype and suddenly the camera died....

  • AlejoRoncarolo,

     

    Does the webcam show up in the device manager under imaging devices? If not, contact Dell Tech Support.

     

    Do you have the latest version of Skype installed? Try tilting the screen while using Skype? How about light pressure near the webcam?

     

    Can you see anything here? Test Webcam

     

     

    Rick

    #DellRockStar

    What is a Dell Service Tag and how do I locate it? 

     

     

    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

  • It does appear and with no yellow ! sign, so it should be working fine.

    I have the latest version of skype installed.

    And the testwebcam page shows a black rectangle, the same as skype and dell webcam central....

    I think if i cant fix it today, tomorrow will call dell support...