Inspiron N5110, problem with Intel Centrino 1030 wireless card. - General Hardware - Laptop - Dell Community

Inspiron N5110, problem with Intel Centrino 1030 wireless card.


Laptop computer Forums (Audio, General Hardware, Video)

Inspiron N5110, problem with Intel Centrino 1030 wireless card.

This question has suggested answer(s)

Hello, I have recently acquired an Inspiron N5110 (Spain) laptop which comes with an Intel Centrino 1030 Wireless + Bluetooth card.

I received it 2 days ago and the wireless card is not performing as it should, when I boot up the system the adapter is disabled some times. I have to go to the device manager to enable it where it says it's disabled and code 22 is shown.

After it's enabled I can connect to a wireless network but sooner or later the connection is "lost", I don't really know how to explain it, it's connected to the network but the icon shows the yellow triangle stating "no network access" (it's a translation from Spanish, the actual English text may be different); sometimes even within the first 2 or 3 minutes. Restarting the adapter makes it work for another moment, sometimes it hangs; being restarting the only solution. When the triangle is shown, clicking it will only show the network it's connected to with the "limited access" tag and no other wireless network (in the area there are about 5, all of them are listed at the beginning).

The system is a clean 64-bit Windows 7 Home Premium, right now the only installed things are drivers (fully up to date) and the Office suite. The BIOS revision is the latest too, A03.

What could be causing this? Could it be a hardware problem? I have an older Inspiron 1520 which is also connected to the same router, it ships an Intel WiFi Link 4965AGN card and doesn't experience any problems.

Thank you for your time,


All Replies
  • have you tried drivers from intels website?


    HP is haveing the same problem, its a driver issue. this link gives hp's instructions and driver fix.


    hp's driver may also work, but i would try intels first :)




  • I have the same exact problem with the same exact laptop I recently purchased. I have tried the HP fix and it did not work. I am so fed up, I'm ready to return it.

  • I have the same Problems with mine. Has anyone found a solution for that? Or is there an offical statement from dell?

    Thnx for your answer

  • I installed SP1 for Windows 7 in the updates and the problem went away......


    I have got the same problem, with a Win7 64bit SP1 Professional from the beginning.

    Do you have other idea?

    Is there any official Dell solution?

  • There is an reported issue from Intel regarding PSP (Power Save Poling) with most of their new crop of Centrino wireless adapters

    They suggest first that you make sure that your router has the most up to date firmware, especially for older routers.

    After that they have a work around that may help.

    Use Intel® PROSet/Wireless WiFi Connection Utility to Set CAM

    Click Advanced > Adapter Settings > Advanced tab.

    Select Power Management and uncheck Default / Auto and move the slider to Highest / Maximum Performance.

    If the slider is already at Highest / Maximum Performance, move the slider to another setting and then back to Highest / Maximum Performance.

    Use Network Control Panel Applet (NCPA) to Set CAM

    Put the wireless adapter into Continuously Aware Mode using the following steps.

    Click Start > Settings > Control Panel.

    Double-click Network Connections.

    Right-click the wireless connection and click Properties.

    Click Configure.

    Click the Advanced tab.

    Select the Power Management setting, uncheck Default / Auto and move the slider to Highest / Maximum Performance. Note: If the slider is already at Highest / Maximum Performance, move the slider to another setting and then back to Highest / Maximum Performance.

    Please let me know if this helps any of you.


    Specialize in Laptops, Mobile Devices

  • Didn't work vor me i installed the newest Driver from Intel but i cannt see the power managemt Setting. the Workaround for me was at the same Place there is a Setting called 802.11n Mode and i disabled that. Thats not cool but at least the Notebook Works now and Stopps chrashing mi wireless router And i cannt beleve in my Case this has something todo whit the Router firmware because that is uptodate and the Router is not old.


    No, it does not work.

    The router firmware is up to date.

    I tried to use the wireless with another router and also the same issue.


    Is there any solution or should i take back the notebook to the store?


  • As a workaround set it to G instead of N mode.

    Right click on the wireless icon, goto Netowrk and Sharing Center, select 'Change Adaptor Settings' on the left of screen, Right Clck on the Wireless Icon, select properties, configure, advanced, then set 802.11n  to disabled.  This will set adaptor to use 802.11g only which is slower speed but works.

    Looking on many forums the Intel 1030 card has this issue across many different PCs when in N mode, so either it is a) unreliable hardware, b) requires a driver update, c) incompatibilities with some routers which will at some point receive a frimware update (this latter possibility is hard to beloeive as my router is almost new).  My vote goes with it being a driver issue.

    For the time being I have set to wireless G and am will try contacting Dell support to chase Intel for a driver upgrade.

  • It is unbelievable that Dell continues to sell this defective product despite the issues that have been logged on their website.

    I bought a N5110 recently in Singapore (should have done a more thorough review first) and have been facing the same problem with the wireless internet as those mentioned earlier in this thread. All that the technical support people here was able to suggest was to do a system reset which includes undoing critical updates from Windows - what kind of solution is this???!! Infact, let's not even talk about the technical support provided by Dell over here. Even after changing the wireless card, the problem still persists.

    On the contrary, my 4 yr-old laptop (non-Dell, of course) works fine with various wireless connections in different locations, whereas this brand new N5110 cannot even achieve decent connection in my home network.

    Hope this serves as additional data points to those who intend to purchase this model. I have given up on Dell addressing this problem and am awaiting a full refund from them - infact, they should also compensate me for all the loss manhours spent trying to get the laptop connection to work!

  • Update on my findings so far as I posted an earlier entry in this forum.  I ensured I had the latest Intel drivers, I updated the bios, tried numerous combinations of settings and still wireless N is hopeless.  Wireless G is fine.  Finally, I replaced the Intel 1030 wireless card with an Intel 6030.  Result?  Still hopeless wireless N reception and wireless G okay.  Thus it is not the specific 1030 wireless card which is the issue.

    I have now given up, disabled the internal wireless card in device manager and bought a Netgear WNA3100 USB wireless dongle.  It worked first time with normal speeds on wirelss N.  I will continue to use this until, if ever, I hear of a fix from Dell or Intel.  Certainly, a quick search reveals that any people are having this issue with these Intel cards and not only on Dell machines.

  • Not knowing this issue, I bought N5110 about 5 weeks back. I am having exactly the same issue. I called their Tech Support twice already - the guys tell me something else or some other problem that is not related at all. You will be surprised that these guys who are in the Tech Support do not know that this is already a known issue and BY NOW should have had a resolution in place. Wow !! That's the state of affairs with DELL. So, folks - please DO YOURSELF A FAVOR - DO NOT BUY DELL INSPIRON N5110 !!!! Blue Iris
  • I have found the solution to the problems that i have been facing with this defective dell unit ...

    I returned the unit back to them and bought a non-Dell laptop with similar specs and price. The new Non-dell laptop is working wonderfully - no problem with wifi connections anywhere and no overheating.

    Cost to me:  Dell only agreed to refund 90% of purchase price - they claimed that 10% is needed for their logistic costs. This is nonsense as their defective product has caused me many wasted hours and frustrations dealing with their ineffective & rude call center agents in Penang. However, the agony of having to deal further with them and wasting more time with no solution, is much greater than the 10%.

    I will let you judge their efficiency - the defective unit was collected by them more than 2 weeks ago but i havent seen the refund yet.

    My verdict - this will be the last Dell product that i ever purchase.

  • I wanted to step in again; both the Intel Centrino 6230 and 1030 wireless cards are combo WIFI and Bluetooth cards.  Update them to the latest driver on if you have not already done so.  Then if you don’t use Bluetooth often try disabling Bluetooth and see if that helps WIFI performance.  Intel is working on new drivers to help with wireless N performance, and disabling the bluetooth may help as a work around until the new drivers are made available.


    Specialize in Laptops, Mobile Devices

  • Is there an answer to this problem yet?  I have been having the same issue with wireless connection dropping for a long time.  Laptop is still pretty new and I am thinking of buying a new one just because this is such trouble.  First Dell I have ever purchased and I am not happy with it.  In my home currently, one laptop, one desktop, my and my wife's phones, and two Rokus are connected to the internet but the Dell Laptop is the only one which constantly loses connections even though I have a strong signal.  I have all the drivers updated and have done every suggestion from this forum and many others without success.  Is seems there are a lot of unhappy customers with the same problem.  What is the issue and is there ever going to a solution?