Latitude won't charge battery - solved (e6410) - General Hardware - Laptop - Dell Community

Latitude won't charge battery - solved (e6410)


Laptop computer Forums (Audio, General Hardware, Video)

Latitude won't charge battery - solved (e6410)

This question is not answered

Latitude e6410.

Here's the problem (I'll answer it myself afterwards, since Dell hasn't acknowledged it and is paying out the rear for it):

You plug in the charger and Windows sees the battery but it won't charge it.

All Replies
  • Answer:

    So 3 motherboard replacements later, I discovered this. No one from dell chat support EVER checked this or asked me to:

    Press Fn+F2 or Fn+F3 to enable/disable charging the battery.


    Wow, don't you feel stupid...

    Dell, please train your chat support please.


  • I have a Dell Latitude E5500 in the same state. The battery ran down even though the adapter was plugged in. Now it won't boot up with or without the battery installed. How can I get it going again? I can't get it to come up and stay up to press FN+F2 or F3.

  • Assuming you are running windows, the problem is probably with your power cord.  If the power cord was functioning, it would power your laptop regardless of the state of the battery.  In fact, you can run a Latitude e series that is plugged in without even having a battery.  Try this:

    1.  Find somebody with a docking station (Dell?), these use the ports on the bottom of your computer to power it, so whatever is broken with the AC adapter line probably wont affect this.

    2.  Put your computer in the docking station and see if it turns on/charges.  If it charges, than something is wrong with your AC adapter.  If it doesn't turn on, then you can always buy a new laptop and hot swap the hard drive.

  • Zach, that's the funniest thing I saw all day!

    Did they ask you to look in BIOS setup to verify battery charging is enabled?

  • Thanks. Some one had told me (wrongly) that a battery must be present. I had measured the O/C voltage at the adapter's connector and it seemed OK. It turns out though, the adapter is faulty under load. I ordered a new one.

  • Had similar issue with an e6410, I swapped out the brick (A/C adapter) and it started to get a charge, it did not with the previous A/C adapter.  I was able to boot up the laptop.  It turned out that the e6410s adapter was damaged, the LED lit plug was bent.  I work in a school district and kids had used the laptop and probably bent it.   Just FYI.  Hope this helps.  

  • Worked for me as well!  Thanks!!!

  • Thanks was really awesome...  :D

    Dell executives must know it

  • Cheers there Zach, I'd been plugged in and unable to leave the house with my laptop. top man.

  • Your AC adapter is broken.

  • I read Zach Baker's response to the battery charge question, but I have just bought a refurb'ed Lat e6410 that tells me that the battery is at 96% charge, the charger is plugged-in, but battery is not charging 

    AND Fn + F2 or F3 does not remedy the problem....

    Loaded MS WinPro 7 today......?