Latitude E6410 Screen Flickers \ Looking for Manual - General Hardware - Laptop - Dell Community

Latitude E6410 Screen Flickers \ Looking for Manual


Laptop computer Forums (Audio, General Hardware, Video)

Latitude E6410 Screen Flickers \ Looking for Manual

This question has suggested answer(s)

My work laptop was just swaped out for a latitude E6410.  

When I turn the screen brightness down all the way, it flickers a little every few minutes.  It doesn't go all the way off, just a little more dim, and bright.  I don't think it's the ambient light sensor, because the brightness is manually set.  Is this a common problem?  Should I make a service claim?  I use my machine in a darkened training room often, and prefer the dimmed screen, but the flickering is a problem.

I can't find the manual for this machine that describes the Fn keys.  The manuals section only has four items, and none of those are the end user manual.  

Only the following Fn keys work:  display mode toggle, Num Lock, Scroll Lock, Prnt Scrn, Pause, Auto Brightness, Brightness Up, and Brightness Down.  

The following Fn keys do not do anything:  Moon (I assume this is sleep), DCP (?), Battery with a lightening bolt (?), Battery without a lightening bolt (?). 

I assume since this machine has a custom XP image, I need to install a Dell utility to make those buttons work?


All Replies
  • Anyone?

  • The function keys are a combination of the Dell quickset utility and the Dell notebook system software and chipset drivers (the latter two need to be installed before any other drivers are loaded).


  • I just started using the E6410 as well.  I agree the screen dims down and just looks like the LED backlighting is sensitive to battery level or something.   What I also seem to notice is if I scroll on a webpage that has dark content or light content.  That triggers the dimming.  Almost as though the display is trying to adjust for the contrast/brightness.  I HOPE it's not Intel or Dell trying to make a feature that is supposed to help us read by auto dimming.  Try opening paint or image with dark colors and I think you'll see the same thing.  As a matter of fact any dark color on the screen triggers it.

    Dell how about a fix for this really annoying thing, is it hardware issue?

  • My Dell Latitude E6410 does the same.

    I use the power plan's 'Adjust plan brightness' setting with full brightness. The screen dims a bit every now and then regardless what I do. A bit annoying problem. This seems to happen only when external display is not in use. 

    What could be the reason for this?

  • I found this by Google:

    "This is due to the luminosity setting and the screen set to take into account the lighting in the room and to save power. So, first, to into the Power Settings and see what is set for screen timing to dim to save power. then, look at the bottom arrow keys and you will see the left arrow has the word "Auto" on it- hold the Fn key and click that arrow key and a the screen should go to bright and if you hit it again, it will dim. This is a toggle for the auto brightness controller."

    It helped for me.

  • I've found 2 things to change my screen brightness;

    One - being what was found on Google. i.e. Auto-dimming via the ambient light sensor.

    Two - depending on what program is on your screen. So, if there is a white thing on your screen (lets say Google search results) the screen will dimm. If something dark is introduced (lets say Windows Media Player) the screen with brighten up a notch. I haven't found a way to disable this.

    If anyone finds out, please let me know, it's driving me up the wall. I've checked DELL utilities, Display prefs, and Power settings so far with no luck...

  • Just press Fn + left arrow key, each time you do that, it disables/enables the Ambient Light Sensor

  • Hi! I had an identical problem with my 6410. In theory, Fn + the auto screen brightness key switches off the dreaded 'ambient light' sensor, but this was not a permanent fix.

    I have now switched the power option in control panel to 'High Performance'. This seems to have solved the problem for the time being. I an experimenting with different power settings, and adjusting the screen brightness via the screen keys, but you might consider trying this as a work around.