Bluetooth /firmware problem? - dell studio 1555, w7 x64


Laptop computer Forums (Audio, General Hardware, Video)

Bluetooth /firmware problem? - dell studio 1555, w7 x64

This question is answered

Hi guys!
I've reinstalled today windows 7 x64 Ultimate version. I've had before the w7 x64 Professional version - though I don't think it matters the version.
The problem is now, whenever I try installing the bluetooth, I get that annoying: Activate Bluetooth using Wireless Switch. Last time(s) I've installed bluetooth, it worked.

My notebook is a Dell Studio 1555, and I'm using this bluetooth package:

However, I've check all things, but it still give me that nag:
1) in BIOS, all switch/bluetooth related are on
2) In device manager, I see the unidentified device, with the following Hardware ID:

Any help please?

I'll try soon to see if the linux bluetooth still works.


Verified Answer
All Replies
  • Hi again!

    I've entered linux, and there it detects the bluetooth, if I let him search my phone via bluetooth it does, but does not allow me to send files (some internal error)

    So, maybe my bluetooth board's firmware is broken. is there anyway I can put the correct one? :( I really need bluetooth.

    Where can I find some kind of firmware upgrade for the bluetooth card?



  • Can anyone help?



  • So it certainly looks like you have followed the basics.

    • Check the BIOS to ensure the wireless card is detected. Also verify the Wireless setting is turned on and not set to Always Off.
    • If the Bluetooth device is installed, also verify the radio LED is enabled. You can turn the wireless and Bluetooth cards on or off with the wireless switch.
    • If the card does not show up in the BIOS or Device Manager, try reseating the card.

    Only think I could thing is making sure that wireless is enabled as well as bluetooth. Other than that only thing I can think of is reseating the bluetooth card to make sure it has a good connection. The following link from the service manual might help.



  • Hi Larry!

    Thanks for the response.

    Yes, the BIOS setting is enabled.

    Also, if I press: WINDOWS+X, and got the mobility center there,  Then click  on Launch, to get to the Radio options, here is what I get:


    So bascically, it's enabled - though I can't check things in there just in BIOS. Btw, do you know why it doesn't let me do that?


    Wow, I've started the installer and now it WORKS:O . How does it happened?


  • Glad to hear that it is all working.  I don't believe that the Windows Mobility Center has access to the BIOS.  FN + F2 should turn wireless on and off though, incase this happens again. 

    Have a great weekend


  • Hi,

    I am facing some problem in my Dell Studio 1555. I had Windows vista installed initially but now I have installed Windows 8. Now I am unable to use Wi-Fi as its not detecting my Wi-f9 device and also bluetooth is not working. I tried to install the respective drivers from Dell website but it said its not compatible and gave some error.

    Please help me to get rid of this.