Latitude E6400 LED Backlight Not Working

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Latitude E6400 LED Backlight Not Working

This question has suggested answer(s)

I need some help repairing my laptop.  Short version...laptop was on and working, when the battery was getting low, I plugged in the 90 w charger, which was powered by a 180W power inverter (converts dc to ac) plugged in my car.  As soon as the charger was plugged in, I lost the backlight.  The laptop boots normally, I can see the display (very dim) and external monitor works fine.  Adjusting brightness by keyboard makes no difference.

I have changed the LCD display with correct new replacement.  Same results, no backlight just dim display.   I have inspected the display cable and adjusted/wiggled it with no result.

On board diagnostic show no errors.  Even says inverter is fine, which it should not have since it is LED backlight.

 

Is a motherboard replacement in my future?  Any other culprits?

 

Specs

E6400 Latitude, LED  Backlit 1440x900 Display, Nvidia NVS 160

All Replies
  • I believe you are correct if you have replaced the other parts. Those parts would include: display, LCD inverter, cable and system board. Those would be all the parts that could cause your issues.

    You have stated that you replaced the display so my next move would be in invert which is what actually amplifies the power from the system board to power your display. If that does not work, than yes, a system board is in your future.

  • I am curious how you solved your display problem.

    My issue begins when one of my monitor hinges failed and caused debris to slide up behind the display, under the back cover.  I am assuming that this caused some physical damage because the next time I booted up I had no  display at all, but after disassembling the display and removing the debris, I could see the image with no backlight.

    My e6400 is out of warranty and I my LED backlight has completely failed.  I am able to see a ghost image on the screen when illuminated by an outside light source such as a flashlight, but there is no backlight. Display is normal when connected to an external monitor, and I have attempted software fixes by adjusting brightness and disabling ambient light sensor.  I have also updated the BIOS with no results.

    I was told I would need a new display, but I would like to know if there is another potential cause such as an inverter or a fuse before I order an entire new display.

  • hi

    i just wanted to say , i have the same issue , the pixels are working but the backlight is out 

    i changed the inverter , but it lighted up for less than a minute before turning of 

    also even if the pixels are not at all driven by the inverter board (after following the cables on the back of the screen), i could analyze that the pixels will not work if your inverter board doesn t work 

    so at the end i am not sure where the problem is from , but not the inverter .

    i am thinking about 2 hack-options here:

    -empty the screen and keep only the pixels and the transparent plexiglass to have a "see through" screen , but there is a board on the top of the screen than is not gonna look good

    - of empty the sides of the screen where there is the neon and change theses with led strips

    it is a lot of work , so i dont know when i will do it , if i do it 

    i removed the screen and all the cables (not more WiFi or Bluetooth) and plugged a screen in digital out , and one screen in vga , it works ; but you will need one dongle for WiFi and one for Bluetooth