Memory size on Inspiron 8500 - General Hardware - Laptop - Dell Community

Memory size on Inspiron 8500


Laptop computer Forums (Audio, General Hardware, Video)

Memory size on Inspiron 8500

This question is not answered

This is old Inspiron 8500 (7 years old) is used for light work, and is now running Windows7 Professional. I tried to ugrade the memory to the declared maximum of 2GB (2 x 1GB) but even though using good Kingston memory, it will only recognise and work with 1GB in total.  My original 2 x 512MB work OK,....if I take them out and put in 1 x 1GB Kingston unit, it works OK, but if I try to use either a second 1GB unit, or even one of my old 512MB units, it hangs on the Windows loading icon. It is as if it will only work with up to 1 GB total.

I can't seem to upgrade the BIOS from A06 to A08 (that may be a Windows 7 ything, the Dell techies think).

Anyone else had a similar problem?





All Replies
  • Does BIOS recognize the memory change?

    Enter BIOS setup and check the memory modules . Check if it detects the two 1GB chips

  • Where did you purchase the memory?

    You should always buy from someone who will guarantee it will work, like Crucial. Return yours if you can abd try a legit seller.

    Some older computers will only recognize a maximum number of memory "banks". If the limit is 2 or 3, and each memory chip has two banks, then you will get what you got. Many sellers supply cheap RAM which may not work. Ebay is a problem source.

    XPS M1530, Win 10 CU Pro 32-bit
    Inspiron E1705, Win 10 CU Pro 32-bit
    Dimension 9100, Win 10 AU Pro 32 bit
    Inspiron 660, Win 10 CU 64 bit
    Inspiron 3668, Win 10 CU 64 bit
    Asus T100 Tablet, Windows 10 CU 32 bit

  • Yes, the bios shows the memory that I put in, but the startup hangs at the splach screen unless I only have 1GB total on board. (Either 1GB in one slot only, or 2 x 512MB .)





  • I bought from a reputable shop, and they even swapped to try different manufacturers.  The best was a Kingston, and that worked if only 1 x 1gb unit was used.  As soon as I put 2 in the machine would hang on startup.  I got all my money back as thy couldn't get the memory to work in my 8500.