Vostro 1510: Disable Num Lock for internal keyboard when using wireless keypad

Laptop

Laptop
Laptop computer Hardware and Software discussion

Vostro 1510: Disable Num Lock for internal keyboard when using wireless keypad

This question is not answered

Hi all,

after 3 hours looking for a solution on the web - unsuccessfully - you are my last hope Wink

I am using a Microsoft Bluetooth Mobile Keyboard 6000 together with the separate number pad on my Vostro 1510. However I think the problem occurs with all external keyboards. When I want to type numbers on the keypad I have to press its Num Lock key. Annoyingly this also turns on Num Lock on the internal keyboard which now produces numbers instead of letters (J=1, K=2, and so on). When I turn of Num Lock on the internal keyboard it is being turned off for the external number pad, too. This makes it impossible to use the external number pad together with the internal keyboard.

The 1510 BIOS does not have an option for toggling the Num Lock key behaviour. I cannot believe that there is no solution to this problem, since many other users must have had it as well.

I am using XP SP3, latest updates, latest BIOS and Bluetooth drivers installed.

Any suggestions would be highly appreciated.

JJ

All Replies
  • No ideas? Anybody? Confused

  • Still unresolved... Crying

  • I am having this issue too, and cannot get an answer....

  • Try booting into the bios setup and see if there's an option to disable the internal numbers used on the keyboard (the blue ones). Then the num lock should only affect the 10-key and not the letters on the keyboard.

  • From my original Post:

    The 1510 BIOS does not have an option for toggling the Num Lock key behaviour.

    *sigh* Indifferent Why is it so hard to read?

  • What I did to turn off the NUMLOCK on my Vostro 1510 was plug in a Standard USB keyboard.  After the laptop installs the Device I press the Numlock on the USB keyboard.  You will see the NumLock LED (the little lock with # 9 in it) turn off.

    That is it.

    Paul

     

  • So just to toggle NUMLOCK you always have an external USB keyboard attached?

    Anyway, 16 months after my original question I've got a new computer now. It's a Latitude E6420, and the problem doesn't occur on this computer. Instead it created new Bluetooth-related problems.

  • How I got to this thread was I was working my second job, setting up a new computer for a business and their old laptop the Vostro 1510  I had to retreive the data from it.  The user attached a keyboard, Mouse and Monitor to it to give him more of a destop feel.  I had removed the Monitor, Keyboard and mouse off the laptop to give more room.  I notice the Num Lock was on.  I tried to figure out how to turn it off.  I googled your thread.   I saw there wasn't a solution.  I tried reconnecting the USB keyboard and turned off the Num Lock.  I removed the Keyboard and it stayed off even after a reboot so I decided to pass on the info.

    Your second problem with the Latitude E6420 and Bluetooth problems, I might have seen.  At my first job, contracting to NIEHS / NIH we image a lot of latitude E6420 laptops with Windows 7 Pro.  With one laptop I found the Dell BT mouse would pair but it never moved the cursor.  The next one I imaged I had no problem.  The first laptop I tried to uninstall the Bluetooth drivers and reinstall but it still didn't work.  Nid did get that one to work.  Let me know if you came up with a solution.

    Paul