Latitude E6410 resume from S3 Suspend (on batteries) - General Hardware - Laptop - Dell Community

Latitude E6410 resume from S3 Suspend (on batteries)


Laptop computer Forums (Audio, General Hardware, Video)

Latitude E6410 resume from S3 Suspend (on batteries)

This question has suggested answer(s)

Latitude E6410 (Intel i7) fails to resume (total system freeze within first 3 seconds) from S3 Sleep (STR) when resumed running on battery power. Sometimes first resume cycle passes and problem occurs  during 2nd or 3rd suspend/resume cycle.  When the laptop is running on AC-power the resume works 100% correctly.

This issue disappears when SpeedStep is disabled in BIOS.

It seems like a BIOS bug (tested with rev. A05)

OS:  Linux 2.6.35 and 2.6.36 x64, Windows 7 Ultimate 32-bit


All Replies
  • Update:  Dell phone support classified the issue as HW problem; laptop servicing has been scheduled which should hopefully resolve the issue.

  • Replaced:

    - mainboard (which includes nVidia discrete GPU)

    - CPU

    - Display

    No success so far. Remains to be tested with a different battery (currently using 9-cell hi-capacity battery with Express Charge)


  • Finally the issue has been officially classified by Dell as BIOS bug, there's no intermediate solution available until next release of BIOS (except from never resuming the laptop on battery power or having speed-step disabled, obviously).

    I would gladly test-out a beta BIOS;  Dell, please, feel free to contact me. I would provide you with my service in order that you could check-out the details of my HW specs and to provide you with feedback on the appropriate BIOS beta.

  • Herroux,

    I've had my E6410 for about two weeks and have observed the same condition.  Mine is the same configuration but with 64-bit, 8Gigs of RAM.

    You are absolutely correct about waking from standby.  I have observed the exact same symptoms and it was pretty frustrating.

    I may have something that will work for you.  If you can live with changing your power options from "standby" (S3) to "hibernate" (S4), your Latitude will probably wake normally.

    No guarantee that this is the best workaround and it may not be as fast for you, but I tried doing this after I read one of your earlier posts, and so far, during the past week, it seems to be working perfectly for me.

    I don't know what trade-off disabling speed-step in the BIOS would introduce, but I was somewhat skeptical when I you reported that Dell Customer Support suspected that it was a defective unit.  I'm sure they did their troubleshooting correctly, but I couldn't imagine that I'd have the exact same issue with my machine.

    I believe I'll be looking for the A06 BIOS on a regular basis.


  • .

  • .

  • .




    Here's the information from my PC.  We have similar models and features, but I don't have the Solid State Drive.  I opted for a 7200RPM drive.

    The only reason I chose this machine was because I really, really need a Dell laptop with a USB 3.0 port.  What's that you say? This one doesn't have one of those.  Correct.  But it does come with an ExpressCard slot.  This is not a great solution, but the configuration does allow me to use a third party "ExpressCard to dual USB 3.0 port" adapter.



    Manufacturer Dell Inc.
      Model Latitude E6410
      Total amount of system memory 8.00 GB RAM
      System type 64-bit operating system
      Number of processor cores 2
      Total size of hard disk(s) 466 GB
      Disk partition (C:) 418 GB Free (466 GB Total)
      Media drive (D:) CD/DVD
      Display adapter type NVIDIA NVS 3100M
      Total available graphics memory 4095 MB
            Dedicated graphics memory 512 MB
            Dedicated system memory 0 MB
            Shared system memory 3583 MB
      Display adapter driver version
      Primary monitor resolution 1280x800
      DirectX version DirectX 10
      Network Adapter Bluetooth Device (Personal Area Network)
      Network Adapter Intel(R) 82577LM Gigabit Network Connection
      Network Adapter DW1520 Wireless-N WLAN Half-Mini Card
      Network Adapter Microsoft Virtual WiFi Miniport Adapter
      Network Adapter

    Deterministic Network Enhancer Miniport

  • Herroux,

    Another update.

    I've  been working on this for some time.  What's been interesting is that each time, I get to the point where the "Resuming Windows" animated graphics appears and then, a few seconds later, the screen blanks, including the LED backlighting.

    What I think may be happening is that it's definitely related to the "suspend" and "hibernation" modes, and the relationship between them.

    I noted that you'd mentioned Linux OS on your earliest post so I don't know whether or not you're principally running Windows, or whether this applies to you.

    What I've found in my case is that there's a point in the Windows 7 power management options where the we set the "sleep" and "hibernate" options.  The default setting for S3 sleep may be five or ten minutes, or some other period of time.  But S4 hibernate's default is set for 360 minutes.  If the machine is left alone, Windows thinks you need to save yourself from a potential calamity, so sleep automatically changes over to hibernate .

    For example,

    When I close the lid, my machine goes to S3 sleep mode.  There's a little blue LED on the top of the unit near the hinge that gently blinks on and off, indicating it's snoozing.  According to the default power plan I'd selected, after 360 minutes, or six hours, of this kind of "sleep", my machine will "wake" for just enough time to write information to disk, go into hibernation, and then power down completely.  From this point, all hope is lost.

    Upon attempting  to restore from S4, the machine becomes confused and the "resuming windows" graphic appears, which in itself, proves that it is trying to restore from hibernate.  Normally, when you come back from unmolested S3, the machine simply awakes from "Standby", and there is no such graphic.

    I have changed my power management to a shorter standby and have induced the machine to become a sleeping beauty much quicker.  In fact, I can now get it to become comatose in a minute or two.

    My new workaround is to set the hibernate option in my advanced power management window to "Never" so that my E6410 never invokes S4 hibernation.  It's probably not the best option, but I have the larger 9-cell battery and as long as the lid is closed, the machine not drawing much current.  I am confident that I will be able to charge it before it completely runs down.

    So now I have a question, is this a problem with the machine or with the OS?


  • .

  • And the problem is apparently independent on the overlaying OS.  I tested the issue extensively on both Windows and GNU Linux, 32-bit and 64-bit OS architectures. If you like, switch off Speed Step, it's much more power efficient to S3 sleep than idling with lid closed, just the  backlight off. With Speed Step you're losing P-states frequency scaling, but thanks to C-states power management the power consumption is still good for battery mode.  With Speed Step disabled the Turbo Boost is however disabled as well - don't get confused by the fact that Turbo Boost is controlled in BIOS separately. If Speed Step is ON, then Turbo Boost can be turned ON  or OFF as additional option;  if Speed Step is OFF, then Turbo Boost is always OFF by principle, no matter if set ON or OFF in BIOS.

  • Mine is the same.  Intel(R) Core(TM) i7 CPU    M 620  @ 2.66GHz

    I'm still curious though.  Does your laptop have an ExpressCard slot?


  • Okay.  Thanks for the advice on Speed Step.  Is performance compromised in any way? For example, how much performance is lost if turn it off and Turbo Boost is disabled? Is it more "theoretical" than real-world practical?


  • Yes,  I have the EC slot version, but I think it's irrelevant.  I believe that 4 GB memory modules and i7@2.66  are two crucial factors.

    If you could try a different size DDR3 module, it would be great to see if the issue disappears.  I bet that either non-i7@2.66 or non-4GB-memmodule equipped E6410s  are free from this issue.

    As to SpeedStep turned off performance:  it depends and I'm not an expert on this. In theory it saves you battery power on medium CPU loads and on the other hand it allows CPU frequency to scale up-to 3.3 GHz (620M @ 2.66 CPU) for a single core (when thermal factors are met and no other threads utilise heavily the other core). In practice, especially for CPU idling, the C-states matter the most and can do pretty good power saving even without SpeedStep. However Turbo Boost, which is unavailable without SpeedStep (e.g. i7z tool shows this clearly), as far as I can practically tell,  is a great feature which increases loading times of most of applications by about 30% which is significant - especially with fast HDDs (like SSDs). With slower, classical HDDs,  the app load times are largely dependent on HDD throughput so the CPU speed-up thanks to TurboBoost plays minor role. I think the best is to google for TurboBoost description and real life experiences. In general, any CPU intensive application (which is not heavily multi-threaded; minimum of common apps are) can significantly profit from TurboBoost in terms of overall performance gain.

  • Update:  tried with different memory modules (2 x 2GB instead of 2 x 4GB) and with a different battery (6-cell instead of 9-cell) - no improvement.

    There are now just 2 components left like real suspects (not counting that BIOS update could solve it):  nVidia GPU  and i7@2.66  CPU.  But it's not grpahics what is stuck on resume, the complete system is frozen, so I suppose the combination E6410 Mainboard + Dell BIOS up to A05 + i7@2.66 CPU is fatal.

    A guy from the net contacted me having the same issue, who claims that swapping his i7 620M @ 2.66 for i7 640M @ 2.80 CPU worked around the problem, same success with Core i5.

    Btw. did you try to see what happens if you disable Speed Step?