Studio XPS Touchpad not working after sleep - General Hardware - Laptop - Dell Community

Studio XPS Touchpad not working after sleep


Laptop computer Forums (Audio, General Hardware, Video)

Studio XPS Touchpad not working after sleep

This question has suggested answer(s)


I have a dell studio XPS 1640 running windows 7 64-bit.  Since I have owned the computer I have had a problem with the touchpad when coming out of sleep.  About 50% of the time I come out of sleep, the touchpad is unresponsive.  In order to get it working again I use the keyboard to put the computer back into sleep and then wake it back up again.  This doesn't always work but it usually does.  I have the most up-to-date BIOS, the newest synaptics driver from the synaptics website, and I also just did a clean install of Windows 7 hoping this would resolve the issue, which it did not.  I really don't think it is a hardware issue, seems more like a software issue, as if the driver is just not loading sometimes when coming out of sleep.  This is driving me crazy and is really a pain.  Anybody have any other thoughts on something I can try to resolve this issue? Thank you!

All Replies
  • Hi there. Try to check your power options settings. You can check the settings on your power plan settings. Try to change your power settings to advance. Just go to control panel and open Power options in Windows 7. Smile

  • Thank you for your response.  Which setting do you think I should change in the advanced power settings? There are no options that pertain to the touchpad.

  • Open power options and open your power plan settings. Click on change advance power settings. Once you open that you can change the settings under "sleep",try to play with the settings and try to simulate it. Put your computer to sleep and try to wake it up using your touch pad. I hope it works.:)

  • Thank you very much for your input.  My problem isnt actually trying to wake the computer with the touchpad, the problem is that after I wake the computer with the power button, the touchpad is unresponsive about 50% of the time.  In order to get the touchpad to work again, I have to use the keyboard to put it back to sleep then re-wake it, or do a restart.  The mouse will not move at all and the mouse buttons will not work until I do so.  Seems like some sort of driver issue but I have the most up-to-date drivers currently so I don't know what else to try.

  • Thank you , I had the same problem..

  • Did you ever find a solution?

  • I am having the same problem, and my touchpad was replaced when still under warrenty!

  • So you had the problem before and after you had the touchpad replaced? If so then that just solidifies what I originally thought which is that it is a software problem and not hardware.  I had my motherboard replaced under warranty and the problem persisted after also (Really wishing I hadn't bought a Dell).  I have tried everything to no avail. Most up-to-date drivers from Synaptics as well as older driver versions. Complete system format.  I even had the problem on 2 different operating systems...Vista and now 7.  Very frustrating to have to put the computer back into sleep and wake it back up several times just to get the touchpad working!!!

  • Not quite...

    The touchpad was intermittent, then packed up completely. I was made to run the diagnostics utillity and it proved that the device was faulty, and was subsiquently replaced by a dell technician.

    It has worked fine for about 6 months, then it started this intermittent fault with sleep.

    I would reinstall windows to see if it makes a difference, but at the moment it is not practical.

  • I have the exact same problem. Mine began acting up about a month ago. Same laptop, Windows7 64-bit, updated everything. Please advise!

  • Wish I could but Dell tech support was no help (shocking). Pretty sure your just going to have to deal with it just like I do.

  • I'm running Vista 64 on a Studio XPS16 and having the same issue.  Coming out of sleep is a throw of the dice as to whether the touchpad is working or not. It started a few months ago.  I suspect a Windows update.

    I can plug in an external (USB) mouse to keep working, but have to reboot to bring back the touchpad.  I haven't tried to send the puter to sleep and come out again.

    I'm also seeing a failure (intermittent) with Bonjour services that was installed with iTunes.  It all happened aroudn the same time.  FWIW.  It may be unrelated, but then again...

    I would love an answer to this as well...!  I was trying to do a customer presentation yesterday and had to borrow a mouse from the customer!!!   aaagh!  ;)

  • Hi,

    One of the fix for this issue is to update the BIOS of XPS16. You can download the BIOS update from Just enter the service tag of your system and just look for the update BIOS release date from the download list.

    Please let me know if this step works.

    Cheers!Big Smile

  • Hmm I have the same problem too XPS Win7 32bit. Just started happening, but at least I now know going to sleep and waking up again gets the touchpad to come back to life.  I noticed it isn't in the system tray, but have so far failed to find a way to manually start it as control panel etc helpfully tell it 'it is working fine'. I'm going to try messing with the power settings as I changed them shortly before it stopped working, but then I also installed a my passport backup disk...

  • Hi

    I have just recently encounted the same problem with my Studio XPS 1640 since installing the official release of Windows 8 64-bit, although I don't recall this happening when using Windows 7 for about 3 years.

    After reading this forum with no offical answer, a completely new idea popped into my head as follows:

    -- Firstly, install the latest Synaptics driver from their site. (currently Version 16) just been released!

    -- Disable both 'HID-compliant mouse' drivers in Device Manager but leave the Synaptics one enabled as this is the one you will always be using.

    I have tested this numerous times so far after waking the computer and has never froze once.

    My theory is that Windows has overwhelmed itself trying to load all three mouse drivers simultaneously which then has prevented the touchpad from working.

    Hope this helps