Dell studio 15 (1558) Internet conection issue. Wireless works, but does not want to connect - General Hardware - Laptop - Dell Community

Dell studio 15 (1558) Internet conection issue. Wireless works, but does not want to connect


Laptop computer Forums (Audio, General Hardware, Video)

Dell studio 15 (1558) Internet conection issue. Wireless works, but does not want to connect

This question has suggested answer(s)

Hi. I just got the most advanced dell studio model with a wireless WLAN 1520 Half mini card. Eeverthing is working good but not the wireless. I get the wireless connections up in the wireless, but when i press connect it doesnt manage to connect. I tried manually but also failed. I can connect with my other mini  pc(this one) so there is nothing wrong with the wireless. 

I hace tried connecting to secure and unsecure internet connections that appear in the wireless but havent managed. I can see the internet connections but it doesnt manage to connect. I tried almost everything and was hoping that i dont need to reinstall the pc if that even helps.

I need help, if anybody can suggest anything that can solve this issue....

Thanks in advance =)

All Replies
  • hi, I have the same problem with my studio 1558 (with Dell Wireless 1520 802.11n Half Mini Card) to connect to my Linksys WAG120N ADSL Wireless Router.

    1- I could connect to another dell studio 1558 with my laptop in adhoc mode 3 days ago (but I can not check anymore because the other laptop is not available now)

    2- I can connect wireless to the router and use the internet with my Sony Ericsson P1i mobile phone

    3- and I can connect with Lan cable to the router with my laptop

    But I can not see any wireless network in my laptop

    I try "netsh wlan show filters" to check if there is any filter about adhoc or infrastructure networktype but there is no filters there


  • I have a Studio 1558 and lost my wireless connection last week to the 2 different routers I normally connect to, I tried everything in settings on the laptop and couldnt resolve it.  Finally I uninstalled Dells wireless utility and then did a system restore back a week and reinstalled the wireless utility from a download and all worked again, even to the point of still having my passwords saved for router wireless access on both routers.  I suspected it was probably an auto update through windows that broke it so i then did windows updates one at a time and this time there was no problem.

  • I solved my problem. I opened the laptop to change the networkcard because dell sent me a new one. Then i found out that one of the conection cables going into the ntworkcard wasnt conected. When i conected that properly, everything workd. The pc- came with that cable of something i think was baddly done by dell, so maybe you guys should open your pc- and check if all the cables are conected because that was my problem....


    Good luck Wink

  • hey

    My problem solved either, but windows system restore couldn't do anything for me, after that I did use the Dell PC Restore and hopefully everything is perfect right now.

  • I've had the same problem on my  Studio Laptop 1558.  I would get connected to an access point and there would be "no internet access"  here is what I did to resolve the problem...

    1. -Open Network and sharing centre
    2. change adapter settings
    3. right click on your card, in my case DW1501 wireless-n wlan half-mini card and click on properties
    4. click on "configure"
    5. click on the advance tab
    6. select the IBSS mode and verify that it is set to 802.11a/b/g/n Auto  click OK

    My adapter card was only set for b, not sure why, but once i changed the setting I was able to connect to the internet.