Vostro Laptop Battery Not Charging - General Hardware - Laptop - Dell Community

Vostro Laptop Battery Not Charging


Laptop computer Forums (Audio, General Hardware, Video)

Vostro Laptop Battery Not Charging

  • Dell Vostro 1510 laptop.  Message states, "Plugged in, not charging". I've installed new DELL battery and charger. Immediately shuts down when unpluged. Tried removing battery and holding power button on for a minute then reinstalling battery.

  • If the new battery and charger haven't solved the problem, it's the mainboard that's faulty.


  • After buying a new battery, I had intermittent trouble charging it. After two solid days of not charging, and Dell support saying I need to pay $59 for diagnostics, I found this procedure.

    1. Click Start and type device in the search field, then select Device Manager.

    2. Expand the Batteries category.

    3. Under the Batteries category, right-click the Microsoft ACPI Compliant Control Method Battery listing, and select Uninstall . WARNING: Do not remove the Microsoft AC Adapter driver or any other ACPI compliant driver.

    4. On the Device Manager taskbar, click Scan for hardware changes . Alternately, select Action > Scan for hardware changes.

    Windows will scan your computer for hardware that doesn't have drivers installed, and will install the drivers needed to manage your battery's power. The notebook should now indicate that the battery is charging.

    It worked. Many discussion forums relate this to Windows VISTA, but I have XP. Be sure you uninstall only Microsoft ACPI Compliant Control Method Battery, not any other ACPI devices. 

  • There is an easier solution.  Unplug the recharger when restarting the computer.  Then the battery is always recognized. After the start process, plug the charger back in the computer. 

    If your computer battery is dead, charge it overnight without starting the computer. Then follow the steps outlined above. 

  • OK,I have the exact same problem here,and I tried to fix it using this solution and it worked for a while ,now I was trying to apply it again but the problem is I accidentally high lighted AC adapter and clicked uninstall, now ,is there a solution for this :(

  • This worked for me. Take battery out and power off from AC adapter. Leave overnight. In the morning press the start button without power plugged in for at least 30 seconds to remove all residual charge in computer. Clean computer and battery terminals. Power up from the AC adapter, put battery in, should start charging. I tried deleting and re-installing battery drivers - didn't work for me. I'm not sure if the solution is to clean the terminals or get rid of residual system charge for a clean start...anyway, battery is still charging normally. Thanks

  • I have the same problem. The only (temporary) solution I found so far, which at least seems to be a bit easiert than your workaround, is to

    whenever the battery icon says "plugged in, not charging" (for me it's usually somewhere around 71 to 74%):

    1. take the battery out while the computer is still running in Windows 7 (but of course with the AC plugged in!)

    2. wait for a while. I'd say about a minute at least. (If this tip should not be working, you didn't wait long enough, so increase the waiting time!)

    3. then plug the battery back in into the still running computer (yeah, not too easy with the AC cable and other cables, I know).

    4. the battery should now charge to its full capacity

    This works for me (Vostro 131 with Win 7 64bit) every time and doesn't even require a reboot.

    But I have to do this now at least once a week, which is quite annoying. Especially when others use the computer and I get back on it and see that it got stuck at 74% again.

    Has anybody encountered a PERMANENT FIX to this problem?

  • I have also Vostro 131 with Win 7 64bit and it stopped charging today. I've tried almost every tip in this topic but non of them works for my Vostro. Next I'll try to leave it without a charger and battery over the night and let see what happens... Have any of you tried what they say if order an on-site visit? There is 3 years on-site in my Vostro.

  • I have also the same issue with Dell Vostro 1510.

    I bought recently Dell Compatible battery (9-Cell 11.1V 7800mAh). But when I plugged in at the time of system start-up BIOS gives "Battery is plugged in but not charging, press F1 to continue". 

    I tried above mentioned all solution including flashing BIOS with latest firmware.

    Also I tried to put battery in charging for overnight but still it is not detected, however when I plugged in battery first time so in new battery some charging was there so my laptop was running fine on battery but battery was not charging so now it is dead.

    Please help.



  •  Upgraded BIOS to A12 and still would only show battery charging for a few seconds.

    checked PhoenixBIOS Setup Utilities/ Main/ AC Adapter = "NONE".

    In desperation I went to PhoenixBIOS Setup Utilities/

    1st I disabled 'quickboot to allow boot testing.

    2nd under PhoenixBIOS Setup Utilities/ Exit  1/2 way down the list; "Load default settings" and saved on exit.

    Rebooted and F2 to PhoenixBIOS Setup Utilities/ MAIN now shows AC Adapter = "90W".

    and my battery shows charging :)

    Also I disabled the Quickboot setting to allow tests 1st, but I see the defaults re-enables Quickboot, so am not sure if that made the difference(?)  Good Luck.

    This was my 1710 w/ Win & 32, but have a 1510 too.

  • Cool, I fixed it as your advise. Welldone