How to enable Fn permanently? - General Hardware - Laptop - Dell Community

How to enable Fn permanently?

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

How to enable Fn permanently?

This question is not answered

 

Relates to Dell Studio 1558.

 

I don`t know which 'clever guy' invented all F1..F12 to be disabled by default in my keyboard but it is mighty annoying. I want to debug my software by pressing F10, but it`s impossible since I have to press Fn as well, which is in the opposite section of keyboard and my hand is just to small to reach both those keys. I want to rename file in my remote computer by pressing F2, but this results in my WiFi being turned off and my remote desktop being killed. And it`s only because some crazy Dell inventor failed to understand what really Fn means.

What I really want is to get F1...F12 functionality when I really press those keys. I don`t want to be forced to press Fn every time. How would you help me?

All Replies
  • I think you are a bit confused.

    Fn+F2 turns off the wifi. F2 by it self does nothing.

    Fn+F10 opens the DVD drive tray. F10 by itself does nothing.

     

    my Dells:
    Optiplex 3020 - Windows 7 Pro 64-bit
    Precision M6300 - Windows 10 Pro 64-bit
    Precision M6300 - Linux Mint 17.3 Rosa / Ubuntu 12.04.5 dual-boot
    Latitude D620 - XP Pro SP3

  • You should be able to make this change in the Bios, I did on my Studio 1555

  • Dear friend, i have the same problem with mi laptop. I use the function keys in every application so, i understand you. I can change this setting in my laptop, so i think this can help you. I have a Inspiron N5010 model, whith Windows 7 Home Premium (spanish). Run the Windows Mobility Center (Start -> All programs-> Accesorios) and them select use the function keys in the dell special features. Setting this, you use the function keys normally.

  • Power on computer

    Press f2 continuously

    You will load into bios.

    Go to advanced- navigate to Function key

    Change the setting to Function key first.

    Save changes by clicking f10.

    That resolved my problem.

    Hopefully will resolve yours.