Studio 1555 dead after trying to upgrade BIOS to A09 - General Hardware - Laptop - Dell Community

Studio 1555 dead after trying to upgrade BIOS to A09


Laptop computer Forums (Audio, General Hardware, Video)

Studio 1555 dead after trying to upgrade BIOS to A09

This question is not answered

My Studio 1555 died after trying to upgrade the BIOS last night. The process froze at "verifying sector 11" and that's it. Now when I push the on switch it makes some noise and stops - even the screen does not light up.

All Replies
  • Hi petertakov


    I had the exact same problem today, same laptop model, on the bios update A08 to A09, I left the laptop for about 2.5 hours hoping it would do something but it was just frozen, so I called dell support and we tryied a few ideas but the laptop is not working.

    I am a little bit anoyed that the dell update has nacked the laptop as the laptop is less than two weeks but Dell are sending an engineer out free of charge to fix it tomorrow (weather permiting as the UK in the middle of a snow storm). so i cant complain about the way they are resolving the problem. i will post details on how the laptop is fixed..


  • Oh how i wish i had seen this 30 mins ago, I just did the update and now my laptop is bricked.  It froze solid at sector 25.  I hope dell is going to fix this for me also. Im in the uk.


    petertakov can you let me know who the guy at dell is who is sorting this out for you please.


    Many thanks


  • Dell apparently does not test their bios updates before deploying them.  I had the same issue with a Dell Studio One 19.  After waiting 4 days for a tech to tell me I was bumped to another day, I was forced to return the unit as the only way to fix the problem is to replace the motherboard. 

  • My Dell 1555 Died after upgraed a09 bios too. They change new mainboard for me. Then I upgraed to a09 agin and it was died agin. And if they change new mainboard I'll do It agin agin agin agin. I'm student in Australia

  • doughy

    petertakov can you let me know who the guy at dell is who is sorting this out for you please.

    I had it serviced by the local (Bulgaria) authorised service - motherboard replaced. They were quite prompt actually but I left it with them to try to deal with the screen flickering issue. I am starting to feel like a beta tester but one who is paying for being such. I will never buy another Dell again.


  • BTW, the guy at the service upgraded the BIOS to A09 to check if the flickering is dealt with in this release and the upgrade went fine save for the fact that the flickering was not cured. This is the second BIOS with the "display quality improvement" and I do not notice any improvement, especially as regards the main and quite obvious problem with the Studio 1555's display.

  • Normal 0 false false false EN-GB X-NONE X-NONE MicrosoftInternetExplorer4

    Dell sent out an engineer, he replaced the motherboard with a brand-new one. The feedback from the engineer was not good at all, apparently this is a real issue with a lot of dell systems. Now the laptop is getting very hot and switching off after 45 mins or so.  so I will be pursuing a full refund as I have no confidence in the system lasting more than a year which is a real shame but in truth I we got this laptop to play hd movies on our wide big telly through the hdmi and to be honest the performance was average at best, not what we were expecting from a dedicated graphics card with 512mb ram, so enough is enough it has to go back and i want my money back.


  • Had the same, "verifying sector 12" and it froze total with a blowing fan and frozen screen. Could not stop it, nothing works so i took out the battery (while "running"). Placed it back again and crossed my fingers. It works! In the bios setup it shows to be version A09 now.
    This is my first Dell, might be the last and don't like this at all.

  • Dell has revoked the A09 Update and reverted to A08, Me thinks they have had a lot of headaches with this one lol

  • I installed A09 BIOS version without problems but my dvd eject button did not work. I tryed with A08 and get the same result - dvd eject buton just did'n work, so i went back to A07 version. I've got this laptop (STUDIO 1555) for about 1 month and it just doesn't work fine. Two times BIOS went restarted to default setings by himself! And the worst thing is that computer most of the time works fine but from time to time freeze or works really slow. A also noticed (i work with music program - Steinberg Cubase) that i can't record anything, because laptop freeze (when i'm recording) for about 5 second and than works again.. But all of this is happening just from time to time and i really don't know, how i'll explain this (BIOS restarting to default values, freezing, slow booting, slow laptop,...) to authorized service and get my warranty!?!

  • I just tried to update my BIOS from A07 to the A08 release on the website. It stopped at sector 36 I think, and then just sat there. Now nothing, except the CD in the drive spinning. What number is it people have called? I really ned to get this fixed, and get the CD back, as the CD itself is worth more than the laptop. Any suggestions?

  • Thinking of update BIOS from a05 to A11...


    I read a lot of troubles concerning updating BIOS on Studio 1555... is it a safe process with version A11?



  • Yep, updating to A11 did work, a bit...

    After 120 min. still the same screen: Erasing block 9 of 36. So i stopped it (by taking out the battery!) and restarted: now it shows A11
    I do not see any any improvements but it still works. Safe? Not to me.
    Good luck, Thomasvaer