digitalPersona software not functioning with Windows 7 upgrade


Laptop computer Forums (Audio, General Hardware, Video)

digitalPersona software not functioning with Windows 7 upgrade

This question has suggested answer(s)

Hey -

Running Studio 1735, upgraded to Win7 Ultimate from Vista Ultimate (much better - finally). Also running digitalPersona 4.01.3765 that shipped with the 1735. It worked fine under Win7 for a week or so, now suddenly shows red "X" over tray icon. When I start it up it goes to the initial setup screen. I walk through the wizard and get to the point where it asks for my Windows password. Once I enter that, the program closes. Device Manager shows AuthenTec Inc. AES2810 fingerprint scanner under "Biometric Devices" is working fine with 5/1/08 driver ver., which Windows 7 says is the latest driver version. Any thoughts? Thanks for the help. Happy New Year!

All Replies
  • Did you ever get an answer to your question or find a solution?

  • Nope! No reply from the community, and no reply by Dell to countless requests I've made for help.

  • try a internet search (Google) for "Digital Persona Fingerprint Reader Software A" for 32 bit or "Digital Persona Fingerprint Reader Software A" for 64 bit, both has support for Win 7 and IE8.  Used the updated Authentec AES2810, Divers from the Studio 1737. It has both 32 & 64 drivers

    I have a 1735 also and upgraded to Win 7 64 bits and that is what i did to get it working.

    good luck

  • I definitely appreciate the effort but this did not work. Same result that Ive had all along.

    Im running a Studio 1535, with the Authentec AES2810. I downloaded and installed the exact same drivers you mentioned. Currently running version, 32 bit version, and 32 bit Win7.

    I searched and downloaded the file that you mentioned above for Digital Persona. Thats the same software that came with the laptop (just a newer version). Installed it, and same result Ive gotten all along. Digital Persona runs, but does not detect the fingerprint reader. When you click the hand to enroll a fingerprint, it says "Enrollment cancelled. The fingerprint reader is not connected. Connect the reader"

    Device manager shows the fingerprint reader, and the built in windows logon feature is working.


    Any other thoughts?

  • hello there.....i ve vostro 1320....i too ugraded to W7 from vista home basic.....the digitalpersona stopped working after the said that the fingerprint reader was not connected....but the device manager showed the fingerprint reader from ubtek....i checked for the latest driver using the windows7 and it said that the installed driver was up to date...then i went to the dell support and download page and then entered my service tag and checked for the fingerprint reader had a newer what i did was...i uninstalled the driver and the installation software both....then re installed the driver manually....then i installed the latest version of the digitalpersona i.e.. 4.0...and now its working like charm....even works with mozilla 3.6.....

    hope it ll help you....enjoy

    but my problem is with the BT....i ve nt found any solution for installing the driver for W7...plz help

  • I cannot remember if I used the factory disk or I used these drivers.


    Authentec AES2810 (Fingerprint Reader W7 64-bit) <ADMIN NOTE: Broken link has been removed from this post by Dell>


    I installed the Vista drivers in the compatibility mode.


    Right click on the drivers file, left click properties, left click compatibility. Change the compatibility to Vista. Then right click on the drivers, left click run as administrator.





    What is a Dell Service Tag and how do I locate it? 



    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

    Microsoft MVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

  • Try this... 
    I am using the 64bit version on my Studio 1735
  • hi,

    Since i wouldnt find a solution in the DELL portal i tries browsing above. compatible software is in below link.

  the exe

    2. extract exe using win rar

    3. go in to the folder "sp43883" the set up inside that folder.


    this version works perfect in my dell studio 1737 with windows 7 ultimate



  • Thank you for this hint, works perfectly with my Studio 1737 and Windows7 64bit Smile  - as opposite to Dell's driver which does not Angry.


  • I tried the above but as I have Windows 7 32 bit the driver won't work. I've tried uninstalling the DigitalPersona software and the AuthenTec drivers, then reinstalling from the original Dell Vista disks with and without the DigitalPersona software but no joy. This is getting frustrating!

  • This is an update to my previous post. I tried numerous things such as uninstalling the AuthenTec driver, uninstalling the DigiPersonal fingerprint software then reinstalling from my original Vista disks. That did not work. I uninstalled everything again and then used Windows update to find a driver but in no case was Windows 7 able to detect the fingerprint reader. When I looked at the device manager it was  there and working but Windows could not find a biometic device.

    Occassionaly I was able to install the  DigiPersona software but it was unable to detect the finger-print reader. I then spent 2 hours on the phone with a Dell technician who basically went through everything again but this had no effect.

    This morning in my Windows Update there was a new driver from AuthenTec. I installed it and lo-and behold Windows now told me that I had a biometric device. I enrolled my finger-prints but even though I selected to use the fingerprint login in  Windows it did not appear on my log-on screen.

    I then discovered that in my logon screen I had to click  "Switch User" and then my fingerprint logon appeared.

    So it works for Windows login but not for secure logons to various websites. I am using the AuthenTec TrueSuite Starter Version software as obvioulsy DigiPersona 3 or 4 does not work with this reader in Windows 7.

    I will now create a disk image in case I ever have these problems again!




    I have DigiPersona installed on my Dell Studio 1737 Windows 7 Home Premium 64-bit. Drivers I first installed Authentec AES2810 (Fingerprint Reader W7 64-bit), <ADMIN NOTE: Broken link has been removed from this post by Dell> using the Vista Compatibility mode



    Near the clock it shows...


    I then see...

    It then open like this

    Log in and follow the instructions.


    The version I have installed is

    Please note, you can tell this is installed on Windows 7.





    What is a Dell Service Tag and how do I locate it? 



    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

    Microsoft MVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

  • Personal 4.1 --By Firegun93.rar


  • Hi,

    I resolved this issue with installing of this software from sensor manufacturer:

    You need also to have installed in advance Validity sensor drivers from Dell web portal.

    I hope it will help you :)