Laptop computer Forums (Audio, General Hardware, Video)

Latitude E6500 Touchpad faulty?

This question is not answered

Hi Everybody

My first post here so desperately hoping to find a solution to a problem thats rendering my new Latitude "Unfit for purpose"...

The touchpad on my new Latitude E6500 is seriously flakey. So far, I've tried Vista business, and now Windows 7 only to find that the "touchpad" on it is not working at all.

When the laptop boots up at the login screen, the touchpad doesnt work at all, if I try to touch click the login button with no password, nothing happens, yet I can left click the actual button and that works giving me the "Password is incorrect" message, so that tells me the touchpad isnt working "pre-login", yet strange enough, I can click on the "ok" button with the touchpad to acknowledge this error.... weird so far...

So, after I login properly it gets really weird...

I cant click on any icon at all in the taskbar, cant click the windows start menu, no shortcut icons are clickable, both with touchpad and/or buttons, nor with a USB plugin mouse either, and I can NOT select anything on the desktop with a single touchpad tap.

I CAN single & double click desktop items with the pad button, but nothing from the touchpad whatsoever, unless I tap it about 20 times, then it randomly selects or even opens stuff if I keep tapping, making it un-usable.

Now, if i "CTRL/ALT/DEL" I have to double click with the button "Start task manager" but opening then closing my task manager then brings the taskbar to life and I can actually click on the start menu and any quicklaunch icons, but again, not with the touchpad, only with the buttons.

So, I open up the dell website and put my mouse cursor over the "Support for business users" "Start here" button and before I even click, its rapidly opening endless new browser tabs as if I were right clicking and selecting "Open in new tab", and within 10 seconds I have 30 tabs opened...

If I hover my mouse over the end of each tab, its closing them all, as if something is left clicking everything I hover over.
Hovering over the tabs, you can see them flickering as if I were constantly clicking them rapidly, and within about 1 minute, there all closed again.

I have just about had it with this problem now and its getting to the point of throwing the laptop under a bus if I didnt pay do much for it because it renders the entire laptop unfit for purpose.

I have installed all the correct windows 7 drivers direct from the dell website (Eventually, after much clicking and difficulty working with a faulty mouse) and only by un-installing the mouse driver via keyboard, only to find windows installs its own one every time I do this which puts me right back at square 1 again with the same problem, so even the default wiindows driver, and the dell touchpad driver both cause the same problem...

I have tried to get this working with both Vista business, and Windows 7 fresh installs (Not dualboot)

Does anybody have any known working solution for this problem at all?

All Replies
  • Just to add too that I cant drag anything either using the left click touchpad button and anytime I open a window, clicking on it with the touchpad left button actually takes the focus away from that window leaving it totally useless.