base system device driver

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

base system device driver

  • can anyone help please - my daughter has a dell inspiron 1520 - windows vista - had a problem and returned back to factory settings but now keep getting install driver software base system device - i dont know how to put this on or where to find this - i am not very computer literate - any help in simple terms would be very much appreciated - thanks jayne

  • Go HERE. Download this file. Do not use the download manager option when the screen pops up use the download with web browser option.

    After you download it run it to install it. This should clear up your issue

     HomeBuilt SandyBridge P8P67 i7 2600k @ 4.5 ghz 8gigs GSkill Ripjaws. Corsair 800D Case and AX1200 Ps X-Fi Titanium Fatal1ty pro PCIe Sound Card
    Dell Studio XPS 1645  Window 7 Pro

    Forum member since 2003

  • hi - thanks Dave for your reply - if you could explain to me please where i can find the file to download for the base system device - thanks very much - jayne

     

     

     

  • I fixed the link, just click on the word HERE in my posts

     HomeBuilt SandyBridge P8P67 i7 2600k @ 4.5 ghz 8gigs GSkill Ripjaws. Corsair 800D Case and AX1200 Ps X-Fi Titanium Fatal1ty pro PCIe Sound Card
    Dell Studio XPS 1645  Window 7 Pro

    Forum member since 2003

  • thanks very much - the link worked - base system device warning no longer coming on computer = thank you - jayne

  • you are welcome glad to hear it is fixed.

     HomeBuilt SandyBridge P8P67 i7 2600k @ 4.5 ghz 8gigs GSkill Ripjaws. Corsair 800D Case and AX1200 Ps X-Fi Titanium Fatal1ty pro PCIe Sound Card
    Dell Studio XPS 1645  Window 7 Pro

    Forum member since 2003

  • thank you for your previous help - i have now spent hours and hours on my daughters computer - thanks to you have now sorted base system device driver - have now got error code 0x80072efe whenever i try to update - any help please would be very greatly appreciated - thanks jayne

  • Hi...Dave I'm using a dell 1520 with windows 7 and im also having the same problem but the link you provided is for windows vista 32 bit.

    Is there a driver for windows 7 64-bit.?

    thnx

  • Hi Halsrc,

    Dell does not list Windows 7 drivers for your laptop. You may need to use a third party device driver.

  • try the driver. Most times if a new drive is not available the one listed will work just fine. Also most of the Vista drivers will work fine under win 7.

     HomeBuilt SandyBridge P8P67 i7 2600k @ 4.5 ghz 8gigs GSkill Ripjaws. Corsair 800D Case and AX1200 Ps X-Fi Titanium Fatal1ty pro PCIe Sound Card
    Dell Studio XPS 1645  Window 7 Pro

    Forum member since 2003

  • I have an XPS l502X win7-64 with the same base system device error message:

    any ideas?

    thanks so much,

    Steve

  • Hi Steve,

    Here are your drivers. Since you haven't really explained what you're doing, I'm not sure how to help.

  • Under your driver listing there are four drivers listed under the Chipset. Download and install all four of them.

     HomeBuilt SandyBridge P8P67 i7 2600k @ 4.5 ghz 8gigs GSkill Ripjaws. Corsair 800D Case and AX1200 Ps X-Fi Titanium Fatal1ty pro PCIe Sound Card
    Dell Studio XPS 1645  Window 7 Pro

    Forum member since 2003

  • Im having the same issue as steve with the four "base system devices" and the one "uknown device".

    It arose after  i formatted and installed Windows 7 on my Studio XPS 16 laptop. I've been to the support-pages and downloaded what i could find under "chipset" for my computer. (Intel-Driver and Ricoh-Driver). But the problem still percists. The problem is that I dont even know what these devices are so I cant even begin to look for third party drivers. 

    Anyone have any ideas?  

  • I just noticed that the Richo-driver got rid of the "base system device" problem, but the "unknown device" still remains. Any ideas on what that could be?