Inspiron 1545 Num Lock

Laptop

Laptop
Laptop computer Hardware and Software discussion

Inspiron 1545 Num Lock

This question is not answered

I know this seems odd since the 1545 has no numeric keypad, but my 1545 insists on setting num lock to "on" no matter what I do to turn it "off".  I am trying to remove a useless icon in the Notification Area which is part of a Dell Tech Support solution (we used to call them "solutions" to our customers, too, but called them "work-arounds" among ourselves).  It was their response to an on-line request I submitted outlining the problem I also submitted on this forum in http://en.community.dell.com/forums/t/19298983.aspx .  It is still not the answer I want, but is the only game in town so far.  I am taking still other avenues to solve the original problem.  Stay tuned......

I have turned num lock off in the registry both in the current user and the .default areas (several times!)  The BIOS settings for the 1545 have no means to enable or disable any of the toggle keys.  That means some piece of software, probably from Dell, is setting the num lock status to "on" during Vista initializaiton.  It actually changes the registry entry InitialKeyboardIndicators back to status 2, numlock on, in the current user settings.  If I remove the entry entirely, whatever it is, puts it back.  Set “wrong”, of course

Can anyone tell me what software is doing it, and if I can affect how it handles the num lock key without doing myself in on other services I might actually want?

I hate to say it, but this is the tenth computer (my fourth Dell) since my Apple II in 1981, and is the only one with which the more I use it, the more I am disappointed.  I hate that.  New toys should always be fun, not frustration.

As I indicated, the answer from Dell is less than satisfactory on several accounts, not only this unwanted icon.  But it does nothing to return the"radio" or "battery" buttons to their original function, either.  However, if you are interested in this Dell-suggested work-around to the missing caps lock indicator, it can be downloaded at http://tinyurl.com/omqx3y

All Replies
  • It is the Dell Quickset options that are doing it.  Dell did alot of things that caused me problems.

    You will notice that the Caps lock or Num lock displays briefly what looks like an A in a padlock.  You lose the window you are typing in, and have the reverse problem when trying to go back to lowercase.  I found it horribly frustrating and no one anywhere seemed to know how to simply turn it off.  Suggestions were being made to uninstall it, but I feared that would make me lose something valuable in Quickset. 

    Here is what I figured out for Windows 7 to very very easily change the Caps/Num lock issue:

    Right click on the Desktop.  Select Personalize in dialog box.  In lower left, select "ease of access center".  When that opens, select 'make the keyboard easier to use'.  When that opens, click 'turn on toggle keys' (puts a check mark by it).  Click button to Apply change, then OK and close the window.  All done!  Note that now when you type, the A button will still show but it will make a noise and go away in a second, but typing is now normal.  At least what I consider normal for my typing! 

    more tidbits I encountered..

    I had problems with the mouse doing what seemed like crazy stuff too.  I had to turn off the Enable Zoom option, under Mouse settings, Dell Touchpad, Scrolling & Zoom settings.                                                                                                                                                                                                                                                  

    I also had problems with the Function keys being backwards from what I am used to.  Inspiron 1545 comes configured for Multimedia Fkeys.  You can drill down to the quickset program to change it - in Program files, Dell, Quickset, then right click the quickset to either create a desktop shortcut, or pin to taskbar.  Then open it and you can change the 'Function key row' to set as Function keys instead.  I did it by changing the BIOS (using F2 while Windows was coming up).  This looks to be a much more user-friendly way to accomplish the same thing. 

    Another note: Control panel is much easier for me to use with Small Icons instead of by Category.  Right click to switch that any.

    GOOD LUCK!!

     

  • I had the problem with Outlook.  I went to Tools - Options - Mail Format tab.  For 'compose in this message format' - changed from "HTML" to "Rich Text".  Problem gone!

  • I had the same problem.  It took me an hour of looking around to find out. Right click on the desk top and select personalize. Bottom left you will see "ease of access centre". Select this, then click "start on screen keyboard". You may have to select show numberic key board, but there you will see a number lock key on screen. If it is highlighted white, click with mouse and it will become black, and that's it, your number lock is off.  Better still it appears to keep this setting when you turn off and reboot. 

    How happy was I to find that!