Caps lock popup and icon on Inspiron 1545 - General Hardware - Laptop - Dell Community

Caps lock popup and icon on Inspiron 1545


Laptop computer Forums (Audio, General Hardware, Video)

Caps lock popup and icon on Inspiron 1545

This question is not answered

The caps lock and “radio” popups and the caps lock icon on my new Inspiron 1545 are presented as expected sometimes and at other times do not appear.

I am a touch typist, so it is most frustrating when trying to enter complicated passwords on a new, unfamiliar, keyboard and being told the password failed. I have to type a letter in a non-masked field someplace to see if caps lock is on. Searching The Internet and Dell tech support and forums has given no solution. I see that many questions are about how to turn them off. (It is beyond me why one would want to do that, but “to each his own”.) I also see that many of the “solutions” are simply SWAGs.

The one common thread seems to be quickset, and I thought it was the proper one since several times I have executed and closed it and the popups and icons worked properly. It appears that is not really the solution, since today they are missing again after a required re-boot for some Microsoft updates and quickset has no effect. The last time I got them working (?somehow?) they stayed stable for 3 days. Today nothing I try works.

I am an experienced user with over 30 years experience in aerospace software development, so this is frustrating the daylights out of me and at my age I can’t afford to kick up my blood pressure on stuff like this.

Can anyone tell me what software enables the caps lock popups and icon?

All Replies
  • Hi , I got the tray Icon to work for the Caps lock key. Find the following exe file, C:\Program Files\Dell\QuickSet\quickset.exe. When it is running I get the notification in thr tray area that Caps lock is on. I ended up adding it to the registry under local machine/software/microsoft/windows/current version/run. I added a new string value and just typed in C:\Program Files\Dell\QuickSet\quickset.exe. works all of the time now.

  • Thanks for replying.  It is strange, since that is the first thing I tried and at first I thought it did the job.  Of course, I was also looking for the popups that initially appeared when I toggled those keys.  Do you get those as well as the icon?

    I even put quickset in the Start > All Programs > Startup menu structure now.  But it appears to do nothing on my computer!  I wonder what the difference is?  My computer was shipped about 6 weeks ago and I am running Vista Home Premium.  I don't have anything too exotic running, a wireless/wired network (the 1545 wireless), with no external hardware connected to the 1545.  I wonder why the difference between the two.  The only thing I can think of right off hand is that you are running a different version of quickset.  Mine is v (from the Details section of the Properties for the executable) with a date of 3/26/2009.

     Dell Tech support suggested a solution which provided an icon (but including num lock which I don't want - see ) but I still have no popups and the "battery" key still doesn't work at all.


  • Dell has come through for me and I am happy again.  I got a phone call in response to a letter to corporate headquarters outlining the problem.


    The solution to the problem indeed involved Dell Quickset.  For whatever reason, the keyboard-support portion of Quickset had become corrupted or disabled.  Even more mysterious is that it “healed” for three days then fell apart again.  I have to wonder if something was catching the keyboard interrupts and overriding the Quickset driver.


    The eager-to-help lady who called had me download and install Quickset and everything works as it originally did.  The popup comes and goes and if the status is locked, the icon appears in the Notification Area.  The “radio button” also displays its popup and the “battery key” again brings up the Battery Meter window.  It sure keeps me aware of what I have done to the Caps Lock key.


    The software is well behaved and does not cause a change of focus on any of the software I have run since.  I wonder if the users voicing concerns about that were using an earlier version of Quickset, or perhaps some software, maybe games, do switch focus.  For me, the behavior is exactly what I want.


    (I had come close to solving the problem myself in that I had downloaded the latest version of Quickset, but on noticing it was the same version as I was currently running I did not do the installation.  As a matter of fact, when I saw that, I even uninstalled Quickset to see if that would help.  It didn’t.  Like they say, “Close only counts in ….”)


    “How to” Steps…….


    Search for R197947.exe


    Download (I saved a copy to have it at hand in the event the problem recurred.), and then run the downloaded executable.  Mine gave several warnings during the execution because Quickset was already on the computer, but it proceeded to install and worked properly.