M1330 battery light flashing red - General Hardware - Laptop - Dell Community

M1330 battery light flashing red


Laptop computer Forums (Audio, General Hardware, Video)

M1330 battery light flashing red

  • I have a XPS M1330 laptop. Its battery light in the front is constantly flashing red. The battery is not charging at all. No other issues. Does this mean the battery needs to be replaced, or is there something more to it?

  • If the like on the adapter is on then one has to go with the battery.  I would get a new one

     Home Built Sandy Bridge P8P67 i7 2600k @ 4.5 GHz 8gigs GSkill Ripjaws. Corsair 800D Case and AX1200 Ps X-Fi Titanium Fatal1ty pro PCIe Sound Card
    Dell Studio XPS 1645  Window 10 Pro

    Forum member since 2003

  • I also have an XPS M1330. It has been working well for years until the other day. I always (95%) use mine plugged into power. I turned it on and the battery light started flashing sequences. Blue - flash once and Red - flash five times. I was unsure of reasons and did some fault finding.

    When I used the laptop with "battery only" it continued to flash in the sequence given above. When I removed the battery and used it with "power only", it didn't flash at all. I presumed it was a battery problem but didn't really want to replace it with a new one so decided to try some charge discharge to see whether something had lost it's place.

    After some searching on the internet, I came across a post that gave me instructions to try. They worked although there may still be a time in the future that I need to replace the battery. Below are the steps:

    1. Remove the power adapter and run the laptop until the battery reads "empty". I needed to restart once or twice as the laptop turned itself off with 3% of power remaining. I turned it back on and let it run to 0% and it switched itself off.

    2. I left the laptop off and then removed the battery and let them sit apart for 10 mins (still off).

    3. I then replaced the battery and recharged it. The blue charge light stayed on unitl 100% and then no lights. WooHoo, the problem resolved !

    4. I then went through the discharge/recharge cycle again as was suggested and there was no change. It still all works fine.

    I hope this helps any others.

    Dell XPS M1330 and Dell SX260

  • Well I thought I had solved the problem. But alas, the red light started flashing again.

    I attempted to cycle the battery as described above 5 times but to no avail. I have now ordered another battery and when it arrives and I install it, I will update the progress.

    Dell XPS M1330 and Dell SX260

  • Yep, that was the problem. I purchased another battery and installed it. All works great now.

    I've stored the old battery as it still charges and holds charge. You never know when things come in handy.

    Dell XPS M1330 and Dell SX260

  • I am having the same problems with my 1300. I figured it was the battery, since it was 3 years old. I purchased a new battery but the battery light is still flashing red. It was green when I first installed the new battery but after about 10 minutes it started flashing red again. Any ideas?

  • Verify that the battery is a genuine Dell battery - not a third party one.

    If it is, remove the battery, unplug the system, hold the power button for 30 seconds.  Then install the battery and see if it will charge.


  • In my case, the red light still flashes and the battery is 100% charged according to the bios. I tried the above, no luck. Previously and still now, I have a message in the bios that he battery health says the system cannot communicate with the battery. On the back of the laptop, there is a small magnetic tape to the right and left of the connector. One of them was very bent and I only noticed it after I got the red flashing light. I tried to bent it back to shape and a piece tore off. Still, I cant use the laptop on battery. Any ideas?

  • OK, I had the same problem, tried to no avail all the solutions I could find on the net, clean contacts, charger (had 3), disable/delete ACPI driver, etc. nothing worked.

    It appears it charged for about 10s on each plugin.  That leads me to think its a software issue rather than a hardware issue.  I put a PLC with a simple on/off timer for the computer power supply as a test.  After about 500 cycles (10s on -> 5s off), the battery charged to >75%, then it would charge normally so I paused the PLC and it charged to 100%.  I'm going to do some more test, like run the battery down and try again.  I'll let you know how it works.