Dell Latitude E6400 Bluetooth issue

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Dell Latitude E6400 Bluetooth issue

This question is answered

I have the Dell Bluetooth 370 Mini card and the bluetooth bus enumerator install and as shown in the windows xp device manager, and the BTTray was on the taskbar.

But when i right clcik to enable bluetooth radio, it prompt and say : "Activate bluetooth using Fn+F2 or Radio On/Off Switch" but the bluetooth blue light indicator was on.

I try reinstall driver many times but did not resolve the issue and even switching off and on the switch on the side, still not working. Its really frustrated as the bluetooth is not working.

Anyone know how to resolve this issue?? Need hep badly. Crying

Verified Answer
  • Partial solution, perhaps:

    Environment: E6400 with Win XP SP3.  370 Mini card.

     

    Symptoms were identical to above including activation prompt.

    Turns out that the 370 driver upgrade from Dell did not upgrade the driver but the control application (WIDCOMM).  Also, Microsoft BT stack/driver still installed, redundantly.

    Approach:

    1) Use Add/Remove Programs and remove the WIDCOMM software.

    2) Command prompt, then run DEVMGMT.MSC, then enable View/ Show Hidden Devices

    3) In the device manager, delete everything under Bluetooth Radios - that is the Microsoft Bluetooth JUNK.   At this point, since you did step (1) you should have no Bluetooth devices left.

    4) Also, delete every single serial (COM) port associated with Bluetooth.  Really. You may be surprised to see a whole bunch of them. They are Microsoft JUNK BT driver leftovers.  These are the reason you may have experienced ever-increasing COM port numbers when fooling around with BT on your workstation.  Mine got up to COM25.Angry

    5) Reboot your machine.

    6) Reinstall the WIDCOMM software by downloading the 370 Minicard driver latest from Dell for your OS.  For XP, the version will be 5.5.0.6100.  Differs for other OS.

    7) repeat step (2), examine devices.  You should have a Bluetooth device shown.  You should have no Bluetooth serial ports however ( probably)

    8) Depending on your client application etc. you can now add some BT serial ports to use for ActiveSync or whatever.  That is too hard to discuss here. These will have reasonable COM port # like 5 and 7.

    9) Death to Microsoft BT drivers...Devil

     

     

     

All Replies
  • I got exactly same issue.  Before I installed this package, no bluetooth device found and BTTray failed to load.   After installed R216460, bluetooth device showed up in device manager and BTTray was running.  it prompts "Activate bluetooth using Fn+F2 or Radio On/Off Switch".  On E6400, F2 is defined as enable/disable battery charge, nothing to do with BT device.  Radio On/Off switch can control the LED indicator on/off.  But even it's on,  in BTTray configuration, diagnostic tab, it still says "Devices not found".   How could I fix it?

     

  • I am having the same problem with a Latitude E6400, 370 card.

    I download the driver, unzip it and run setup.  I get a dialog box that says "Activate bluetooth using Fn+F2 or Radio On/Off Switch"

    So did you get past this hurdle?

    Cheers

    Kilgore

  • I'm having the same issues described above by others and can't seem to find any documentation to fix this issue.  The Bluetooth on my Dell Latitude E6400 is completely useless at this point.  Any help would be greatly appreciated.

  • I am having the same problem. Running Windows 7 64 bit. First I installed the Dell Wireless 370 Bluetooth Minicard driver 6.2.1.100, A17 and the bluetooth was working fine. I then installed a Logitech setpoint driver in order to configure my Logitech bluetooth mouse. After installing the setpoint driver the bluetooth has not been working the bluetooth indicator light is turned off . I have tried to restore windows from a restore point before I installed the setpoint driver. This has not sold the issue - the bluetooth light is still turned off.

    I have tried to remove the bluetooth driver and install it again and during the installation I am asked to activate bluetooth which I cannot. The only option is to cancel the driver installation.

  • Found the solution:

    I performed a manual firmware upgrade of the Bluetooth device by running the following program: C:\dell\drivers\R226750\R226750\Win64\svcpack\SetupBluetoothDFU.exe. The program will prompt you for a ".dfu" file which is located in the same folder C:\dell\drivers\R226750\R226750\Win64\svcpack.
    After updating the firmware the Bluetooth is now working again:-) 

  • Partial solution, perhaps:

    Environment: E6400 with Win XP SP3.  370 Mini card.

     

    Symptoms were identical to above including activation prompt.

    Turns out that the 370 driver upgrade from Dell did not upgrade the driver but the control application (WIDCOMM).  Also, Microsoft BT stack/driver still installed, redundantly.

    Approach:

    1) Use Add/Remove Programs and remove the WIDCOMM software.

    2) Command prompt, then run DEVMGMT.MSC, then enable View/ Show Hidden Devices

    3) In the device manager, delete everything under Bluetooth Radios - that is the Microsoft Bluetooth JUNK.   At this point, since you did step (1) you should have no Bluetooth devices left.

    4) Also, delete every single serial (COM) port associated with Bluetooth.  Really. You may be surprised to see a whole bunch of them. They are Microsoft JUNK BT driver leftovers.  These are the reason you may have experienced ever-increasing COM port numbers when fooling around with BT on your workstation.  Mine got up to COM25.Angry

    5) Reboot your machine.

    6) Reinstall the WIDCOMM software by downloading the 370 Minicard driver latest from Dell for your OS.  For XP, the version will be 5.5.0.6100.  Differs for other OS.

    7) repeat step (2), examine devices.  You should have a Bluetooth device shown.  You should have no Bluetooth serial ports however ( probably)

    8) Depending on your client application etc. you can now add some BT serial ports to use for ActiveSync or whatever.  That is too hard to discuss here. These will have reasonable COM port # like 5 and 7.

    9) Death to Microsoft BT drivers...Devil

     

     

     

  • Oops, forgot to mention that the BT indicator light is not necessarily on after this.  There is some other problem about that which I cannot resolve yet.  However, BT tray icon is available to confirm it is on.  Also, forget the FN+F2 thing - that will never work on E6400.

     

  • This is the same issue I am having (less the Logitech setpoint install).
    System: Latitude E6400
    O/S: Windows 7 x64  

    Solutions I've tried to no avail:

    • Checked that bios was configured properly with Bluetooth activating via the switch.
    • Attempted to reinstall driver software
    • Attempted to update bluetooth firmware

  • There is a button on the right side right next to a sliding switch which should all you to continue with the install,

    I first thought it was the sliding switch as well, but one press of the button and I was installing my bluetooth driver.

  • Hi

    I cannot get this device to work - even though I follow the instructions in the approved Dell answer :-(! On my computer there are no Microsoft Com ports and no BT devices to delete - only the one installed using the WIDCOMM software.

    I can get everything to work when I install - but then after a reboot - it doesn't work anymore. Then I try to right-click the BT icon to activate BT and it tells me to use the radio button or Fn+F2 - none of these two solutions work :-(

    Is there another solution?

    Peter

  • Hi,

    Same issue in my case. Not able to switch the bluetooth device on. The solution provided does not work for I neither have list of ports nor bluetooth devices in my device manager. Happy to get proper solution from dell for it seems to be a generic problem. Waiting for fast feedback.

    thanks & regards

    Pawel

  • Check your BIOS settings if Bluetooth is enabled in your wireless devices.

    Good Luck

    Lucky Luck

  • Hi,

    I went to the list of the services and I have manually started the service called Bluetooth Support Service and BT has started working properly. So I have change the start of this service to be automatic.

    Hopefully it will help to you also.