Systemic problem with internal keyboard on Inspiron 1545

Laptop

Laptop
Laptop computer Hardware and Software discussion

Systemic problem with internal keyboard on Inspiron 1545

This question is not answered

When I got my new laptop a few week ago, I quickly noticed that the control key would fire-off randomly as I typed (for instance, typing the word "ate" in a IE would select all text (ctrl+a), open a new tab (ctrl+t), and send me to the search box (ctrl+e) despite my not pressing the control key at all). I spent some time with Dell technical support updating keyboard drivers, BIOS drivers, and running in-depth tests of the keyboard, and their conclusion was that this was a hardware issue, so I opted to use my 21 day window and get a replacement.

Well, the replacement came today, and it has the exact same problem, which leads me to believe this isn't just a random hardware error. I'll try to provide as much information as possible about my computer's build and what I did with it to help you guys with locating any potential problems:

Build (copied from shipping label):

-Inspiron 1545, Intel Core 2 Duo T6400, 2.0GHz, 800 Mhz, 2M L2 Cache

-4GB, DDR2, 800MHz, 2 Dimm

-Bright, Glossy, widescreen, 15.6'' display

-256MB ATI Mobility Radeon HD4330

-500 G 5400RPM SATA Hard Drive

-Vista Home Basic SP1

-9-cell battery (which, BTW, I took out and let cool per the troubleshooting instructions if keyboard is totally non-functional)

 

What I did with it since turning it on:

-Looked at basic setup info (F2 in boot up), only changed time

-Set Vista preferences, created account

-Connected to wireless internet

-Installed theft-protection

-Set Yahoo as hompage; installed Yahoo toolbar

-Set favorites (first occurence of glitch in middle of this process)

-Revisited Dell-Support

-Turned off; removed battery, and let cool

-Allowed automatic updates to install

-Registered with MacAfee

-Updated (or attempted to update) any marginally relevant drivers

-Came here

 

Again, because this has happened with two seperate computers, I think it is not just a production error, rather that it stems from one of the following:

-Some problem with my computer's build

-Some action I took

 

I would appreciate any help and suggestions you can provide. Thanks!
-Andy

All Replies
  • Go to Control Panel, Regional and Language settings, Keyboard and make sure your correct English version is selected. Also recheck the Keyboard settings in Control Panel, Hardware.

  • Andy,

    I'm having the same problem with my Inspiron 1545.  I purchased mine back in April, but the problem did not begin until late May. I called Dell Tech Support and after I convinced them the problem was not software related, they helped me replace the driver.  This worked for awhile, but now the problem has resurfaced.  The one thing that I have discovered is that the issue does not occur with an external keyboard.

    So far I have not had successful help from tech support.  So if you resolve the problem, I will be very interested in knowing how.

    -Mary

  • I found an older thread shortly after posting this (while waiting for tech support) that solved the problem. Apparently, the default settings on the touchpad include a zoom in/out function accessed by touching the extreme left side of the touchpad. Because doing this also functions as a control key press (holding ctrl and scrolling with a mouse will have the same effect), brushing your hand against the pad while typing makes the control key fire randomly. Just access options for the touch pad (it should have an icon in the taskbar) and turn off the zoom function. It's worked for me so far. I'm just angry that tech-support was unable to provide the same solution before I went through the trouble of replacing a computer that was not at all defective, especially because this seems to be a problem lots of people are having.

  • awjordan"[quote user="awjordan

    I found an older thread shortly after posting this (while waiting for tech support) that solved the problem. Apparently, the default settings on the touchpad include a zoom in/out function accessed by touching the extreme left side of the touchpad. Because doing this also functions as a control key press (holding ctrl and scrolling with a mouse will have the same effect), brushing your hand against the pad while typing makes the control key fire randomly. Just access options for the touch pad (it should have an icon in the taskbar) and turn off the zoom function. It's worked for me so far. I'm just angry that tech-support was unable to provide the same solution before I went through the trouble of replacing a computer that was not at all defective, especially because this seems to be a problem lots of people are having.

    I've just found this thread having spent hours on the phone to Dell trying to resolve problems whilst trying to write my masters dissertation on a computer I couldn't type on.  They sent an engineer today to change the keyboard and controller and it worked fine for my daughter (who types with two fingers) but as soon as I tried, it did the same thing again.  I phoned to try to get a refund but I couldn't get one - it has to be within 7 days and I'd spent nearly 6 weeks trying to get it sorted out.

    I was going to send it back to Dell to get resolved but decided to look again and thought it must be something about my typing style - I've seen some posts which suggest that the computer is not suitable for typing - not sure what you are supposed to do with it?

    I altered the touchpad sensitivity which made it much better and then read this so have disabled the zoom on the touchpad and now it seems to be working fine

    Ive just written an angry note to dell customer service suggesting that they pass this onto tech support so that other's dont have the same problem

  • Wow, I'm having them come and replace my keyboard for the 4th time on Friday.  Maybe I should try this solution.  I can't believe that the Dell Chat representatives have no idea about this problem. 

    Matt

  • I'm wondering if you still think this is solved "so far"  I looked, I don't have the zoom on my touch pad, but I did update the drivers.  And I even tried turning off the touchpad and using and external mouse.  I can still put the computer into "control-lock" mode.  Where every key I hit is modified with the control character until I hit left control again.  It's also only the left side.  If I'm in control lock and I hit the left control it always takes me out of it immediately.

     

    I'm on a Studio 1535 though with a backlit keyboard and a remapped caps-lock to Control_L.  I'm bummed, I thought you had the solution for me.  We will see what happens when they replace the keyboard for a 4th time...Technically this is only the 3rd replacement, the first one came with the laptop.

     

    Matt

  • Matt,

    It seems to have solved the problem I was having with my 1545.  I use the keyboard on a regular basis now, which is something I couldn't do before.  So far (cross my fingers) the problem has not resurfaced.

    -Mary

  • I tried all that is said on here and the typing is still iffy, it took 3 attempts for my password to type right to do this message,, my 1545 had multi issues from new 3 weeks ago, blue screen error, touchpad issues, keyboard problem, pop up random dialogue boxes and menus, dropping connection, slow responses, lagging typing, slow ie8, and it is sitting in the same room as an inspiron 1300 that seems like lightening in comparison.  I am not happy - It goes back for "repair" today, and I have to go back to uni soon.

  • I have the same problem with my 1545 that I bought in July 09.  When I type fast, my curser moves to a random location and then erases the text where it lands.  If I do not notice, I may have to retype a lot of stuff.  Very frustrating.

    Unfortunately for me, I bought two of these for my office.... : - ((

    I do not know if I can handle, emotionally, calling Dell tech suppport again....  I do not know what to do???

  •  

    So far, my issue was fixed by changing the default settings on the touchpad as awjordan suggested.  See below:

    ***********************************

    Re: Systemic problem with internal keyboard on Inspiron 1545

    I found an older thread shortly after posting this (while waiting for tech support) that solved the problem. Apparently, the default settings on the touchpad include a zoom in/out function accessed by touching the extreme left side of the touchpad. Because doing this also functions as a control key press (holding ctrl and scrolling with a mouse will have the same effect), brushing your hand against the pad while typing makes the control key fire randomly. Just access options for the touch pad (it should have an icon in the taskbar) and turn off the zoom function. It's worked for me so far. I'm just angry that tech-support was unable to provide the same solution before I went through the trouble of replacing a computer that was not at all defective, especially because this seems to be a problem lots of people are having.

    *************************************
    I use my Inspiron 1545 for school and regularly type with the laptop keyboard.  I also use the touchpad as my mouse, so changing the settings as suggested does not cause the touchpad to stop functioning.   Hopefully this will help your issue.  If not, try using an external keyboard.  On my Inspiron, before I changed the settings, the probelms would not occur when I used an external keyboard.
    Hope this helps.
    -Mary
  • Unfortunatly, I had significant problems with this computer no one could fix so I reinstalled vista.  It fixed my problems, but I do not have a dell touch pad control now.  Any thoughts on that?
     
    Thanks in advance.
  • awjordan:

    I JUST got my 3-month old 1545 back from Dell repair.  I put up with my left control key working intermittently until I was positive it wasn't ME goofing up.  Sometimes I got what I was cutting/copying/pasting - - sometimes I got a small    x   c  (or)   v   .

    BestBuy GEEKs were ABLE to duplicate the problem (where I turned it in to sent it back to Dell).  Dell replaced the keyboard.  When I got it back I only typed a few sentences (doing my CNTL x/c/v tests) and the problem was still there!??!?!!!  &^#&$&#!

    I took your suggestion and turned OFF the ZOOM in the touchpad - SO FAR SO GOOD !!!!  [ test time 1 hour ].  I can't make it screw up.

    I will pass this on to the GEEKs at BestBuy so they can keep more customers happy with their new perfectly good 1545 laptops.  I had to do without my laptop for 14 days during this needless "repair" - what a pain.

    Thanks for your post awjordan!

    DELL - SEE THIS ???      THIS IS AN EASY FIX !

    Paul4507

  • I have nearly the same computer with a Logitec Bluetooth mouse.  My keyboard skips keystrokes at random intervals.  It is particularly problematic on certain websites, like Facebook, but it happens all the time in every application.

    Mac

  • I've had the same problem with my 1545 since buying it in July, along with the laptop just locking up and only being able to restart it again by turning the power off. But as for the keyboard problem, I ca't find  the touch pad icon on the taskbar even when I expand it, it's just not there. I've looking in control panel for the touch pad but nothing there either?

  • For touchpad settings look under the mouse icon on control panel.  If you have an external mouse, you should x the disable touchpad device when an external mouse is present setting.