Studio 15 (1555) keyboard function keys

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Studio 15 (1555) keyboard function keys

This question is answered

Hello!

 

I just got a brand new Studio 15 and am a little frustrated at the function keys - it seems that (by default) all the function keys are the alternate functions and in order to get my oh-so-useful F1,F2...F12 keys I actually have to press the Fn button.  Please tell me that there is a way to reverse this behaviour.  For example in order to close a window I should just be able to press ALT-F4 instead of ALT-FN-F4.  I would much rather have to press Fn-F4 to lower the brightness and ALT-F4 to close.

Also why are there no status LEDs at all?  I miss my hard drive/battery/power LEDs :(

Thanks for any help!

Verified Answer
  • I think there is a setting in the bios that will reverse this behaviour. I am waiting to take delivery of my 1555, and this is the first thing i will be doing.

    Regards


    Chris

     

All Replies
  • Look for an F Lock key in the top row. That toggles between the 2 functions. Check other keyboard settings and help in Control Panel.

  • Thanks for the reply, however I have already checked.  I see no function-lock key and there is nothing in the control panel or keyboard settings to control this.  Any other ideas?

  • I think there is a setting in the bios that will reverse this behaviour. I am waiting to take delivery of my 1555, and this is the first thing i will be doing.

    Regards


    Chris

     

  • Hooray!

     

    I was certain that Dell would have a software app (i.e. quickset) that would allow this change, but apparently not.  Switching it in the BIOS worked!  Thanks!

  • Hi,

    I have the same issue, I want to press the Fn button to get to the volume etc and have the F buttons work as F1, F2 etc. I am a total novice, can you post step by step instructions for finding the BIOS and changing please?

  • Hi 7snowsurfer7

    I can give you instructions for part of the way,  but once you are in the bios i cannot direct you.  The reason for this is I haven't taken delivery of my Studio 15 yet. Hopfully the setting should be obvious. However, DONOT alter any other setting in here as you might cause problems. If you are not sure, and have a techy friend, get them to do it for you.

    Warning aside,

    First of all make sure you power off your laptop (if the laptop is in standy, you cannot get into the bios).

     You have a very short window of opertunity to enter the bios. If you see the normal "loading windows" screen, you have missed it and will need to shutdown the computer again. 

    Press the power button wait until the Dell logo appears and then press F2 (or F12). 

    If it has worked, you should be confronted with a text based screen with various options and details about your computer. As an aside the mouse pad will not work and you navigate around the bios with the cursor keys. Left and right generally moves between different options pages at the top of the screen (General, advanced, etc), whilst up and down will allow you to navigate between options within a page. Either pgup/pgdn or + - will allow you to change these options (there is normally some very limited help on the right hand side that tells you what you need to press to alter the settings). As i don't know what page the F key behaviour setting is on, you will have to browse each page in turn until you find it. Once you have changed the setting, there should be page with options such as

    "Exit Discard Changes"
    "Exit Save Changes"
    "Load Defaults"

     Choose exit save changes. Your laptop will exit the bios and reboot.

    I will be able to give more accurate details once i have my laptop, which should hopefully be next week. 

    Hope this helps

    Chris 

     

  • The BIOS setting is easy to find (under Advanced) and did indeed swap the key priority back to FN.

    However 2 days later the BIOS reverted to multimedia setting. I've reset it again and keeping fingers crossed.

    Dell Studio 15 / Windows 7 HP 64-bit

     

  • This worked fine.  Now where is the bios setting to make the labels on the keys "F1, F2, etc" have high contrast so I can see which is which without leaning in and squinting...  blue on black... really?

     

    Chris

  • Yes, You can change that I did. The change is in the Bios.

  • I just found a solution that does not involve making a change in the BIOS.

    I have a Studio 17 laptop with Windows 7.  There is a soft button that look like two gears above the keyboard.  That will bring up the Windows Mobility Center.  One of the options is to change the Function Key Row. (You can also use Search to find the Windows Mobility Center)  

  • Thanks a lot - that did the trick and it was much easier than having to alter the BIOS. I didn't have that soft button, so just searched for Windows Mobility Center as you said and two seconds later I'd changed it.

  • You can chage this in the BIOS. When you turn on your computer, go into setup (usually F2), then under one of the settings, I don't remember exactly which one, you'll see an option to change whether the keys use the funtion or media controls first.

  • Thanks a million, that was really annoying, Thanks to your advice, it's been solved now. Searched for Windows Mobility Center and switched the function.

    Thanks again :)

  • I dont get this option when I open up the mobility center. Furthermore, i press te fn+f2 keys but it does not allow me to get into the BIOS. The only thing it does is turn off my wireless connection. anybody out there have any bright ideas? I have already updated everything that was needed going by my service tag. All i need to do is make sure my RS232 port is working properly...but thats a whoooooole other problem.

     

    thanks, any help would be appreciated

  • Mr_bojiggler

    I dont get this option when I open up the mobility center. Furthermore, i press te fn+f2 keys but it does not allow me to get into the BIOS. The only thing it does is turn off my wireless connection. anybody out there have any bright ideas? I have already updated everything that was needed going by my service tag. All i need to do is make sure my RS232 port is working properly...but thats a whoooooole other problem.

     

    thanks, any help would be appreciated

    That's right, no option in the mobilty centre.

    But here is what worked for my 1555:

    • Shut down your laptop (not slumber/hibernate)
    • Hold down the F2 key while turning on your laptop (do NOT pres <Fn> key while pressing F2, since this will start a laptop check that takes 45 minutes and will NOT get you into the BIOS)
    • In the BIOS screen choose Advanced
    • Change the Function keys pre-set to the option you want by pressing the <space> bar (you don't have a numeric keypad, so no +/- key)
    • Leave the BIOS screen while saving your changed configuration

    Of course: be careful when you change the BIOS-setting, so leave the other options alone and don't save your changes unless you are absolutely sure that nothing else is changed.