Roxio Creator DE all your drives are set to disable. - General Hardware - Laptop - Dell Community

Roxio Creator DE all your drives are set to disable.


Laptop computer Forums (Audio, General Hardware, Video)

Roxio Creator DE all your drives are set to disable.

This question has suggested answer(s)

Cannot open my OEM Roxio Creator DE. Notice says: 'All our drives are set to disabled. On this operating system, in order to start Roxio Creator DE you must either physically remove your drives or enable at least one drive.' Occurs on my Dell Inspiron 1521, Vista 32 bit. I know many are having this problem, but can anyone tell me how they fixed it?

Thanks for your help/

All Replies
  • I am having exactly the same problem with my Dell Inspiron 6400.  Does anyone have a fix for this problem ?.

    Thanks in advance

  • Hi,

    check Device Manager if there are are errors.

    If there are, then you may try this:



  • Have experienced the same problem and have yet to find a solution anywhere.  However, HP and/or Compaq website suggest that it may be a related problem with Microsoft Media Player 11 on my Vista 64 bit laptop.  If you find a solution kindly post it. 

    Thanks for your help!

  • Thanks to the two of you who replied.

    Haven't got anywhere with this issue so gave up........instead i downloaded free software from the net which i found which was great and enabled me to do exactly what i needed.  let me know and i can send you a link. 

  • I was finally able to re-install Roxio Creator Priemier 10.2 on my laptop.  Unfortunately, I cannot claim a solution since I tried several remedies at the same time.

    Here what I did:

    First, I uninstalled the failed install of Roxio Creator Premier.  Second, I install a trial version of Iolo System Mechanic (which I since purchased) and ran it.  You can find it at their website.  It is just below the Buy It button on the same  page.  Third, I ran Microsoft's Fix It at the following link :  both for reading and writing on my CD/DVD drive.  Lastly, I reinstalled Roxio Creator Premier and bingo it worked for me. 

    Note, once I installed Roxio Creator Premier I immediately ran its update function which found three updates.  You guessed it they had at least one critical update for this product.  Unfortunately, you cannot get it without first installing Roxio Creator Premier.  Not a big help to those who are having problems reinstalling the product.

    If you tried this please post your results for others. 

    Merry Christmas and a Happy New Years to all!  Smile