Windows 7 and Dell Bluetooth 355 driver - General Hardware - Laptop - Dell Community

Windows 7 and Dell Bluetooth 355 driver


Laptop computer Forums (Audio, General Hardware, Video)

Windows 7 and Dell Bluetooth 355 driver

This question has suggested answer(s)

I have a dell xps m1330 with the above bluetooth module inside.  I recently updated to windows 7 rc1 (64 bit) and everything is working great except for this.  i cannot seem to find a driver that will get this to work.  Has anyone had any luck getting their bluetooth module to work with windows 7?  any help is much appreciated.

All Replies
  • This driver should do the trick ;)

    Let me know how you go :)


  • The link does not work, any help!?!? 

  • Hmmmm... It seems they don't easily allow for the pasting of links....

    Navigate to and select the anycom-blue-usb-200-250-500-550-v6-2-0-8500-vista.exe download.

    Install that and see how you go ;)



  • I have the same problem as the person who began this thread, however I have an Inspiron 1720 running Windows 7 RC1 32bit.

    Will the link you gave the original poster work with my 32 bit OS and if not can you give me a link for the correct driver please?

    Thanks in anticipation,


  • No need for a reply as the driver works perfectly with Windows 7 RC1 32bit.

    Thank you for the link!


  • I'm having the same issue. Could someone help me? The download link has been down for the past week. Could someone post an alternate link? I cannot find one. I went to the anycom website and tried to download it directly from there to no avail. Please help.


    I'm on Windows 7 64-bit RTM.

  • Any chance anyone still has this file... or a working link to the file? I can't seem to access it on and could use this file for use with Windows Server 2008 (Windows 7 drivers are meant to work fine with Windows Server 2008 btw :) )


  • Just download the driver for Vista 64 and it will work for Windows 7 64. I have been doing this for my 1720 since the Windows 7 Beta back in Feb. and now with the RC.

    Alienware Aurora R4: i7-3820, 8GB, 10TB of HDD, AMD/ATI Radeon HD 7800, Samsung 27" monitor

    XPS 730x: i7 920,   Replaced with an Alienware Aurora R4

    XPS 410: Core 2 Quad 2.4GHz (Q6600) , 6GB, EVGA 8800GTS 640MB,
    Single TV Tuner , X-Fi Xtreme Music, Logitec X530 Speakers

    Latitude 10 Tablet

    Inspiron 1720: T7500, 4GB, 120GBx5400, 120GBx7200, 8600GT, DVD+/-RW, Bluetooth,
    Windows 8.1

  • Just thought I'd share how mine works. I have an M1210 with the 355 bluetooth and 32bit Windows 7. I downloaded the XP Patch/Upgrade for the 355 Module and it worked without any trouble at all. Connected to my mouse and phone immediately. Goodluck and hope it helps.

  • I'm sure Dell will or already has started working on this issue and is progressing towards a fix as their engineers work on solutions as they step closer towards selling computers with Windows 7 with function drivers.

    First off in order to make this change to Windows 7, they need to add ' BTW Radio ON ' Patch/Upgrade fix to all service tags with bluetooth adaptors that could require this wakeup, and have it as optional with all OS's.

    Second, they need to fix their drivers (I believe Dell's Alps touchpad drivers are part of a conflicting issue with Dell's bluetooth 355);
    I've been having issues with my Bluetooth 355 needing the BTW Radio ON when I clean installed Windows 7 64-bit.  Just in the past hour it's been working without disappearing unlike it's normal few min of operation to then disappearking from control panel and Device Manager.  Then only way to restore bluetooth functionality was to restart computer, (Restarting bluetooth service and other methods proved no help, tho I didn't try any registry things to solve it).  I have a Vostro 1520 and installed: New Bios A03, Chipset drivers (R208743: O2Micro Driver OZH24 SD/MMC Host Controller) and Input Device Drivers for Alps ToudPad (R213942) from Dell's Support: Drivers and Downloads section. 

    I recently went into the Dell Touchpad menu, clicked Device Select and checked ' Disable Toudhpad / Pointing Stick when external USB mouse is present '.  This has solved my issues thus far and suggest others to try this.  I assume if my bluetooth fails and disappears again my touchpad will work like when I switch my bluetooth mouse off and the touchpad works then.

    EDIT: Actually this didn't fix the issue. Sorry!  Almost two hours later and the bluetooth crashed on me after I restarted.  I'll just try different drivers and hope that'll fix the issue for me.  Good Luck to the rest of you!

  • I think we finally have the sollution for the problem: Try installing Bluetooth 370 for Windows 7 64 bit edition that came out from the Alienware 15X models. It recognizes perfeclty the 355 bluetooth with Windows 7 32 bit. At last I have my old bluetooth working again. In fact, these drivers are no more that the Widcomm update. Here's the link, hope it works:

  • juanjofh -- THANK YOU!  Your solution worked.

    I upgraded my m1330 from Vista 32-bit Home Premium to Windows 7 32-bit Home Premium and my bluetooth 355 stopped working.

    I un-installed the old vista driver/software then downloaded and installed the 370 software for Alienware 15x laptop, 64-bit version, and it works great again.


  • I tried this with Windows Server 2008 R2 (x64) and the install reported "unsupported OS". Several of us are trying to get Bluetooth working with Windows Server 2008 R2 cleanly. It used to be that Vista drivers would most often work w/ Windows Server, but the same can't be said for Windows 7/Window Server 2008 R2. Any thoughts on this on how to possibly use the Win7 drivers for Server? I'm using a Inspiron 1720.


  • Still having issues where I have to turn off my wireless/bluetooth withthe hardware switch and back on for bluetooth to work, randomly stops working and disappears. :(

  • I am too.  Win7 Release, 64 bit, upgrade from Dell-installed Vista 64.  So the reason why it has trouble is the driver is reporting trouble "Windows has stopped this device because it has reported problems. (Code 43)" and someone earlier suggested this is a conflict from the Alps touchpad driver.  I'm going to look for the "Dell Touchpad" software since I do not seem to have any such thing installed, and maybe that advice to autodisable it when the mouse is working is the way to go.

    I did try installing the BT 355 driver from this Dell support site but that is an old file (2007) and it refused to install due to "your system has a later driver already installed", even after I uninstalled the Win7 driver.  I also found the BT 370 software that was suggested, but it refused "this software is not for your system".  So I'm stuck and unhappy.

    Dell, sort this out!  There are going to be a lot of folks updating a 1530 to Win7 and this silly driver problem you should have caught and fixed on Windows Update by now!  From the mail here we can see this problem is a year old, why is Dell sitting on its hands?  Come on, do the right thing.