Cursor jumps back when typing

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Cursor jumps back when typing

  • I have Dell Latitude D510.  Recently the cursor has been jumping back when typing, so I find the last few letters appear earlier on in the document.  It's not a Word issue, as happens sometime when typing in Google.

    Touchpad only has basic features activated.

    Seems to relate to when I rest on the laptop, as if I hover it seems ok - but this is impractical & a bad typing posture!

    Other non-Dell forums talk of several causes and several cures, none of which help!

    Any ideas, or do I need a new laptop?

    Thanks

  • I suspect you are accidentally touching something on the touchpad.  I have that trouble when I'm using my wife's Acer laptop, as I'm used to typing using a regular keyboard on a Desktop PC.  Actually, I have a lot of problems trying to type on any laptop keyboard.

    I am not a Dell Employee

    Dell forum member since 2002

    Home Built PC with Gigabyte GA-Z77X-UD5H motherboard, i7 3770 CPU,  Windows 7 64 bit Home/Win 8.1.  SSD drive.  Sonar X3c 64 bit Recordng Software.

     

    Member of Nashville based R.O.P.E.

  • I wish that were the case,

    I've been having the exact same problem.  I just got my computer two days ago and it has been happening ever since then.   At first i thought, as you suggested, it was the base of my hand touching the trackpad.  But since then i've been very carefull to watch my hand movements and it still happens sometimes.  It's the most ing frustrating/annoything in the world.

    Does anyone have any idea what could be causing this??

    Muchas gracias in advance :)

  • Do you have an external keyboard you can plug in and see if it still happens?

  • 1) Make sure your BIOS is the current version

    2) Check for any Dell external device driver updates (even touchpad mice get treated like external devices)

     

  • You know what, after i posted my message yesterday, i got soo frustrated with this "jumping text" i decided to do a few experiments

    First, i just let the mouse sit over a text field without clicking it to see if it spontaneously would move there... nothing

    Then i turned off the trackpad when external mouse was plugged in = no jumping

    but then i thought that wasn't necessarily a fair experiment since the entire trackpad was turned off completely

    so, next i tried turning off the "tap to click" feature on the trackpad - again, no jumping

    Then i took your suggestion, just to be sure, and i plugged in an external keyboard, and again, no jumping

    So the only conclusion i could come up with is that it had to be me accidentally touching the pad

    Then i watched my self really carefully to see when exactly the text would jump. It always seemed to happen after the character "y". I realized that when i reach to press the "y" button on this keyboard with my right hand, the base of my thump, ever so slightly, grazes the trackpad...mystery solved

    It was me all along.

    It's annoying, but now i'm just a little more consious of my movements when I reach for the "y" key

     

    THANK YOU all for your suggestions and help :D

  • now is the time but if i delay too long the cursor jumps back

  • I can confidently say that the curser jumping is a chronic one with laptop. I have two Dells and one Sony. I use XP, Viesta, and 7 in all three. Even as I type here the curser jumped back to the beginning of the second sentense. I have tried using a mouse, but did not work. I am curful to keep  my palm high avoiding the pad. Yet to no avail. In many cases when I am in a hurry, I discover that a whole sentese, or even a paragraph has disappeared. The curser not only jumps eratically, but also selects text and replaces it as you touch type. One would miss the typewriters. They never did that.

    I think it is a microsoft structural problem. I used Macs for many many years. Never known such a stupid problem.

  • I had this problem, 'tapping' was on and so sensitive that the slightest accidental contact with the pad would trigger a 'button press'. I couldn't adjust the pad because the computer saw the pad as a PS2 mouse! A different driver allowed pad adjustment; switching tapping off completely cured the problem.

  • I had the same problem and it frustrated me to no end. Read about a build-up of static electricity, which can be removed by removing the battery, putting it back in and then rebooting. It worked!

  • I think your right CLGreg! I removed/reinserted the battery and, no more jumping! I conclude this is a design fault in Dell systems. I am a programmer and type a million characters a day on MANY different laptops. I have ONLY had this issue on my two newest Dell Inspiron 17R models.

    Actually, it just did to me again... But it was doing it every few words before removing the battery. Static is a major issue here in this office so I conclude it is a problem related to static buildup making the touchpad too sensitive. Worse yet, the FN key that turns the touchpad off is the ONLY key that doesn't work... FRUSTRATING!!! I think I will be returning both of these otherwise perfect laptops. How could such an obvious and crippling bug have been overlooked in so many models? Dell, TEST YOUR PRODUCTS!!!!!!!!

  • I'm having this same problem with my Latitude E6410. The cursor jumps back while typing, also randomly flys around, closes windows and selects things, taking me out of what I'm working on. It also will become unmovable, totally stuck, does not respond. I have the pointing stick disabled, all but the basic touchpad functions are also disabled. An external mouse works fine but I need to use the touchpad not a mouse. I have the latest drivers and nothing has changed. This malfunctioning touchpad has ruined an otherwise great laptop for me. My Vostro also had keyboard and touchpad problems, think this will be my last Dell product.

  • I may have found the way to eliminate the cursor jumping all over the place and messing up  most everybody's frustrations!

    It was not until I came here out of major frustration and almost tossing my Dell 17R out the window....

    Go into the Touch Pad Settings and adjust the Touch Pressure toward the Plus (+) sign making it less sensitive Then  turn on the Touch Guard.

    Doing this completely eliminated my cursor sneaking all over the place as well as destroying major portions of what I had already written!

    All my issues began after I adjusted the Touch Pad to a more sensitive setting. and I did not realize until I had read several of your posts so thank you all for helping me arrive to a solution for something that has been very frustrating as I am not the guy who can look at the screen & not the keyboard while typing!

  • Hope it works for you, already tried this solution and still have the issues.

  • So Sorry it did not help....