Power Adapter Error message & Battery Not charging!

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Power Adapter Error message & Battery Not charging!

This question has suggested answer(s)

I am having Inspiron-6400 (XP SP3) laptop. 2 years old. Suddenly I am getting the following message for the past two days:

"Your system will operate slower and the battery will not charge. Please connect a Dell 65W AC adapter or higher for best system operation."

That error message comes when I plug in the AC adapter to go to AC from battery.

It results in Battery not charging. That is a big problem. The tray-icon just shows 'On AC Power' and the 'Charging' indication does not appear any more.

A related message is also seen when I reboot the laptop, at the start itself. That message adds a suggestion by saying 'Try to reseat the power adapter'. Reseating it does not help. Though, a couple of times it helped. So I am not sure what this mechanical / reseating thing has to do with this error.

Overall, it is frustrating. It will be great if someone can help me with the exact solution for this, other than going to Dell requesting for paid-service support.

 

All Replies
  • I am having the same problem with my Studio 1735, 5 months old.  I removed and reinserted the battery, which seemed to fix the issue (at least for now).  Anyone else having the same problem, and if so, anything else that needs done to fix it?  Thanks.

  • Sounds like your battery has failed and needs to be replaced. Remove it and just use the adapter to avoid seeing the error. Batteries need to be replaced after 2-3 years or so. If you don't need the mobility, you don't really need to replace it. Batteries are expensive.

  • I am having the same problem on an XPS1530 that is less than 1 year old and had the same thing on an Inspiron 1521. What gives I emailed Support and got no reply

  • The battery is not getting a signal from the charger as to what charger is being used. This signal is sent via the small wire you see in the middle of the DC power plug. Either the wire in the charger cord is broken, or the connection from the laptop DC socket to the system board has broken. Both are common, with the socket problem more often. The first thing to do is either try your charger on another laptop, or try another charger on yours. If the charger is good, then the power socket needs to be replaced. Fortunately, on the E1525 (and the M1530), the power socket is not soldered to the system board, but is a small board that plugs into the system board. It will be repaired under warranty, but is inexpensive and not too difficult to replace yourself if out of warranty.

    If the charger is bad, you can purchase official Dell chargers from third-party suppliers for much less than Dell charges. I would get the 90 watt charger, even if the laptop came with the 65 watter. Dell supplies some laptops with 58 watt batteries with the 90 watt unit.

    XPS M1530, Windows 8.1.1 Pro 32-bit
    Inspiron E1705, Windows 8.1.1 Pro 32-bit
    Dimension 9100, Windows 8.1.1 Pro 32 bit
    Inspiron 660, Windows 8.1.1 Home - 64 bit
    Compaq DX 4370G, Windows 8.1.1 Home - 64 bit
    Asus T100 Tablet, Windows 8.1.1 Home - 32 bit

  • Thank you KirkD for the nice inputs. Due to logistics reasons, I have  no way to take my adapter to another computer to check out. But I had a chance to try a borrowed adapter from somewhere else and it is able to charge my battery fine. So I should suspect the charger cord should be broken in mine? Not sure if I should fiddle with it by cutting, checking continuity etc. I have the risk of totally damaging the only power adapter I am left with.. after the series of 3 failed adapters lying on my desk! You know.. I have spent thousands of bucks on these adapters.. and I really wish I stop spending for my DELL laptop any more.

    Let me know if you or anyone has some good tips to get this problem resolved.

    Thanks very much.

  • These chargers usually have this problem from wrapping the cord around the charger or by "over flexing" the cord. I have seen some cords where the outside insulation has pulled out of the DC plug because of careless handling. In addition, the small wire in the plug might be bent and not making good contact. Some people have had success by simply removing and reinstalling the battery while plugged in. Others claim the charger will begin to charge if plugged in after the laptop has been booted on battery power. 

     

     

     

     

     

     

    XPS M1530, Windows 8.1.1 Pro 32-bit
    Inspiron E1705, Windows 8.1.1 Pro 32-bit
    Dimension 9100, Windows 8.1.1 Pro 32 bit
    Inspiron 660, Windows 8.1.1 Home - 64 bit
    Compaq DX 4370G, Windows 8.1.1 Home - 64 bit
    Asus T100 Tablet, Windows 8.1.1 Home - 32 bit

  • thanks to the chap that pointed out the plug has 3 wires not two, I stripped apart the plug and made good the problem..then using an old trick to kick start the 6 cells inside the battery pack which are wired in 3 pairs, the charge system now detects the batteries. before they had fully discharged causing little to no charge current being drawn ,hence causing the charging system to switch off. ie green charge light on for 5 seconds, then 4 orange pulses which repeats. would go into better details which would result in this post being removed again.

     

     

     

     

     

  • Hello Jonathannc.

    Great to know that you could fix the problem by stripping it apart. I was the one who started this posting thread. Can you help me with a bit more information on what exactly I should do to get this problem fixed? I continue to have the same problem --- the battery does not get charged; laptop works fine on mains power; Exactly same as you described your problem in the earlier message. If you can describe how I should fix it, it will be a great support to me and everyone who is stuck with the same issue. Please.

    thanks a lot.

  • Easiest thing to do if the unit still works on AC is to buy an external charger to charge the battery when needed. This is much cheaper than getting a system board repair. Be aware that the problen is most likely a broken solder connection fror the DC power jack to the system board because of stress on the socket by the power cord. This will eventually get worse because the socket can wiggle more once a connection is broken. The socket has usually four physical connections and three electrical connections, but the soldering is not beefy enough. Resoldering the socket is not trivial.

    XPS M1530, Windows 8.1.1 Pro 32-bit
    Inspiron E1705, Windows 8.1.1 Pro 32-bit
    Dimension 9100, Windows 8.1.1 Pro 32 bit
    Inspiron 660, Windows 8.1.1 Home - 64 bit
    Compaq DX 4370G, Windows 8.1.1 Home - 64 bit
    Asus T100 Tablet, Windows 8.1.1 Home - 32 bit

  • I had the same problem with my Inspiron 1525. As you suggested I re-booted using the battery, and it is working fine now. Many thanks for your suggestion.

  • Same experience with my 1525 -- re-booted on the 6% power left on my battery, and it started charging.  But then it stopped again.  I played with taking the power supply in and out, applying a little pressure in different directons.  Sometimes I can get it to say "charging" but then it goes back to "not charging/"

  • After much research I have solved this problem. The reason that the AC Adaptor will power the laptop but won't charge the battery is that in the AC Adaptor puts out a signal from the adaptor to the laptop charging circuit that lets the laptop identify the adaptor and turns on the charging circuit. When you look at the adaptor plug that connects to the laptop, there is 1. an outer shield DC-, 2. an inner shield DC+, and 3. the inner pin in the middle of the plug. The signal that comes from the AC adaptor goes thru this pin to the laptop.

    Here is the answer. The problem is the wire inside  the cable has been broken off the connection to the center pin. The FIX is either:

     1. buy a new AC ada[ptor,

    2. Cutoff the connector, remove all the rubber from the connector, trim back and remove the covering from the end of the cable, (where the connector was cut off) then resolder the little wire back to the center pin, then reconnect the existing + and - connections from the cable to the connector. Observe good soldering of the wires connected back as not to melt the insulation of any of the wires. When finished use meter to check for shorts before you reconnect power. Also if you have any Heat shrink tubing apply it over everything you just soldered. Otherwise use Electrical tape. BE CAREFUL AND DON'T WORK ON THE ADAPTOR WITH AC POWER ON. AND DON'T FORGET TO CHECK THE POLARITY OF THE +++PLUS+++  AND ---MINUS--- WIRES. 

    3. Go on EBAY an find a new cable that goes between the adaptor and laptop and replace it.

    After I fixed the wire and connector the battery charged to 100% and its as good as new and didn't cost me anything and I am happy. Good Luck, Eric  

  • Hi Eric,

    Thanks for the very valuable points that will help a lot of people to address / resolve this issue on their own. If there are pictorial illustrations you can attach (not sure if this forum allows that though) that will add even more clarity.

    I have adapters failing every 4-6 months...I have so far bought 6 adapters!! Now to avoid nick of the moment problems, I have two adapters - one for home, and one for office! Thanks again.

    - Raj

  • I am having the same problem. I have noticed that the little wire that was inside the whole in which one puts the power adapter is no longer in place. I suspect it was driven into the computer itself. Is there anything I can do about it? Thanks for you help!

  • You will need a new power supply. If the signal wire has broken off and still in the DC socket on the computer, it must be removed before using the new power supply.

    XPS M1530, Windows 8.1.1 Pro 32-bit
    Inspiron E1705, Windows 8.1.1 Pro 32-bit
    Dimension 9100, Windows 8.1.1 Pro 32 bit
    Inspiron 660, Windows 8.1.1 Home - 64 bit
    Compaq DX 4370G, Windows 8.1.1 Home - 64 bit
    Asus T100 Tablet, Windows 8.1.1 Home - 32 bit