Dell XPS M1530... Battery not charging, says its plugged in but not charging... someone please help! - General Hardware - Laptop - Dell Community

Dell XPS M1530... Battery not charging, says its plugged in but not charging... someone please help!


Laptop computer Forums (Audio, General Hardware, Video)

Dell XPS M1530... Battery not charging, says its plugged in but not charging... someone please help!

  • Hi, I could really use some help, my laptop battery status is at 0% and its staying on with the adapter plugged in, and the battery status says its plugged in but not charging, can someone please help me! I have a lot of schoolwork I need to get done, and I called and they said the couldn't get the guy to call me in about 3 days, then it would be another 3 days for him to get out here, I dont have that much time!

  • Did you ever get this problem resolved?  There are many people here, including myself, with a similar problem.  I can charge my battery up to 11% and then I get a message "plugged in, not charging" when I click on/highlight  the battery icon in the tray at the bottom of the screen.

  • Solution: have Dell Support replace the motherboard, under warranty only; this is a known problem, no recall issued yet.

  • Solution: have Dell Support replace the motherboard, under warranty only; this is a known problem, no recall issued yet.

  • I have the same problem. Dell replaced the A/C adapter cord but it didn't work. Now I don't have any charge left in my battery and if by accident I remove the cord from the power outlet, the laptop turns off and I have to restart the whole session.

  • Hello .. I had the same problem and ran a google search on "trouble charging dell laptop battery".  Although following the instructions helped me successfully charge the battery in both of my laptops, it only worked once and the issue is constant now.  I cannot get much in the way of dell support on this item either.  One of my systems is less than a year old so I certainly hope they will take ownership of that one and I am just out of luck on the three year old laptop.  The resolve on google will make you take the battery all the way out and unplug the AC adapter from the wall and then wait ten seconds and plug the AC adapter back in and plug it into the laptop and then slide the battery back in .. seems a bit stange to have to do this to charge a battery.  The history of Dell batteries that I have been aggressively reading would suggest they have ongoing battery issues.

    If you find something that fixes this issue, I would so appreciate knowing.



  • hi! had experienced the same problem with my 9 cell battery. i just noticed on the taskbar that the battery suddenly won't charge and the battery is about 16%, tried to unplug and plug again the charger and the battery icon on the taskbar indicates charging, however it will stop after few seconds. after few weeks the battery can't be detected and completely dead. Encountered this problem 1 week after the warranty expired. I read lots of feedback from other XPS M1530 owner which encountered the same issue, most of them happened few weeks after warranty expired. I bought a replacement battery but now 6 cell and hoping it will last longer at least 3 years same with other laptop brand use by my sister. I keep my dead battery hoping that Dell will issue a battery recall.

  • I had the same issue only three days out of warranty.  I did call dell and they sent me a new charger as well as a motherboard.  Because I was three days out of warranty, they have left it up to me to switch out the motherboard myself.  I'll let you know the results after I make the change.



  • There is an internal battery charger on most laptops.

    The external ac/dc adapter is rarely the cause of these problems unless u have a Mac.

    On a Dell it is most likely that the internal charger is built into the motherboard.

    I'd advise you to consult a Dell technician about warranty or repair work or buy a new laptop.


    A new mother board and power adapter fixed this problem for me, they just replaced these components today and everything is working fine... Although I know I need a new battery, its capacity to charge and runtime has been significantly reduced...


    Hope this helps...

  • I disconnected the power cord from the wall outlet and plugged it back in and now the battery is charging.

  • Dell XPS M1530 Battery charging - bios downgrade to A09 can help

    I took delivery of a Dell XPS M1530 laptop on 31 January 2008. Very pleased with it - ran OpenSolaris almost straight out of the box (sole exception being the Marvell Yukon ethernet, now supported by yge). Things went reasonably well until the SAGE-AU conference last year, when I noticed that the charging function wasn't. Totally unchargable.

    The battery and AC adapter, it turns out, were under a 1 year warranty, not 2 years like the rest of the system. Got a new 3rd party battery (from and a new Dell AC adapter, and the battery lasted until about a fortnight ago.

    Got another 3rd party battery, this time somewhat cheaper via a Melbourne-based store. It arrived 60% charged, and seemed to charge up ok when I plugged it all in. Yay, I thought, problem solved.

    Not so. As it happens, my laptop's charging circuit inside the case (not the AC adapter) appears to be unable to recognise any sort of AC adapter, so I get the dreaded "AC Adapter - Unknown device installed" message in the bios, and under bios version A12, NO CHARGING TAKES PLACE WHATSOEVER.


    Rotating the power plug in the socket doesn't help either, even though it's a genuine Dell AC adapter.

    A bunch of searching this evening turned up this thread, which said that it was worth trying to downgrade the bios to version A09, and perhaps run the bios flash program with "/forceit" as an option.

    This is about the only reason that I keep the Vista partition hanging around. Though sadly, when you run the 1530_A09.exe program (even with /forceit and /forcetype) in Vista, with the battery at less than 10%, you get an error message telling you to charge the battery to at least 10% before trying again. Very frustrating!

    Fortunately, one of the posters in that thread had a link to a Win98 rescue cd image which contains the bios flasher... pulled it down, burned it, booted it, flashed the bios (it's on the logical D: drive) and now I'm sitting here watching the laptop bios battery screen increment the charge status every few minutes.

    The AC Adapter is still "unknown" - but at least I'm getting charge in. And I don't have to go out and buy a new laptop (at least, not just yet).

    This is the sort of thing which really annoys the heck out of me. Not only is there no opportunity for me to get the bios flashed from OpenSolaris using fwflash but there's clearly some "enhancement" in A12 which is actually a regression and serious functional misfeature compared to A09. Let's not start on the hardware problems in the AC adapter, either.

    Posted by jmcp @ 12:27 PM EST

  • martyn012.  I just read your post and I was wondering if you could forward me the link to the Bios Flasher and possibly the A09 Bios.

    I purchaed an aftermarket battery without dwelving into the issues that are around the M1530 XPS.

    Thanks in advance with any help that you can assist me with. Mario Q.



  • I just purchased a battery as well without knowing the issues at play. 


    Any way the link could be sent this way as well?

    Thanks very much.

  • about the "plugged in, not charging"..... i thought it was the battery. buying a new 1 online, didn't change anything. it sd the same thing. i looked closer @ the end of the power cord that plugs in2 the laptop & noticed there should b a pin inside. since i've a 2nd dell laptop, i realized i could possibly switch power cords. i did & the 1st laptop began charging. in the end, it was the power cord, which i've since ordered. glad it wasn't something more serious.