Stuck in MediaDirect loop - cannot always get into windows - pls help if you can as i'm desperate! - General Hardware - Laptop - Dell Community

Stuck in MediaDirect loop - cannot always get into windows - pls help if you can as i'm desperate!


Laptop computer Forums (Audio, General Hardware, Video)

Stuck in MediaDirect loop - cannot always get into windows - pls help if you can as i'm desperate!

This question has suggested answer(s)

like the subject says my laptop (dell inspiron 4600 windows XP pro) is stuck in an infinite loop of MediaDirect.... i've spent 3 days trying to get it to work correctly & i'm now tearing my hair out & absolutely desperate for any help.... please! 

this is what happens:
when i 'turn it on, i don't see the usual dell bios flash screen because it goes straight to the MediaDirect flash screen & then the MediaDirect menu;
choosing exit it shows a Windows logo & the word Exiting below with a blue bars beneath it,
but then it loops back to the beginning i.e, the MediaDirect flash screen & then the MediaDirect menu - i'm back to square one!

by pressing a combination of the MediaDirect & Power on buttons at varying times when I've turned it on I can sometimes see the line at the top of the screen that says something about loading mbr2... (it flashes off very quickly) & if i see that i know it'll actually boot into windows ok... but over the last 3 days it's taken me over an hour sometimes to get the combination right & actually get into windows - can't carry on like that!

If when in windows i then choose to switch off it'll then start the whole cycle again, if I choose to restart it will actually come back up into windows ok. 

I've got all the cd's that came with the laptop, I did put in the re-install mediadirect cd (got to the two options) but stopped short of doing anything with it  because I didn't want to loose all my info...

Please can anyone help, i'm absolutely desperate for this to work.....

thanks in advance


All Replies
  • anyone out there got ANY ideas please?

  • Progress so far is that I've actually wiped the drive & started again using the instructions that I'd got with the cd's & booted from the Dell MediaDirect Cd; chose option 2 & created a C:\ partition of 85gb out of the 120gb available, then when i put in the Win XP cd & got to the partitioning screen it showed 4 partitions available (sm un-named partition1; C:\ partition2; d: partition3 & DelMediaDirect partition4) so I went ahead & installed Windows on to C:\ & it's done it ok...

    Once up in Windows i put in the MediaDirect Cd but as it wouldn't autorun I read in the instructions that it should be running an installer & when I did that it appears to have re-installed the MediaDirect program but I haven't tried it yet as I'm now doing the drivers...

    I'll post back if it actually allows me to use the MediaDirect....

    P.s. can't believe i'm the only one that's come across this....

  • I had a similar problem...

        I was stuck in media direct. so I booted up with a Gparted live cd and removed  the media direct partition (I don't use it anyhow). I formatted the harddrive and reinstalled windows. Now I can't shut the computer properly. When I choose shutdown it reboots showing the mediadirect splashscreen but boots into windows (as mediadirect is not there anymore). I   think the media button is either stuck or shorted.

    do you have any ideas?

    Is there any way to disable it?



  • I have the same problem too...

    When I choose shutdown it reboots showing the mediadirect splashscreen but boots into windows...

    Is the any solution?


  • This just happened to me...out of the blue. Had worked all week on my laptop and today when I turned it on it was stuck in this loop. Tried shutting it off and on by holding the power button, but each time it rebooted, same problem. Called Dell support. At the blue Dell screen, hit the F8 button 8-12 times and you will bet the screen to start up in safe mode....but choose to start up in safe mode with networking. Once I was in windows, he had me uninstall the Media Direct program. Then we shut down from Windows. When we turned the computer on, voila! No Media Direct loop and I booted into the normal windows screen! Hope this doesn't ever happen again...but will back up my files today as this is too scary.
  • I have the same issue as mawoz1 but unistallation of Media Direct hasn't fixed my issue :(

  • The MediaDirect hit me this morning at start up... stuck in loop. It's unable to load due to MS BitLocker (Drive encryption)... I hit 'Exit' and it shuts my computer down... power up again, same loop... IS THIS A VIRUS or has Dell created a monster ?

    Computer is an older Inspiron so I don't have the startup CD... What now... HELP!!  ANYBODY?

  • I had the same problem today with my Vista based laptop. I was able to fix it by running my installation disk and using the Repair feature. It boot up properly.

  • This just happened to me today. My laptop is an old Inspiron 1525 and I don't have the disks. Help! Update I found the fix. Turn off the laptop Hit the button with the house on it This will get the laptop to toggle boot partitions Cheers
  • THANK YOU!!!!!!!!!!!!!!!!!!!!!!

  • thank you