Laptop boots to black screen with blinking cursor (after Dell splash screen) - General Hardware - Laptop - Dell Community

Laptop boots to black screen with blinking cursor (after Dell splash screen)


Laptop computer Forums (Audio, General Hardware, Video)

Laptop boots to black screen with blinking cursor (after Dell splash screen)

  • Hi guys, I have an Inspiron 6000 (just 3 years old) which won't boot up past the Dell splash screen.
    Yesterday it froze up and since then it loads past the splash screen to a black page with blinking cursor in the top left.

    A few weeks ago I replaced a failing 40GB HDD with a 160GB drive. Also installed 2 x 1GB RAM to give it a bit more speed.

    It will boot from the Windows XP Home CD but won't repair/reinstall windows, for the repair it goes into a DOS prompt stating "C:\Windows" where it doesn't allow more than one character to be typed at the prompt (e.g. it says type exit to cancel but only allows the "e").

    For reinstalling, it copies the setup files then asks to reboot, and then loads off the CD again in a circle instead of going forward to XP Setup.

    I've used the DELL diagnostics CD to boot off, which has passed everything as working (including a detailed check on HDD & memory).

    Also tried tapping F8 to go into safe mode which doesn't make any difference.

    Any advice on finding out what's gone wrong would be appreciated, I'm surprised to find this happening on a laptop that's only 3 years old. Thanks!
  • Format the drive and reinstall windows that way...
  • Hi,

    I couldn't possibly written a better description for the problem I am having with my Inspiron 6000 laptop.   I have tried all the same things and got the same results....still a black screen with a blinking cursor.

     Did you ever find a solution?


  • If you've installed a drive over 120G on a 6000, MAKE SURE Windows is installed in a sub-120G partition.  If it isn't , you WILL have problems.


  • I did install a 250g and everything was fine for over 3 weeks of daily use and then came the black screen.  I'm sorry but I don't understand your instructions but I don't think it matters since my operating system disc doesn't work either.  I can't get anything to work except the F2 and F12 keys.  The diagnostics all passed and and when I select the boot from the CD/DVD Drive, it goes to windows setup, loads files. says it is starting Windows, I select "Repair", and it goes through all the copying of files and restarts to the same black screen.  I think maybe a new laptop is in my future.

    Thanks for trying to help.

  • Delete all existing partitions on the hard drive and create a single 120G partition for Windows.  Format it and install.  AFTERWARD you can create another partition to use the rest of the drive.  The system doesn't support a drive over 120G at the BIOS level -- that is the problem. 

  • OK But, before I do this since I really don't have any knowledge at all about these things AND I fear that I may not have told you everything correctly, I would like to tell you exactly what it says on the screen that shows the existing partitions and unpartitioned space.  I hope you don't goes:

    After the explanation about using the UP and DOWN ARROW keys it lists 3 options:

    1 To set up Windows XP on the selected item, press ENTER

    2 To create a partition in the unpartitioned space, press C.

    3 To delete the selected partition, press D

    Then there is a rectangular box that has the following info:

    238473 MB Disk 0 at Id 0 on bus 0 on atapi [MBR]

          C:  Partition1 [NTFS]                        238465 MB (218748 MB free)             The brackets around this last item are kind of pointy

                Unpartitioned space                              8 MB


    Then at the bottom of the screen  there are 3 choices:

    ENTER=Install     D=Delete Partition  F3=Quit

    Is this where I should be?

  • Yes.  Delete the existing partition and create one at 120G or smaller.  Then install Windows to that.


  • Ok...I did that and I got the following response:

    The partition you tried to delete is a system partition.  I goes on to warn that I will loose diagnostic or hardware configuration programs.........

    Should I still delete the partition?

  • Dear ejn63,

    I can not thank you enough for all your help.  My laptop is up and running again thanks to you.......many, many, many thanks to you.

  • I have a similar problem on my Latitude D820, where after the dell splash I would get a black screen with a blinking cursor. The problem is that it will not boot from the CD. I tried hitting F12 and selecting to boot from CD drive which didn't work. The only buttons that work is the F2 and the F12. I haven't changed any of the hardware either. Any help would be great. Thanks!

  • Try as above - remove the hard drive.  Will the system then boot from the CD?


  • Thanks for this tip.  Creating a 100 GB partition for Windows 7 was the only thing that worked and it allowed me to install a fresh copy of Windows and defeat the blinking cursor of death issue.  After 3 days of continuous work, I now have my Inspiron 7010 back!


  • TO DILL36: When you deleted the partition and created a new partition...what did you do? Did you type in 122880MB for 120GB? I tried to do that but after I press enter, the number 122880MB (which equals 120GB), dissapears and  the number 706309 or something like that appears again. Did this happen to you too? Sigh...I have the same problem on my Dell inspron 6000.... -_-


  • I have also been having the same problem with my Dell XPS L702X. After a very detailed explanation of my circumstance on other forums and after applying a number of suggested solutions and/or implied downloads I find my situation more complicated then when I first sought help from forums such as this one.

    My Dell XPS L702X has gone from applying a system restore solution to a much more serious condition to where it boots from the initial Dell Logo to an obvious "Black screen with a single blinking _ at the upper left hand corner of the screen. Once again solutions offered as well as suggested downloads that I have burned to CD's and have attempted to run, including windows 7 reinstallation CD's , has proven futile. 

    Now it appears that I will be unable to find an application, software , download or advice that will get me the results I have been seeking for over a week, now.

    There has to be someone or something out there that has the answer to this ??????

    Plain and simply put; F8 will not respond. Only keys that do function are F2, F12 and ctrl + alt + delete. Using the ctrl + alt + delete then tapping F12 I am able to access "Boot Menu" where I can scroll down to +CD/DVD/-RW Drive. This is where I have made several attempts to run suggested downloads. I found one individual who explained a Windows XP reinstallation disc would assist me to restoring my system to where I could get back to "my" systems safemode, etc.

    This example started out very promising however ended up to be just another frustrating attempt to restoring my "OS" to a decent point of familiarity. This is also a step I decided to trust that has helped to put my system in it's current state.(I.e.) "  "Black screen with a single blinking _ at the upper left hand corner of the screen.

    Oh, one last oddity to my OS's mess. While I was running a download , that was supposed to be the answer to all my prayers, it offered me three choices. The choice I made was, "Start CD with CD ROM Support". This seemed to be the obvious choice. Not so as I found myself in a "Command Prompt" identified as "The Windows Setup files were not found: A:\>_ 

    If this Command Prompt was C:\ or D:\ I would have felt allot more hopeful as I have become more familiar with both while researching my frustrating Dell-ima.