Latitude E6400 - Not creating docked hardware profile

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Latitude E6400 - Not creating docked hardware profile

  • We got a bunch of new Latitude E6400 (Windows XP Pro SP2) laptops in with port replicators. I've pulled one out for testing and I'm noticing that when we boot it in docked mode, it will not generate a "docked" hardware profile. We've rebuilt our test E6400 with our custom Dell Image Direct restore DVD, but it still won't generate a docked hardware profile, so there is no "undock" option available from the Start menu.. Anyone experience something similar? Our D620 and D630 models never had an issue like this with their specific port replicators. Am I missing something obvious?

     

     

    Thanks!

  • I'm also experiencing this with the new E6400 & E6500 latptops in Vista.  I haven't verifed the problem with Xp yet.   I would like to see an solution for this problem as well.  Can someone help?  Thanks
  • Okay, I noticed this problems about two weeks ago when we got our first batch of Latitude E6400 laptops in. I originally thought it was a problem with our OS build image and contacted Dell Support to find out if this was unusual. Dell Support did think it was unusual, but could not rule out that my build image was causing the problem.

     

    I went back and created a new build image through Dell Image Direct and still had the same issue as described in my opening post. I was at a total loss and called up Dell Support once more this afternoon. After speaking with a Dell tech, I was told that there is no longer a docked/undocked profile with the "E" class of Latitudes and you do not need to hit "undock" in Windows to remove your laptop from the port replicator. He pointed out that Dell even removed the "undock" button from the new port replicators.

     

    So, according to Dell Support, there is no more docked/undocked hardware profiles with these laptops and you can remove them from the port replicator by just pressing down on the eject button.

     

    I don't have a problem with this, but I wish the first support tech I talked with had explained it to me. Now I just need to wait for Dell to update their control point software so I can set up a software profile that will disable wireless when the laptop is on the port replicator.

  • What a pain - not using the built-in Windows docking profiles, but requiring ControlPoint is a major step BACKWARD, IMHO.  Why should customers depend on this software, especially when it's not even ready?  We, too, want to turn off wireless when docked, and this will delay our laptop deployment as we don't want to touch them again when Dell finally gets CP updated to include wireless (not like wireless is a new technology???).

  • Same issue, e6400's and m4400's.  I don't think it hot undocks properly either. We've had all kinds of issues with the laptop screen not coming back on after ejecting.  I too am annoyed that we have no good way to disable wireless while on a dock.
  • To sort this all out:

     

    The E-series does not use nor does it NEED dock profiles. The dock is considered known add on hardware. Hot dock with Device Manager open and expand the USB heading. Adds two when you dock, removes them when you undock. 

     

    Using dual spanned desktop? Hotdock, second monitor goes off, redock, there it is, laid out the same.

     

    It is a world of improvement and has NOTHING TO DO WITH the DCP. It's from items added with the Notebook System Software and Chipset software after OS load.

  • Yes, but it's handy to be able to enable/disable hardware under docked/undocked profiles - especially the wireless NIC.  This feature is built in to Windows, but Dell chose to bypass it without a full solution - we're still waiting for the wireless module in DCP to be able to disable the NIC when Ethernet is connected.

     

    I did find that the E-series with Intel 5300 AGN is part of the problem because it doesn't have the property to Disable When Wired Connect, which the Dell 1510 N card does.  I'll probably order my next E6400s with the Dell card now.

  • xandraius

    To sort this all out:

    ...

    Using dual spanned desktop? Hotdock, second monitor goes off, redock, there it is, laid out the same.

     It is a world of improvement and has NOTHING TO DO WITH the DCP. It's from items added with the Notebook System Software and Chipset software after OS load.

     

    The problem we see is that if you undock with spanning desktop, anything that was opened on the lost moniitor now opens off screen.  previously XP would realign everything on the remaining desktop.  Anyway to make this happen?  One of our execs is frustrated...

     

    \\uSlacker

  • We are seeing issues with the E6400 and E6500 with port replicators.  The replicators do not present an undock button and there is no “undock” option on the Start menu with XP svc pack 3 on these machines.  According to this Dell forum, you should be able to just press eject on the replicator.  I’m not sure it hot-undocks/ejects properly. I have users where the laptop screen not coming back on after ejecting and they are forced to do a hard shut down, sometimes multiple times to get it to come back. 

  • Dell is saying that the bios versions on these machines are already out-dated.  Ours have version A06 and the Dell site now has version A11.  I will try that on one of the machines and let you know how I make out.

  • Updating the bios version cured all my ejecting issues on one machine.  Looks like the fix.

  • My new E6500 also experiences these problems.  I would like to disable the wireless while docked, plus I have an annoying screen issue.  When I use laptop undocked, it obviously switches to the laptop screen.  When I place the laptop back in the dock and boot up, it continues to use the (closed) laptop screen.  Luckily I have the LCD mount dock, so I can open the laptop a bit, logon, change the display properties to use the dock's monitor rather than the laptop screen, reboot, and close the laptop while it's power-cycling (closing the laptop while in Windows will cause it to suspend).  I am using the A11 BIOS and WinXP SP3.

    I definitely prefer the docked/undocked profiles of my old D610.  It was simple and "just worked" with both profiles.  The E6500 is a major hassle everytime I put it back in the dock after using it undocked.  I see that A12 was just released, but the notes don't mention anything that appears to be related to this.

  • We just installed some M6400 and M4400. The undocking of the M6400 is ok so far. We had 2 machines with problems but they dissapeared after some docking / undocking. But the M4400 are not working at all. The screen never comes back on after docking. Sometimes not even when undocking.

    We're running XP X64 with most recent drivers and bios.

  • The E series laptops don't create 'docked' profiles because they don't see a 'Docking Station ID', they only see a bunch of ports from a 'Port Replicator'. The D series laptops came with 'port replicators', but  they had 'Docking Station ID's' which were picked up by XP when they were 'Docked". I wish the engineers would communicate these differences to the marketing and support staff, so they could explain it to the customers and/or their support staff.

  • We ran into the same issue.  The E6400 came out of the box with BIOS A06.  We have upgraded to BIOS A12 and have Windows XP SP3 installed.  The issue remains the same.  Undock with spanning desktop leaves everything on the lost monitor and won't switch to laptop mode.  Then when it is re-docked, the laptop is frozen.  Placed a call into Dell and they said that maybe the motherboard needs to be replaced.