Studio 15 Keyboard/Touchpad issues

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Studio 15 Keyboard/Touchpad issues

  • Hello,

     

    I recently purchased a Studio 15 Laptop, and after using it for a few days (less than one week), I have developed the following problems:

    The touchpad/mouse buttons are not functional.

     

    The lighted buttons (play, pause, FF, REW, Mute, Vol Up, Vol Down, and CD Eject) do not light or function, though the Bluetooth, Disk access, and Wifi lights do operate normally.

     

    Many keys in the center of the keyboard (including but not limited to: 7, Y,U, H, J, N, M) will not respond except when hit repeatedly and very forcefully.

     

    This has rendered the computer functionally unuseable.

    I was able to get the touchpad functioning briefly in Safe Mode by using the advice in this article:

    http://support.dell.com/support/topics/global.aspx/support/dsn/en/tree?c=us&dl=false&l=en&s=gen&treeid=FD1972D3BA5A43E08BAEA893CA928107&doclang=en&cs=

    But upon returning to traditional startup, the cursor would not move, though on my first attempts to use the touchpad it would briefly become the "working" cursor (with the blue circle), while continuing to remain unresponsive.

     

    I assume that this is some sort of hardware issue, with some sort of flaw in the middle of the keyboard affecting the touch sensitive controls and keyboard, though the semi-functionality of the touchpad baffles me.  Any help would be much appreciated. 

     

     

     

     

  • I recently purchased the same laptop and I am experiecing the same problems.
  • I called Dell support and they had me take out my battery and hold down the power button for 30 seconds.  After restoring the battery and turning on my laptop the problem had been solved.  You might want to give this a try.  Though I am afraid the problem might come back. 

  • Hey guys.

    I had to same issue. Tried the remove battery and hold power for 30 seconds and it works!

    Any idea what caused this? Does it happen often. Is it covered under warranty?

    Thanks

  • Hey,

     

    I'm also experiecing this problem, though m keyboard does work if I leave te keyes pressed for a second.  Not tried removing the battery yet but I'll post again with the reslts.  Will there be a recall for is as I've tried a system factory reset and the media buttons still didn't work so I'm guessing it's a hardware problem.

     

    Here's hoping the battery reset works.

     

    Rick.

  • Hey,

     

    Removed the battery and held the power button down for 30 secs and voila...    ...all the media keys work and my touch pad and keyboard are working flawlessly.  Don't want to have to do this every few days though, I've only had the laptop for about 5 days!!!  I'm going to report this to Dell and I guess if enough of us do the same we might get the problem fixed.

     

    It's a shame as other than this problem the laptop is awesome and runs perfectly.

     

     

    Rick.

  • Let me add myself to the growing list of frustrated Studio Laptop users!  I've done the battery reseat and it works for a week maybe and then back to square one.

     

    Can someone from DELL please read this and respond?

  • Here is yet another very frustrated new Dell Studio laptop owner, about to attempt the remove battery-hold power button manouvre.

     

    This is all very disappointing. :smileysad:

  • Hi, i have the Studio17 but am experiencing the same problem too! i've only had the laptop for a week. was on the phone for over 1 hour with support, had to do all sorts, resulting in restoring to factory settings and losing everything i had on the laptop... still didn't work. they said they would call back... i'm still waiting! this definitly needs to be reported and sorted out! obviously a problem they have to repair on all our laptops!
  • Right after my last posting, I engaged in a 2.5 hour session with Dell's tech support staff, who had me doing all manner of diagnostics until the guy was finally satisfied that the problem was to do with the hardware installed (as I insisted from the beginning) and instructed me to send my laptop away to be repaired. Like you, we'd only had our Studio a very short time. We can ony hope to get the laptop back from Dell's authorized repair shop in a fully functional state...

     

    Will keep you posted. In the meantime, I suggest you attempt to get your money back from Dell or arrange to have it repaired.

     

    Why all the silence from Dell with this particular, quite damning, forum topic??? 

  • i went on to the chat tech support yesterday afternoon, and mentioned this topic was here and that quite a few people were experiencing the problem. he told me that there have been no customers complaining that this was a recurring problem and it wasn't a hardware problem!

    i told him what it said on here about removing the battery etc... and it did work. he also said that it wouldn't happen again. luckily they email the full conversation so if it does reoccur, i have proof that i showed my concerns to dell that i was stuck with a laptop that doesn't work correctly, and was told by them that there was no problem.

  • I have had the eject key stay lit 3 times now, i have had to repeat the battery step to fix it, but this is getting annoying now. I'm going to talk to dell support and see if i can get anything.
  • I have been having the same problem with my laptop. I've had mine since the end of July and this problem surfaced after I had had it about a two weeks. I had researched it and removing the battery does work but it's not a long term fix. I have been dealing with this problem because it was only a minor inconvience but it's been increasingly getting on my nerves every time it happens.

  • On my first Studio 1735 I had the same problem along with many others. The keys would work off and on. I had to do a factory re-imagine and it seemed to fix that problem which was not the reason I was do the re-imagine but that was short lived. I wound up requesting an exchange and sent the defective laptop back. Got the exchange and the media keys had acted up at first but again I had to another re-imagine as well as reinstall drivers etc from the disc with the laptop and that seem to fix the issue with the keys. You may want to try that, reinstall from you cd's if all else fails contact Dell and request an exchange especially if it is a brand new laptop. I don't feel that I want a third party tech opening a brand new laptop up, which was the main reason I requested the exchange.

  • Add me to the list of angry Dell Studio 15 customers!  I just got my laptop a few days ago... after TWO HOURS, the mouse/touchpad/buttons stopped working!  That's outrageous.  I'll try the battery reset, but it sounds like more typical Dell "never heard of that problem" rhetoric that's seems to be so common.  Should've learned after my last Dell laptop. :-(