1525 sd port doesn't work

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

1525 sd port doesn't work

  • Hello Dell users -

     

    I have a brand new Inspiron 1525 and am trying to get my photos from a 1 gig sd card into a file on my laptop.  I've removed the "fake" sd card that came with the computer and put in the picture card.  It opened once (meaning it showed up as as an sd card in the "my computer" area, but I moved on to something else at home and eventually "safely removed" the card without finishing my task.  A few days later I tried again but the computer doesn't even recognize the card... the "my computer" area does not list the card as being in its slot.

     

    What is more curious is that if I remove the card and put it into my trusty multi-slot card reader and insert that into one of the usb ports it opens up the iphotos on the sd card just fine and I can upload from there.  I know I can just use the card reader, but I really liked the idea of being able to just put the sd card directly into the laptop.

     

    Does anyone have suggestions or ideas for me?

     

    Thank you very much!

  • Assuming your OS is Windows Vista, you should check that you have the latest version of the Microsoft WPD FileSystem Volume Driver. It is listed under Portable Devices in Device Manager.
    John

    My Dell system

    Inspiron 1520 purchased 5 Feb 2008
    Windows Vista Home Premium SP2
    Intel Core 2 Duo Processor T7250:2.0Ghz, 2MB cache, 800MHz FSB
    4GB 667MHz Dual Channel DDR2 SDRAM
    NVIDIA GeForce 8600M GT with 256MB dedicated graphics memory
  • go to start, then right click on computer select manage, choose device manager, then see if the media card reader is listed there,

     

    if it isnt there go to support.dell.com  select drivers and downloads, try selecting your computer by the service tag or the model, download the latest version of the chipset driver restart the computer and download the latest version of Ricoh driver as well, restart your computer again. 

     

    PD: download both drivers at the same time but make sure you install the chipset drivers first then the Ricoh.

  • I found the card reader on the device manager and navigated my way through "updating" it.  It worked when I inserted my sd card to I'm thinking the problem is now fixed.  Thank you!
  • You found it? What is it called? I'm having a similar problem with my new Inspiron 1525, where the SD card I'm inserting is not reacting with the computer at all. What exactly did you do?

  • Hiya, yes, I am also having the same problem. Inspiron 1525, SD card reader does not detect card and I can't find the hardware anywhere on the computer, tried addressing the issue as suggested above, the Ricoh driver I understand, but you mention a chipset driver which I coudln't find at all at the drivers site, I entered the service tag and also looked at the drivers for all 1525's, nothing that seemed relevant for this hardware, can you give further details? It seems like the hardware is just not connected to the motherboard at all... I phoned Dell as Warranty has run out, they were no use at all as all they wanted was money to issue 2 year warranty and wouldn't help otherwise, after 15 mins on the phone... Have even got a torch out to look inside the slot, but nothing looks out of place. Does anyone have any ideas how to proceed?

  • Here's the answer!  Took me a min and a lot of searching- open device manager and open "Disk Drives" right click "SD Memory Card"  / properties - under the "Policies" tab check the setting for "QUICK REMOVAL" . . . close all open windows and reboot. . . after reboot re-check to make sure the policy  setting is still set to "Quick Removal" ... I also changed the driver on the "SD Host Adapters"  manually to the Ricoh driver - this may help ya... good luck!

  • oh.. one other thing - once you do this DO NOT use the "safe removal" method - its not necessary anymore - just remove the card -  if you use "safe removal" you will need to reboot for the sd reader to read again... Peace...!