Battery not charging on Latitude D610 - General Hardware - Laptop - Dell Community

Battery not charging on Latitude D610


Laptop computer Forums (Audio, General Hardware, Video)

Battery not charging on Latitude D610

  • I have two batteries for my laptop they no longer charge in the laptop.  I have it plugged into the AC Adapter, but the battery charge light no longer comes on.  The batteries both work, but they are both nearly discharged.


    Any ideas as to why the charging is not happening?

  • First thing to try is a new adapter - if it doesn't charge either battery, then you've a faulty power jack or faulty mainboard.


  • I have the exact same problem on my D610 and it just started a few days ago.


    I noticed it because I use a docking station when my notebook is at home.  When the computer is docked I don't like to have the battery in because the system will stay cooler without it, however when I'm about to undock the computer I'll slide the battery in, undock it and be on my way.  Just a couple days ago I slid the battery in to undock it like always (I've been doing it this way for over a year) and the whole system locked up.  So I shut the system down and tried it again.  The same thing happened and now I've noticed the battery won't charge.  It says the battery is at 70 percent but the system claims to be on AC power without charging.  It's as if it doesn't know the battery is not fully charged. 

    I'm pretty sure this is a software problem somehow as opposed to an adapter problem because the battery doesn't charge on the docking station or simply plugged into the AC adapter.

  • If the system won't charge with the notebook undocked and powered off, it's a hardware fault -- since it sounds like it won't charge in or out of the dock, most likely it's a problem with the mainboard, but if it's out of warranty, it may be worth trying a new power supply first.  At $35 or so, it's a fraction of what a mainboard will cost.


  • The battery will charge when the system is powered off both on the dock and off.  The battery will not charge when the system is on.
  • The battery will charge if the system is on, but it's takes some time.


    Dell Latitude D620, Intel Core 2 Duo T7600 2.33GHz, 4GB RAM, 250GB Seagate Momentus 5400.4 HDD, 64MB Nvidia Quadro NVS 110M, Intel PRO/Wireless 3945 ABG, DVD±RW, Windows Vista Ultimate w/ SP1

  • What wattage is your power supply?
  • It's the defult 90w power supply that comes with the D610. 


    I did some looking around on the Dell site and found some possible solutions for my problem and I'm going to try those out and see if they work.  I'll let you all know what I find out.

  • I have a Vostro 1500 with the same problem.  Did you get any resolution to your problem?
  • Both batteries will charge when the laptop is in the docking station, but not when attached to the adapter.  I borrowed a co-workers adapter and his did not work either.  So what is the next step?
  • Anyone have a solution for this problem?  I have bought a new adapter and a new battery - still have a problem. 

  • This is the replacement part you need:




  • I have the same problem (battery not charging in laptop) on a D610 which has a 1400x1050 screen.

    Before I buy a new motherboard, I have a couple of old 1024x768 D610s in full working order: can I swap one of their motherboards, and will they support the hi-res screen. Or do I need to buy a motherboard with specific support for the hi-res screen?

  • i had the same battery issue but it has no concerns with battery or battery charger Smile but the battery driver might be faulty so all you need to do is to open CONTROL PANEL,then click on SYSTEM AND SECURITY,then under SYSTEM heading you would find DEVICE MANAGER option click on it and then double click on BATTERIES,then some options will appear which will include an option containing the words AC ADAPTER,then right click on it and click the option of DISABLE and restart the computer and follow the whole method again but now instead of DISABLE a word of ENABLE will appear click on it and the problem is solved but if still the problem is not solve so then right click on the AC ADAPTER and uninstall that driver and then reinstall it this will solve the problem.WISH YOU GOOD LUCK Cool

  • i tried both things u suggested and neither worked....what do i do... i needd to be able to get my battery to charge