Dell Latitude X300 Bluetooth problem

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Dell Latitude X300 Bluetooth problem

  • I have just been given a Latitude X300 from my brother.

    So first thing i did, update the bios to the latest version A10. 

    Then i reformatted it and install fresh XP Pro.

     

    Now, while i'm installing the bluetooth driver, it asked me to press Fn+F2 which is to turn the bluetooth on.

    When i press Fn+F2, the bluetooth isn't turned on, but wifi. 

    So i couldn't install the driver. So i ran windows update and it picked up my bluetooth and install the driver.

    When i go to Device Manager, i can see my bluetooth icon with an exclaimation mark on it. Went to properties, it says that the device failed to start.

     

    I'm lost at the moment.

     

    I really need bluetooth to connect it to my phone.

     

    Any help? 

  • Check the BIOS to see if Buetooth is enabled. Fn+F2 is for WiFi, not Bluetooth.

    [View:http://i133.photobucket.com/albums/q74/robin24k/cv_sig.jpg]

     

    Dell Latitude D620, Intel Core 2 Duo T7600 2.33GHz, 4GB RAM, 250GB Seagate Momentus 5400.4 HDD, 64MB Nvidia Quadro NVS 110M, Intel PRO/Wireless 3945 ABG, DVD±RW, Windows Vista Ultimate w/ SP1

  • there's no bluetooth option in the bios...

     

    Where is it? 

  • It should be in the Wireless category. You may have to dig around a bit though as I'm not sure where it actually is.

    [View:http://i133.photobucket.com/albums/q74/robin24k/cv_sig.jpg]

     

    Dell Latitude D620, Intel Core 2 Duo T7600 2.33GHz, 4GB RAM, 250GB Seagate Momentus 5400.4 HDD, 64MB Nvidia Quadro NVS 110M, Intel PRO/Wireless 3945 ABG, DVD±RW, Windows Vista Ultimate w/ SP1

  • i have looked on every pages in the bios, and i couldn't find anything on bluetooth ..???
  • Never mind, the X300's BIOS is probably different and I don't know the specifics.

     

    Is the Bluetooth LED on?

    [View:http://i133.photobucket.com/albums/q74/robin24k/cv_sig.jpg]

     

    Dell Latitude D620, Intel Core 2 Duo T7600 2.33GHz, 4GB RAM, 250GB Seagate Momentus 5400.4 HDD, 64MB Nvidia Quadro NVS 110M, Intel PRO/Wireless 3945 ABG, DVD±RW, Windows Vista Ultimate w/ SP1

  • No. but everytime i turn on the laptop, you can see the BT led blink for a sec.

     

    I openned up the laptop, and I saw the bluetooth module there, no loose cable.

     

    any other idea?

  • Maybe someone with an X300 can chime in and be more specific, but there should be somewhere that you can enable/disable the Bluetooth card.

    [View:http://i133.photobucket.com/albums/q74/robin24k/cv_sig.jpg]

     

    Dell Latitude D620, Intel Core 2 Duo T7600 2.33GHz, 4GB RAM, 250GB Seagate Momentus 5400.4 HDD, 64MB Nvidia Quadro NVS 110M, Intel PRO/Wireless 3945 ABG, DVD±RW, Windows Vista Ultimate w/ SP1

  • anyone please?