Apoint.exe Failed to load lanucher dll - General Hardware - Laptop - Dell Community

Apoint.exe Failed to load lanucher dll


Laptop computer Forums (Audio, General Hardware, Video)

Apoint.exe Failed to load lanucher dll

  • I just started getting this error message yesterday on startup.  I have not installed anything new on the laptop.  I have an Inspiron 1720.  Yes, the error message is spelled "lanucher" instead of launcher, and there isn't a period between that word, and the "dll".  After I receive this error message the Alps or Dell Touchpad icon closes in the system tray and I lose the ability to scroll up/down and left/right with the touchpad.  I've tried upgrading the BIOS to A07, and I also updated the driver for the touchpad.


    Can anyone help me with this?





  • I don't know if I can help, but I can confirm the same problem popping up around the same time as your post.


    I have spent a bit of time with Dell Tech Support but they have not been able to identify any cause or solution. I left off with them saying that there is a possibility that there is some spyware present, but they are not able to find it. 


    They are recommending that I reinstall windows.


    I notice that a number of folks have hit this message. Do others have this issue and have you found solutions short of reinstalling windows?

  • I am having the same problem as of today. On start-up I get a tiny window, the top bar reads "Apoint.exe" and the message is "Failed to load lanucher dll"


    Is this just an inoccuous misspelling or evidence of malware? I run and update Ad-aware frequently, as well as Symantec Corporate edition and the McAfee Security Center junk Dell put on here.


    Do I need to update a touchpad driver or something? When I attemped to do just that, the option to update the driver was greyed out. :(


    Also, in the Control Panel, the first icon is a picture of a little blank page with a corner folded over (default icon?). Is this related?


    Inspiron 1420

    Windows Vista Home Premium


    Please help, someone. Thanks!





  • I know this will sound crazy, but I was looking in one of the system directories exploring Vista....because I just got it for the first time, and I ran across this MP3 file with a weird name...I can not remember it because I immediately and permanently deleted it thinking it was there by accident.


    The very next time I booted up is when I started receiving the Failed to load lanucher dll message and it even though my laptop mouse tablet is working, the scrolling bars on the right and bottom ceased to function.  The mouse buttons are fine.  I have tried to uninstall and reinstall and update the tablet driver for my Inspiron 1720 but nothing has worked.


    Is Dell really using files named *.mp3 as system files, or did I delete some music file that has to be present before the mouse pad driver can work?  I know it sounds crazy, but I swear that is what happened.


    Anyway, I haven't been able to use my scrolling feature for months because of this and can not find a solution anywhere on the internet, so are there only a few of us that have this problem?  ARRRRRGGGHHHH!!!

  • I have the exact same problem.  It started happening in April about the same time as fcprimoy I think.  I get a "Apoint.exe" window with the message "Failed to load lanucher dll" (funning spelling, no period).  If I click the OK button, I lose the touchpad's ability to scroll.  If I just leave the window open (for days at a time sometimes), the touchpad is fine.  It is very annoying and if I accidentaly press enter when the window is focused (i.e. same as OK), I can only get the touchpad scrolling back by restarting the computer to get the Apoint.exe window back.  When it first happened, I tried restoring to an earlier setpoint, but it didn't work.  Since I am not that technical, I didn't want to mess with anything else until there was some recognized solution out there.


    I have been watching this discussion and searching the internet to see if anyone had any solution and have not seen anything yet.  It does seem to be a Dell issue though.  Every mention of this problem I have seen has been on a Dell computer.


    I have:

    Dell Inspiron 1420

    Windows Vista Premium

  • Well I am supposed to know what I am doing as an IT professional myself, and I couldn't get the problem fixed no matter what I tried.  I do know that when I deleted the mysterious MP3 file with the weird name is when the problem began.


    I tried to uninstall and reinstall the original software and driver, and it said it was successful.  I believe I tried the version from Alps and Dell both.


    There has to be an answer.  Thanks for the tip on leaving the window open though.  I hadn't tried that, and i do like to have my scrolling active on the pad.  It has been driving me crazy without it.


    Take care.

  • My girlfriend experienced the same problem on her 1420 and i tried all the things mentioned above with no joy. There is only one thing that resolved the issue for me though.


    Steps taken:


    1: uninstall Alps touchpad driver

    2:open regedit

    3: search for Alps

    4: Delete any entry in the registry with regardds to the Alps pointing devicea and services

    5: reboot

    6: reinstall the latest Alps driver from the Dell site.


    I do not get that anoying popup anymore and the scrols option on my touchpad works fine.


    Hope this helps!!

    Message Edited by Curley72 on 07-22-2008 05:06 PM
  • I am also getting the same message with the same misspelling of lanucher!!  I have noticed that when I am typing, occassionally, my touchpad moves the curser to wherever the mouse is, which appears to be common to others getting the same error message.  I have also reinstalled the driver with no success.


    Thanks for any help from anyone!!

  • I did what Curley72 suggested and I have not had any problems since.


    1: uninstall Alps touchpad driver

    2. Open regedit

    3: search for Alps

    4: Delete any entry in the registry with regardds to the Alps pointing devicea and services

    5: reboot

    6: reinstall the latest Alps driver from the Dell site.


    Good luck...

  • I have never used Regedit--so I am a little hesitant to start deleting things. Could you be more specific as to what to delete. I did a search and did not find anything. Thanks.
  • Hi SupraxM,

    Once you are in Regedit, scrol the left navigation bar to the top and click on 'My Computer'. Once that is highlighted, you can click on 'Edit' on the top and select FIND or jsut press Ctrl+F. Search for Alps. where it highlights Alps, you can delete it safely. Press F3 to search for the next entry. Delete them all and follow the steps i published in this thread.

    I dont like messing about with regedit either but this should not affect your laptop. My girlfriends laptop has been working fine since.

    Do let me know how you get on.

  • Please help. I got this problem also. I got this problem when I got a Blue Screen. I even don't know why I got a blue screen, I have a 3 gb RAM and a 250 HDD and an NVIDIA GeForce. Could anyone tell me why I got such a blue screen and how to avoid it....? Please,....


    Dell People, please help us solve this "Appoint.exe Failed to load lanucher dll" it's so irritating everytime I start up my laptop. Thanks.

  • Sounds like others have worked out a solution - see previous posts on this thread. 


    They showed up with their solution too late, so I had already just done clean install of the OS, without the bloatware sent along by Dell - grrrrrr.  My machine iis running faster and better than ever.




  • I have the same problem using a new Inspirion 1525 which was working fine for past three months since purchase but now have this message and the scroll feature on the touch pad don't work. A HW test shows the HW is working OK but Dell want £39 to speak to their SW dept who said they can help - my laptop is still under warranty and I have extended warranty but this apparently doesn't cover SW issues which a mal functioning touch pad is classed as!


    I am willing to try the regedit approach suggested but have never opened this before. How to you open regedit and how do you exit it in the end?  I have found the latest Alps driver and I'm ready to load it. I can uninstall the Alps driver from the control panel but it is using regedit to remove the other bits of Alps that I am unsure of.


    Is someone able to go over this part of the solution slowly again? Thank you.

  • I've found a solution! All you need is to give "Administrator Permits" to Apoint.exe (try in Program file/DellTPad)...then all that you need is to allow the start-up execution in windows defender (every time for now), but now it works fine for me!Bye bye! ;)