No sound through HDMI connection to TV

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

No sound through HDMI connection to TV

  • I can't get sound through HDMI connection from my XPS M1530 to my TV (Samsung LCD).

     

    Video transfers great but audio still comes through the laptop speakers.

     

    Testing through Control Panel->Sound->HDMI->Properties->Advanced I can hear the sound through the TV speakers, however there is no audio on my TV when playing music, DVD's, videos etc.

     

    The HDMI installed codec is from Sigma Tel.

     

    Help anyone?????

  • thats truly weird... did you try other tv's?
  • have you tried changing your audio output DEFAULT to the HDMI?  if you'll right click on the speaker icon in the startup tray, go to playback devices, and change the output from the headphones/speakers to the HDMI output.

     

    note: you'll need to change it back whenever you're ready to use your headphones!

  • I've experienced similar issues with my M1530.

    I have the blu-ray drive and couldn't wait to watch my first HiDef Bluray movie through my new HDTV (Panasonic Viera)

     

    I struggled with the sound however just as you have stated no sound through the HDMI cable to the TV just sound from the laptopspeakers. I selected HDMI as the default sound source by right-clicking on the speaker icon in the righthand system tray and selecting Playback Devices. You then set HDMI to default. However this is where the buggy Vista drivers start to give you bother. sometimes I get sound through the TV and sometimes I don't. When I don't the workaround is disconnect the HDMI cable at the laptop, let things settle, then re-insert the HDMI cable. This usually cures the problem and its showtime!

     

    Hope this helps.

    Now if only I could get Vista SP1 installed......

     

  • Yes my friend, I have. No joy tough.

     

    However, If you have a look at my reply further down, you'll see what solved the problem.

     

    Thanks for suggesting though.

  • Yes I have, with no joy.

     

    However, changing the output default to HDMI from the sound program in the control panel did the trick.

     

    My God, VISTA is killing me!!!!!!!!!!!!

  • K  ind of late, but if this helps anyone, I'd like to know.  Itworked like a charm for me but I had to learn this on my own.  No help via Dell and absolutely NO HELP from VISTA/Bill Gates.  They're like the government.  They point fingers here there and everywhere, but...

     

    Here's the fix for no sound from laptop to TV via HDMI connection.  It's not a sound, video card problem, not a drive problem AND THERE IS NO EFFECTIVE "PATCH" FOR THIS.  i'VE TRIED THEM ALL...  It's a VISTA problem FIXED BY DOING THE FOLLOWING;HOWEVER, YOU HAVE TO REVERSE THE PROCEDURE EACH TIME YOU WANT SOUND BACK TO YOUR LAPTOP SPEAKERS:

      1. Go to Windows Media Center
      2. Go to tasks
      3. Go to settings
      4. Go to general
      5. Go to Windows Media Center Setup
      6. Go to set up your speakers and click next
      7. Choose Toslink (digital) and click next
      8. Choose two speakers and click next
    1. Here's the fix for no sound from laptop to TV via HDMI connection.  It's not a sound, video card problem AND THERE IS NO EFFECTIVE "PATCH" FOR THIS.  i'VE TRIED THEM ALL...  It's a VISTA problem FIXED BY DOING THE FOLLOWING;HOWEVER, YOU HAVE TO REVERSE THE PROCEDURE EACH TIME YOU WANT SOUND BACK TO YOUR LAPTOP SPEAKERS:
      1. Go to Windows Media Center
      2. Go to tasks
      3. Go to settings
      4. Go to general
      5. Go to Windows Media Center Setup
      6. Go to set up your speakers and click next
      7. Choose Toslink (digital) and click next
      8. Choose two speakers and click next
  • any suggestion for window 7. I am trying to connect to a Samsung HDMI TV from a Dell Studio 1535 laptop and get no audio