Forums

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Touchpad Buttons don't work with USB mouse

  • I have an issue with my new Inspirion 1501 Laptop which I bought as a refurb from the Dell Outlet.

    The touchpad worked fine until I plugged in a USB mouse. The the USB mouse (Logitech) takes over and the mouse works fine,however, the touchpad buttons stop working. I realize there is a setting to disable the touchpad when a mouse is plugged in, but this is unchecked. I am able to move the cursor via the touchpad with the mouse plugged in, but the buttons become non functional. Even after I unplug the mouse, the buttons still do not work, sometimes the left will work, but never the right. This is the second time this has happened. I called tech support the first time and they ended up restoring the computer to the original "as shipped" condition, which of coarse wipes away everything I had installed, but at that point it wasn't much. When it was restored the buttons worked on the touchpad and I have been using it this way for about a week, until I finally tried the mouse again and now I have the same problem. I would hope this is just a software issue, the first time the tech tried to update the driver which did not help. I am running Vista home premium. Any help would be great.

  • did you install the logitech mouse drivers?
  • No. I just plugged the mouse in and it worked.

    I don't have a problem with the mouse, it is the touchpad which has the right button not working.