We've been having a few repeat problems with our Latitude D620 laptops.

First, the system configuration:

Intel Core 2 Duo T7400
1 Gb RAM
60 GB Hard Drive
8X DVD+/-RW

XP Pro, SP2, plus all the latest updates

We've had a problem where 2 of the 7 D620 laptops would lockup when the network cable was connected. It didn't matter if the laptop was running on AC or on batteries. The *second* a network cable was connected to the laptop, it would lock up. Let's call this laptop, Laptop A.

I even let it sit for as long as an hour but nothing on the screen changed - there was no hard drive activity and the mouse was still frozen.

By way of trouble shooting we've:

o Swapped the hard drive with one from a different system and the problem followed the system, so we know it's not a hard drive problem.

o At Dell's suggestion, uninstalled/rebooted/reinstalled the network drivers (although this didn't really make sense since the problem followed the laptop itself and not the hard drive).

o Tried different network cables.
o Tried different ports on our router.

But the problem still followed the notebook.

Dell replaced the motherboard. That worked fine - for 9 days. On the 10th day, the laptop locked up again - same symptoms.

The Dell tech suggested we flash the BIOS to the latest Rev. We did and that seemed to fix the issue.

As a precaution, Dell replaced the motherboard, memory and CPU (the replacement motherboard had the latest BIOS rev on it).

About a month later, the laptop locked up again - same symptoms.

This lockup was somewhat more amusing since it would *always* lockup in the user's second office, but only sometimes in her primary office. More network cable/different port on the router playing - all to no avail.

What also made things more fun was in the process of troubleshooting this, the other laptop (Laptop B) started to do the same thing - locked up when the network cable was connected.

This time, we:
o Swapped the hard drive to different laptops.
o Tried different combinations of power supplies, power cords and Ethernet cables.
o Tried it with the battery plugged in and with the battery removed (and just the AC adapter plugged in). It always failed as soon as the Ethernet cable was connected.

o Dell sent out 2 motherboards and 2 CPUS.

That seemed to settle the problems down for a few months.

o Fast forward to June (6/19). Laptop A had the problem reappear. It'd been working fine since then - it was part of our loaner pool and everytime before it would be lent out, we check the laptop out - windows updates, anti-virus software updates, etc, etc. Once again, as soon as the network cable was connected, it locked up. This was the one that had the motherboard (two times), memory and CPU replaced before.

o Dell replaced the motherboard, memory and CPU. The laptop seemed happy again.

o 9 days later (6/28), Laptop B started acting up - my notes said it was acting "funny" - not doing the lockup but was having other problems.

o On 7/17, Laptop A locked up again when a network cable was connected.

o Dell replaced the motherboard, CPU and memory of Laptop A (again). Dell tech support suggested replacing the laptop entirely - we'd waited about a week for a new laptop to be shipped, but because of a delay in getting the displays, I asked Dell to replace the motherboard, CPU and memory and that we'd swap the laptop out when the replacement arrived.

o By the time the replacement parts arrived, the laptop was fine again - no lockups at all. They replaced the motherboard, memory and CPU anyway. That laptop has been fine since then.

o About 2 months later (8/22), Laptop B (the one that had been acting funny) went funny again. Anything typed on the laptop displayed in uppercase (as if the shift key were stuck on). This happened with the laptop keyboard, PS/2 and USB keyboard. (The laptop originally had a PS/2 keyboard plugged into the docking station). The USB keyboard was tried as a replacement. We also rebooted the laptop several times as well during this process. After about 20 minutes of swapping out keyboards, docking/undocking, rebooting, powering off, removing the AC adapter and battery, the laptop allowed us to type in lowercase again.

Dell offered to replace the motherboard, but since the motherboard had been replaced before they suggested they replace the laptop.

That laptop was a D630 that is also having problems - for that, see my post on the D630 lockups out of the box.

Comments/suggestions/questions?