constant high pitch noise from inspiron 6400/e1505

Laptop

Laptop
Laptop computer Hardware and Software discussion

constant high pitch noise from inspiron 6400/e1505

  • HI, I've had my inspiron 6400 for more than a month and the high pitch noise from the right up corner never dies. Sometimes, it's lower but always audible especially when it's quiet around. I did a research on this forum and some others. I updated the sound card driver, did a clean install but the noise is still there. It's a great laptop in general, but the noise is really bothering me now. I'll try to call Dell and ask for a replacement but I'm not sure if that's possible. Because I've already got an exchanged unit(the current one) for some battery problem. Any input is appreciated. Thanks!

    EDIT: BTW, i don't have a BT module and the noise is not lowered when I unplug the AC adapter.And when I got my headphone in, the noise is really loud in the background when I'm listening to music unless I turn up the volume.

    Message Edited by andy_tok on 03-25-2007 08:37 AM

    Message Edited by andy_tok on 03-25-2007 08:37 AM
  • I had the exact same problem. The second I turned on my 6400 I heard this high-pitched whining noise, way louder then I knew a laptop should be. I couldn't figure out exaclty where it was coming from though. Dell sent me a replacement which was nice and quiet but the screen didn't work. I ended up switching the screens, and in the process had the laptop all opened up and tried to pinpoint the sound. It seems to be from the area where the processor and video card are (I have the NVIDIA 7300 and Core 2 Duo 2.0 GHz). I think the processor and video card are kind of one on top of the other so it was impossible to tell exactly where the sound was coming from, or it could even be from the motherboard. It's no good trying to find the source of the sound when the laptop is still all put together, I found it was just louder wherever there were air vents because that was where the sound could get out the easiest. The only thing I know for sure is that it's not the hard drive and not the screen because I switched both of those and still heard the sound. I could still hear it even without any screen attached. Strangely enough, when there's no hard drive at all (you can still start the comp without one) it doesn't make the high-pitched sound, but the problem isn't the drive itself since it happens with any hard drive. It could be the video card, in that maybe the video card isn't active until the OS starts to boot and you need the HD for that, or something similar with the processor, in that before the OS starts to boot the CPU isn't working very hard then once it gets going at faster speeds it starts making noise. I'm just guessing here, and I wasn't about to try switching the processor or video card, too much work.

    The thing is, this could be a widespread problem, but most people probably wouldn't notice, or just assume this was how it's supposed to be. I've spent lots of time using Dell laptops so I noticed this immediately.

    Since I had only had mine a day they sent a replacement. After 30 days they generally try to repair it not just replace it.

    Message Edited by biznatch11 on 03-25-2007 05:12 PM
  • I think I've managed to track down the cause and stop it from whining!
     
    You will need to get hold of a utility called "RMClock"
     
    If you use the settings as follows, it appears to stop the whine!
     
     
    Under the management tab, the only items to tick are "Alert when CPU termal throttling is activated", and the 2 restore check boxes. I also changed the defaults menu to "CPU-defined default FID/VID"
     
    Under the "Advanced CPU Settings / Processor Tab", all should be ticked apart from "Enable Thermal Monitor 1 and 2"
     
    Under the "Advanced CPU Settings / Platform Tab" remove the tick from "Enable Popup Mode" - this one stops the whine, the others help preserve battery life.
     
    Hope this helps
     
    Tim
  • What exactly is this program doing that stops the noise? Is it slowing down the processor speed? Thanks.
  • I had a similar problem with a high pitched noise on an M1210 that was solved using RMClock (The only command I had to use was 'Run HLT command'). Interestingly I have since partitioned the hard drive and installed a Linux OS on it (Ubuntu 6.10) and I haven't heard the noise at all. This seems to mean its a software issue of some sort.
  • weird, the noise is gone, completely. Don't know why? probably has sth to do with the vista update and graphic card driver update i did today.