Inspiron 600m Laptop- USB Ports not working - General Hardware - Laptop - Dell Community

Inspiron 600m Laptop- USB Ports not working


Laptop computer Forums (Audio, General Hardware, Video)

Inspiron 600m Laptop- USB Ports not working

  • Both ports suddenly stopped working. I had a USB printer plugged in one and a usb mouse plugged into the other. I have done a system restore, reloaded windows, reloaded all drivers, hardware,  and the ports are still not working.
    The device manager shows no problems with the ports, the USB cable lights up showing there is current, however, the printer, mouse and computer are not talking to each other.
    Can the ports be replaced, and how?
    Or, if I were to purchace a docking station, would I still have the same problem with the USB ports? I don't know what else to do.
  • Hi,
    It sounds like a MBD failure, a dock is one way to go. A PCMCIA card may be a cheaper option.
                                                                           Regards Chris
  • My Inspiron 8600 USB's also quit on me. It is dry in my house and there is a lot of static electricity. I am consantly getting shocked around the house. I touched my computer and a huge spark passed, the computer instantly shut down. When I restarted it it said the computer overheated. It booted up and the desktop showed but it was unresponsive. My hard drive had been slowly failing so I replaced it. Everything works but the USB ports. I even tried a PCMCIA adapter but it seems there is barely any power being supplied. The PCMIA works with my EVDO card. Is it a damaged Board? What should I do?
  • Roscoe,
    A dock is worth a look, I would think about a new computer with a long complete care warranty. A new MBD and anti-static mats are another choice.
                                                                               Regards Chris
  • Ordered the docking station. It arrived, hooked it up...USB ports don't work. I am ready to throw this laptop out of the window. I can't tell you how many hours have been spent on this!!!!
  • Can someone from DELL respond to this??? I just purchased the docking station in an effort to use the USB's on the docking station, and, THEY DO NOT WORK ON THE DOCKING STATION EITHER!!! Another $150.00 bucks for something that I cannot use.
    It is awfully odd that this should occur one month outside of warranty.  I cannot print. I cannot use my all in one. I cannot use my mouse.
    Can you help me?
  • Azaidom I found a way to get USB access to my computer. I got a PCMCIA card usb adapter. At first it didn't work. There was not enough power being supplied. It has a port for a DC adapter plug. I had to buy a powered usb hub to get the DC converter plug. I pluged the PCI adapter card in and was able to us the card's USB ports. Now, the computer's ports still didn't work, and the adapter cannot be used if I am away from an outlet, but I can't afford a new laptop right now, and everything else works fine on it.
  • Thanks for your response. From what I can see, there is only 1 slot for a pcmcia card on this machine. I have my Linksys card in that slot for my wireless connection and home network. Is there a way around that?
    I cannot afford another laptop right now either, but I do need to print from this machine.
  • I also have my slot filled with a Sprint Broadband card, so I can't be online and us the USB at the same time. Is your linksys networked with your desktop? I have my printer on my desktop and send things to the printer from my laptop via the wireless network. It's pretty easy to share the printer. I hit print anywhere in the house and it comes out in the other room.
  • I have a similar problem. My 8600 started running very slow, using 100% system resources. I tried the usual checks and contacted Dell for assistance. They said to do a factory restore on the laptop. I did and the computer came back to normal speed. The problem now is the USB ports don't work on the laptop or with the docking station. I contacted Dell again and we went through all the diagnostics. All hardware is fine according to the results. The optical mouse will light up but no device will work in any ports. I did the usb reinstall,etc. The big thing is the USB ports were working fine until I did the factory restore! Dell says I need a system board??
    I may need a board but I don't understand why the factory restore would make the ports inoperable.
  • Hi,
    To test the port, try a USB keyboard, and see if you can move around the BIOS. If so, the port is OK. In Bios the OS does nothing. There may be some system issues, have a look in device manager.
                                                                             Regards Chris
  • Thank you, I'll give that a try.
  • Was there any resolution on this?  I'm having the same problem.
  • I think USB issues can be one of many things. Software, device manager (drivers), or in my case a fried motherboard.
  • I know you're trying to be helpful, but I was actually looking for a solution.  So no. 
    My software hasn't changed, the device drivers haven't been updated, my motherboard isn't fried.  (I should have said all this in my initial question).  I'm including this issue discussion on the following string -- in case anyone has had a similar problem and found a solution.  Or in case someone has a possible solution.

    Message Edited by Uncle_Joe on 01-27-2008 09:51 AM