Latitude D620 touchpad problem


Laptop computer Forums (Audio, General Hardware, Video)

Latitude D620 touchpad problem

  • When last time I turned on the computer I discovered that the touch pad of my Latitude D620 was not longer working (neither the pad itself, nor the buttons).

    I use WIN XP Home in spanish.

    Really I don't know how this could happend, because since the last time I used my computer the only "unusual" action I did was to upgrade via internet the antivirus program that we use in my university (TREND MICRO OfficeScan). And this is done automatically or manually and I never before had faced any problems with this antivirus.

    Any help will be greatly appreciated.

  • if everything works OK with an external mouse and the system is not locked up, do the following.

    You can use the Mouse Properties window to disable the touch pad and track stick or adjust their settings.

    1. Open the Control Panel and click Mouse. For information about the Control Panel, see the Windows Help and Support Center. To access the Help and Support Center, see Windows Help and Support Center.

    2. In the Mouse Properties window:

      • Click the Device Select tab to disable the touch pad and track stick.

      • Click the Pointer tab to adjust touch pad and track stick settings.

    3. Click OK to save the settings and close the window.
    Regards, Latitude 6430u, Venue 8 Pro
  • I have recently been provided a Dell Latitude D620.  The mouse options are PS2 compatible (generic) and therefore I can not disable the touch pad. 
    I've tried installing several of the mouse applications, none have worked.  Please suggest a way to disable the taps functionality of the touch pad (it is disrupting my typing!)
  • Have you installed this driver  file  R113813
    Input: Alps GlidePoint/StickPointer, Driver, Windows 2000, Windows XP, Multi Language, Multi System, v., A10
     Adds the feature where the touchpad/stick is disabled when a USB mouse is plugged in. This feature is disabled by default but can be enabled via a checkbox on the Devices tab in the Touchpad. When a USB mouse is plugged in a pop up message informs the user that a USB mouse has been detected and that the touchpad/stick has been disabled. A red 'X' appears over the touchpad icon in the systray when it is disabled.
    Regards, Latitude 6430u, Venue 8 Pro
  • Thank you.  I installed, rebooted and had the icon in the system tray. 
    I tried downloading a few different applications with the same name (different number) and it didn't work yesterday.  Good to know I was headed in the right direction :)
    Thanks again,
  • Yeah, those others are all for external devices. The Alp touch pad and stick are the only intgegrated utilities. You may also want to update your Dell Quick Set Utility, improved location profiles, wireless and power management etc. etc. Lastest version is 8.1.0. Right click on the icon in the system tray and select 'about' to see which version you have.  
    Regards, Latitude 6430u, Venue 8 Pro
  • can help me with my mouse.... I couldn't control it . it moves by itself, when I wanna click on something moves allover the place and I have to try several times to click the spot i want. can you help how to fix this problem?