Inspiron 4150. a/c adapter light flashes when connected to it.

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Inspiron 4150. a/c adapter light flashes when connected to it.

  • Hi,

    I have a 4150 that works perfectly with a battery.

    But when you insert the a/c adapter in the unit the adapter light flashes at a slow rate and the laptop does not power at all and the battery does not charge. Needless to say neither the unit power on led nor the HD or the battery one lights up.

    I dissasembled the unit to check the power jack (the female receptacle) but it does not seem to be loose or broken.

    Anybody with a similar problem?
    Am I out of luck? Any suggestions?

    thanks in adv
    al
  • I have the same issure with the Inspiron 1150.  I have also taken it apart, and checked all of the connection on the mobo.  The ONLY difference is that the lights do not flash at all.  (except for briefly once when you first connect the AC adapter. )  I will be interested to see if you receive a solution.
  • OK, I'll give this a try.  You need to isolate this to: (A) bad AC adapter, (B) bad battery, or (C) bad laptop.  I assume you don't have 2nd battery or AC adapter to try.  There are "protection" circuits built into these items to prevent thermal/current overloads which may be shutting things down.

    Step 1: Disconnect everything from everything, including AC adapter from wall plug and wait a few minutes.

    Step 2: Connect just the AC adapter to the wall plug (do not connect to laptop).  Verify that the green light in the AC adapter is on.

    Step 3: Remove battery from laptop. Plug AC adapter into laptop.  Does the laptop boot and run??  If NOT, is the green light still lit on the A/C adapter??  If laptop boots and runs, this implies that laptop and adapter are OK (almost).  If laptop doesn't boot and AC adapters green lit is off, then it could be either item.  The laptop may be overloading the AC adapter (which shuts off) or the AC adapter may be bad, BUT since the laptop runs on battery alone, try another AC adapter first.

    Step 4: Remove AC adapter from laptop and install your battery,  Does laptop boot and run??  Does power meter recognize battery and give charge level??  If NOT, suspect battery first and laptop 2nd, especially if Step 3 was successful....  If laptop works with battery, power laptop off.

    Step 5: Disconnect AC adapter from wall and connect to laptop, but keep laptop powered off.  Plug AC adapter into wall and verify still have green light on AC adapter.  If green light is off, AC adapter has shut down due to excessive load from battery/laptop or maybe adapter is going bad and is unable to supply sufficient current.  If Step 3 was successful (i.e. you can run laptop on AC adapter without battery installed, suspect a bad battery pack).  Remember, just because a battery supplies power to a laptop doesn't mean its cells aren't going bad and overloading the AC adapter.

    Step 6: With AC/Battery/Laptop all connected, BUT laptop turned off, verify that charging light on laptop is on.  It may flash as the battery reaches a full charge.  Once fully charged (hours), the light should go off.  Does the battery fully charge???

    Step 7: If battery fully charges, try turning on the laptop and see if it boots... If so, I suspect that your AC adpater is unable to simultaneously charge the battery and power the laptop without a thermal/over-current shutdown (AC adapter shuts down and green light on adapter is OFF).

    Hope this helps and good luck....

    Edit: Not sure about Dell, but batteries are good for 300 to 500 charge cycles... How old is your battery??  If you do a lot of off AC Adpater work, followed by recharge, etc. you may have reached end-of-life on battery.  If you have to shot-gun, try battery first (if you're wrong, you have a useful spare battery), AC adapter second (spare AC adapter is sometimes handy), and laptop last (spare motherboard is $$$$).

     

    Message Edited by wraujr on 04-14-200610:47 AM

  • Thanks for the help wraujr!! 

     

    When the ac adapter is plugged in, the light on the adapter is green, and remains on.  (no flashing, fading, etc).  When I plug it into the computer, (whether or not the battery is in it), the 3 lights on the front of the laptop will flash (quick on, and then off), then nothing.  Wiggling the adapter makes no difference.

    I have tried a 2nd adapter, and received the same results.  The laptop recognizes the battery, and that is what I had been using up to this point.

    I am at the conclusion that this is a motherboard issue.  I have googled this problem, and I am not alone in this problem.  It almost seems like it is a fault with Dell.  There first suggestion is to replace the motherboard.  However, it is cheaper now-a-days to just by a new computer. 

    After all of the advice that I received, I have decided to sell off the pieces.  It's easier than re-building it from scrach.  (See my ebay auction... haha)

  • After posting, I was reading more posts and yes it seems as if there is a problem with some motherboards developing bad connections/solder joints on a certain integrated circuit.  See this link:
    Before scaping, you might try printing out these posts (including pictures and diagrams) and then take your laptop to an electronics/TV/computer repair house.  If supplied with all the details you might find a competent technician who can re-solder the bad connections for less than $100.  If you do the legwork it sounds like less than 1.0 hour to re-solder/re-assemble laptop.  Finding a competent tech to works on these "micro" parts will be the biggest challenge......
  • My laptop works with the AC adapter pluggin in.  The battery chargeing light does not come on.  The battery is fully discharged with 0% power and does not charge.
    Is the battery bad?  How do I check?  If the battery is bad, what is the partnumber that I will need to puchase.
    Thank you.