I have hit a complete block, trying to enable the wireles card on my Dell D610.
I can't even appear to enable the wireless card, let alone go to the next step of searching for available wireless networks or connecting.
Below, I list all the relevant configuration statuses.
 
 
 
In Device Manager, I can see that under Network Adaptors I have 'Intel(R) PRO/Wireless 2915ABG Network Connection' (as well as 'Broadcom NetXtreme 57xx Gigabit Controller' which I use successfully to conect to a network through a wired connection.)
I believe I have the latest driver (v. 9.0.2.31 dated 19/07/2005), and it says that the 'device is working properly'.
 
In Network Connections, I have selected 'enable' for the Wireless Network Connection - but the status reads 'Wireless Connection unavailable'.
 
I have an icon for 'Intel PROSet/Wireless on the task bar, but the only options that are not greyed out are 'Open Intel PROSet/Wireless' and 'Enable Radio'.  There is a tick next to 'Enable Radio'. 
Clicking on 'Enable Radio' causes a message window appear stating 'The Intel PRO/Wireless Network Connection is still disabled.  Press Fn+F2 to enable it.'  But pressing Fn+F2 has no effect on anything.  (The Disable Radio option is greyed out.)
 
I next click on the option 'Open Intel PROSet/Wireless'.
At the top of the new window it states 'Wireless is turned off.Select 'Enable Radio' below to enable wireless networking'.
However, the drop down in this window already shows 'Enable Radio' with a tick next to it - the Disable Radio option is greyed out, so it is not possible to select anything else.
If I hover my mouse over the 'Enable Radio' box, a pop-up states 'Wireless is off'.
 
So........it looks like the wireless is off!
But....there appears no way of turning it on!
Wherever there is a choice to 'Enable Radio' or 'Disable Radio', the Enable Radio option has already been selected, and it is impossible to select the Disable Radio option as it is greyed out.
How on earth can I get the wireless card enabled....?
Please can someone advice?

Cheers,
Don