Forums

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

WiFi is not working

  • I have posted this problem on the Network forum but unable to get much response. Hopefully, I have better luck here since this forum has more visitors.
    My D410 has been working with my wireless router for months without problem. In the last couple days, for some unknown reason, the WiFi light is no longer on and I cannot connect to my wireless network.
    I checked the wireless card properties in Device Manager, it shows "This device is working properly.". And when I right-clicked on the Wireless Network Connection, it showed it has been enabled. So WiFi should be working, but it is not. The WiFi light on the laptop is not on.
    The traditional fn-F2 key combination does not work here. Because for the D410, this combination is for the bluetooth only. There is nothing on the keyboard that is for WiFi.
    And something is very strange. On the Wireless Network Connection Properties page, under the Wireless Network tab, the "Use Windows to configure my wireless network settings" option is unchecked. If I check it and click "OK" to save and exit out. Then when I go back to this page, the option is back to unchecked. Why??? If I check the "Use Windows to configure my wireless network settings" option, I can see all available wireless network. I just cannot connect because there is no WiFi.
    I downloaded the user guide and service manual from Dell web site. And they are all useless.
    By the way, my other computers are all working properly with my wireless router. So the problem is on my Latitude. The Latitide is supposed to be a better computer but it does not appear to be. Last week, I have to replace the keyboard and this week, I have the WiFi problem.
    Has anyone seen this problem before? Please help as I am pulling my hair on this problem.
  • Is the socket for the wireless card broken and the card is not in the slot?

    Report Unresolved Customer Service Issues here
    I do not work for Dell. I too am a user.
    The forum is primarily user to user, with Dell employees moderating.

  • Thanks for the response. Can you tell me how to check that?
     
    Correct me if I am wrong, but I thought for the D410, the wireless card is a firmware and not using the PCMCIA slot. I checked around the laptop and there is no other slot except the one for PCMCIA which is currently empty.
     
    Last week, Dell has to replace my keyboard. It is entirely possible that they broke something during the replacement process.
     
    If you can tell me how to physically check the wireless card on the D410 model, I will appreciate that very much.
     
    Thanks.
     
  • http://support.dell.com/support/edocs/systems/latd410/

    http://support.dell.com/support/edocs/systems/latd410/sm/blue0.htm#wp1006343

    http://support.dell.com/support/edocs/systems/latd410/sm/minipci0.htm#wp1000001

    Report Unresolved Customer Service Issues here
    I do not work for Dell. I too am a user.
    The forum is primarily user to user, with Dell employees moderating.

  • I have had this same problem (or similar) for the past few days, except no hardwar changes have been made.  Did you get it working?