Ethernet doesn't work on C/Port II - General Hardware - Laptop - Dell Community

Ethernet doesn't work on C/Port II


Laptop computer Forums (Audio, General Hardware, Video)

Ethernet doesn't work on C/Port II

  • Ok, here is my situation guys.

    My user has a Latitude C500 and a docking station. Out of the blue, one day her ethernet was down when she came in and docked her station.

    So, first I check the bios and make sure it is enabled. It is.

    Second, I check the connection under network connections to make sure it is enabled, and it is.

    Third, I plug it into the ethernet port directly on the laptop. Works fine. So, I am thinking the port on the station went out.

    Finally, I switch out the docking station to and plug it into the ethernet port. It still wouldn't work. So, both docking stations didn't work.

    Everything seems to be fine, but still no connection. Could there be an issue with the hardware part of the laptop that connects between the station and the laptop? Any help would be appreciated.
  • I'm having a similar problem where a new C/Port II dock won't pass the Internet connection through to my C400. The cable connects just fine when plugged into the C400 directly, but not when it's plugged into the port, and then I dock the C400. Interestingly, the Audio is not passed through either. Beeps still come out of the computer instead of the monitor (where the audio cable came from).

    Bummer. I was hoping Docks passed everything through, but apparently ethernet and audio aren't working...

    I'll update this if I figure out why.


    PS: Already running BIOS A12... :)
  • More follow up on the Ethernet issue:

    1) With a cat 5 cable that works when directly connected, the doc connector's "green" light is on solid, but I never get orange activity light (like I do when directly connected).

    2) With a retractable cable that works when directly connected, the doc connector's green and orange lights "flash" together permanently. Just about a second on then off then repeat indefinitely.

    What I'm doing now to work around the problem is using the retractable cable to connect to the built-in connector before docking (it bends the connection a little, but it does fit.

    I'd really appreciate it if somebody from Dell would tell me what the green/orange flashing pair means on the dock connector. I've spent quite a bit of time searching for diagnostics and manuals on the Dock, and there is NOTHING out there. Is there a "hardware test" we can run on the dock (the audio is apparently not taking data from the notebook either, as all sound is currently coming out of the built in speaker).

    TIA, Steve
  • Hello.
    Using: Dell Latitude C600 + C/Port II + Win XP

    Having the "same" problem: ethernet cable connected on docking station + green & orange led and... nothing.

    Went further by enabeling the "docking ethernet" BIOS option ( restart + F2 ). I see the green + orange led. + XP "sees" the ethernet cable connection on the docking station.

    I have some I/O trafic on the connection (I see packets comming in and out) but can not "use" it like with a ping or http.

    I played with TCP/IP : IP address, gateway address, DNS, network mask... Not sucessfully. I do not understand whether I should/could/must/must not use/set up DHCP. I have the feeling that should be DHCP.

    I noticed the network card "Fast Ethernet 3Com 3C920" is set on the same IRQ than the embeded "3Com Mini PCI Ethernet Adapter". Am not sure that's a trouble. Loads of shared IRQ on the system.

    I noticed that this card 3Com 3C920 has a "network address" set to "value" "absent". I modified it to partial network address xxx.yyy.zzz, full address xxx.yyy.zzz.www . No sucess. Tha same here: what should/could/must/must not be done ?

    Some help will be appreciated.

  • Hello, again.

    I got it working. More details on my config. I am using a home high speed connection (as opposed to enterprise network). The connection going through laptop ethernet socket is DHCP configured.

    After quite a few random exploration, a long unsuccessfull internet browse here are my last findings.

    My solution :
    The docking ethernet connection is handled by a network card "Fast Ethernet 3Com 3C920". One has to specify IP details for the connection using this card.

    Start > Network connections > right clic, properties of "local network connection ... Fast Ethernet 3Com 3C920" > tab "general" > Internet protocol TCP/IP > Properties

    * In tab "General" :
    - leave the "get IP address automatically" checked
    - leave the "get DNS server address automatically" checked
    * In tab "secondary configuration" (or similar stuff)
    - check the "user specified" radio
    - and fill IP address, network mask, default gateway, main DNS and other DNS. ( Get those details with a command "ipconfig /all" in a console, when connected on the laptop ethernet socket).

    This works now for me on both sockets.