No bootable devices - General Hardware - Laptop - Dell Community

No bootable devices


Laptop computer Forums (Audio, General Hardware, Video)

No bootable devices

  • Hey,
    Someone else used my inspiron 510m and now when i turn it on i get "loading PBR for descriptor 2...failed." When I press a few random keys I get "No bootable devices--strike F1 to retry boot, F2 for setup utility"
    I havn't got a clue what to do, and I'm useless with computers.
    Please help somebody!
  • Is your hard drive seen in BIOS?

    If it is then you will have to try fixing it by booting off your XP CD, going into the restore console and trying to commands fixboot and/or fixmbr.
  • I've given that a go, and it says "CARDBUS NIC boot failed"
    then it goes on to say "PXE-E61: Media test failure, check cable" amongst other stuff which doesn't look so bad
    then we're back to "No bootable devices....etc"
  • It sounds like he may have disabled your bootable drives in BIOS on Page 2. The Boot Order can be modified to move drives around, but it is also possible to disable them; they then willl not work no matter where they are in the Boot Order. On my I8200, you enable and disable them by highlighting them and then using the space bar. The Instructions for your model should be in the right column after highlighting the drive; your owner's manual only says it is possible , not specifically how to do it.
  • No, they're all enabled.

    This is getting frustrating!

    Thanks for your suggestions though, any more ideas?

  • You did not say if your BIOS is actually seeing your hard drive. You will find this information on page one of your BIOS where it will tell you the capacity of the hard drive.
  • All I can see concerning the hard drive is "Primary Hard Drive: 40 GB"

  • 177rich177 wrote:
    All I can see concerning the hard drive is "Primary Hard Drive: 40 GB"

    That's good!

    I suggest that you try using the fixboot and/or fixmbr command from the restore console.
  • How do I do that???
    Sorry I'm no good with computers at all, I need it spelling out, nice and slow lol.
    Thanks a lot anyway.
  • Does your model come with a floppy drive?
  • My dad's sorted it, and the hard drive is nackered apparently. Its a warantee issue. Thanks a lot though
  • I have a Inspiron 2200 and I am having the same problem you are. When i called they told me to take my battery out for 10 seconds but u really have to leave it out for 20 minutes or so. That worked for me. Also, when it says "No Bootable devices etc...", try and hold down ctrl, alt and del. That worked for me a couple of times to. If none of that work, u will have to send away for a new hard drive and they will have to send someone out to your home to install it, or they will talk you through it on your phone. I hope some of that helps.
  • I tried to turn on my Inspiron 6000 this morning and I got the "No bootable devices, Press F1, yada yada yada" error. I have no clue why! I'm the only one who uses it and I haven't downloaded anything in the past few weeks, actually. I've just been using to check email and MySpace. Anyway, I turned it off and on a few times, hoping it would somehow reset and fix itself but no go. So I pressed F2 like it suggested but I did't know what was doing so I just exited. I don't know what made me think of it, but I flipped the whole thing over and took out my battery. I put it back in (the same battery) and sure enough, the darn thing booted up without a problem. What's really weird is that I haven't touched my battery since I put it in (when Dell sent me a new one b/c my old one was defective). Any idea what happened and why taking out the battery seemed to remedy it? Thanks! Sincerely, Aerogodess
  • I am having the same problem that started with my inspiron 9200 just continually rebooting.  I changed the hard drive thinking I could then just load windows back on but now I am getting the no bootable devices. I try to make it load off the cd drive, nothing but a steady green flashing light on the cd drive.  I was thinking the cd drive was not working so I went and got an external cd drive thinking I could load windows from there but it is not getting recognized as beeing there. 
    Totally lost and confused.  Is there any hope for me or my laptop?
  • The fixmbr and fixboot worked for me TY