Dell Latitude C600 - Battery Module 75UYF not charging - General Hardware - Laptop - Dell Community

Dell Latitude C600 - Battery Module 75UYF not charging


Laptop computer Forums (Audio, General Hardware, Video)

Dell Latitude C600 - Battery Module 75UYF not charging

  • I recently found that the battery on my Latitiude C600 is not charging while the AC adaptor is connected to the laptop. I used the 75UYF battery until it was down to 4%, then plugged in the AC adaptor but the power level never increased after several hours.  Thinking the battery was bad, I used another fully charged 75UYF until the power went down to 67% power. I then attempted to charge the battery overnight (8 hours) but unfortunately the power level only increased to 68%. I left the same charging until I came home from work, and the level showed only 70% power.  
    Is there some sort of setting that I need to check or alternative way of charging the battery?  If it is the motherboard causing problems, are there external chargers available for this type of battery? Thanks for your time and trouble.
  • Maybe the AC adaptor is dead.  Can you run the notebook direct from the AC adaptor without the batteries?

    If this works I suspect you're looking at a failed charger module.  I forget whether this is on the motherboard or a daughter-card, but its somewhere inside the case.  If you want to investigate this further you should find the maintenance manual on the Dell site, probably under Downloads or Support but they often need a determined search.  Spares probably available from PartsPeople - or try ebay if you like the risk of getting a dud.

  • Yes, the laptop works fine with AC adaptor attached, but its just not charging the battery. I tried charging in both modular bays with no luck. I will check the maintenance manual provided to see about the charger module. If replacing parts becomes cost prohibited,I found an eBayer that sells external battery chargers that can charge the 75UYF.
  • Hi,

    You will need a motherboard, as the charger is built in. Also, be aware there are many different part numbers, and not all work with all CPU's fitted. Make sure the part number is the same, or be certain it will work.

                                                                          Regards Chris

  • I wound up purchasing an external battery charger that solved the problem.